VideoHelp Forum

Try DVDFab Video Downloader and rip Netflix video! Or Try DVDFab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 7 of 7

Threaded View

  1. Member
    Join Date
    Oct 2006
    United States
    Search Comp PM
    I'm getting the Inconsistent Timecodes! SCR<>GOP error. If I encode for 10 minutes, it says SCR=12:12:00 & GOP=12:11:59. If I encode for 20 minutes, it's SCR=12:20:00 & GOP is 12:19:58. I have an encoder card in my pc that creates the MPG files using the Main Concept MPEG Encoder. The video plays & converts to DVD fine (as far as I can tell). I tried running pvas on the file & it's okay there, too. Is this a false error? Or can you tell me what setting I can change in my converter to fix this problem? Thanks very much for any suggestions you have!
    Quote Quote  
  2. Hi rain, welcome on board!

    If it's working ok, then it is more or less a false error...

    encode for 10 minutes, it says SCR=12:12:00 & GOP=12:11:59.
    is really strange. First of all the timecode should start at 00:00:00, but ok. But 10 minutes should result in anything like: XX:10:00.

    Some questions:
    Are you using the mpeg files directly (without demux)?
    If you run the file through pvas, which duration is shown there?
    If you use the elementary files after demux with pvas, which duration is then shown in GfD?
    Which version of GfD are you using
    Have the files NTSC (29.97 fps) or PAL (25 fps) standard?

    BTW: I have never heard about an encoder card (hardware) which uses the Main Concept MPEG Encoder (3rd party software) for 'on the fly' encoding...
    Quote Quote  
  3. Member
    Join Date
    Oct 2006
    United States
    Search Comp PM
    1) Oops, you are correct on my timecode error. It's SCR=12:10:00, GOP=12:09:59. sorry

    2) yes, mpeg file directly w/o demux. I can demux my output, but the software will only create an mpg video file (even elementary). I tried using that, but couldn't associate the audio file with an elementary mpg file in GFD. Duration shown in GFD using the muxed file = 00:10:00.06

    4) PVAS scan info:
    Found 1 video stream.
    Found 1 MPEG audio stream.

    VIDEO #1
    Resolution 720 x 480
    Aspect ratio is 4:3
    Frame rate 29.97 fps
    Nominal bitrate 8000000 bps
    First PTS: 00:00:00.213

    MPEG1, Layer 2
    stereo, sampled at 48.0 kHz.
    Bitrate 224 kbps
    Each frame contains 24.0 ms audio (672 bytes)
    First PTS: 00:00:00.213

    Input: D:\test_dvd35.mpg
    Closing starting GOP.
    Aiming for sync at 00:00:00.213
    Streamstart seems to be in (reasonable) sync:
    Video 1 starts at 00:00:00.213
    Audio 1 starts at 00:00:00.213

    Last fileset:
    464787178 total bytes written
    Video 1: 17891 frames, 00:09:56.963
    Audio 1: 24991 frames, 00:09:59.784

    Sync estimate at EOF:
    MPEG Audio #1 : sync

    Video statistics
    GOP length (min/avg/max):
    3 / 13 / 15 [frames]
    64388 / 348610 / 482344 [Bytes]
    GOP bitrate (min/avg/max):
    3193 / 6020 / 8895 [kbps]

    5) using mpv / mpa demuxed from pvas, GFD duration = 00:09:55.77

    6) GFD version 1.04

    7) NTSC (29.97 fps)

    8) I have a DRC-500 pc card from Digital-Rapids. It's their low-end encoder card.

    Quote Quote  
  4. Ok.
    1. If the files without demux work, I would just use them and ignore the error (SCR<->GOP)

    2. ...but couldn't associate the audio file with an elementary mpg file in GFD
    If it is an elementary file, you should name it either .m2v or mpv. The extension mpg is considered as multiplexed file.

    3. As you can see in the output from pvas, the durations are different (audio is longer than video). Probably the SCR is even a tick longer than both. That's the reason for the 'error'. As the differences are very small, you can probably ignore them completely (even ChapEditGFD should work properly with them).

    4. NTSC is more 'critical' to such errors than PAL, that's due to the factorial framerate (and the resulting 'drop-frame' - 'non drop frame' timecodes)
    Quote Quote  
  5. Member
    Join Date
    Oct 2006
    United States
    Search Comp PM
    Great, thanks. I have tried changing a lot of the hardware and advanced encoder settings, but don't know which one would fix this. If you have any suggestions to point me in the right direction, please let me know. Thanks for all your help!
    Quote Quote  
  6. As I don't know your hardware and encoder, I can't help you with these settings...
    IMHO you have the following choices:
    Either you will have to find out a working setting yourself (maybe someone else with the same equipment could help you), or accept the error just as 'false' error, or demultiplex your mpg with pvas or projectx (or another demultiplexer) and use the elementary streams in GfD.
    Quote Quote  
  7. Member
    Join Date
    Oct 2006
    United States
    Search Comp PM
    ok, thanks again!
    Quote Quote  

Similar Threads