VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 20 of 20
Thread
  1. Hi,

    I have a new computer (yeah!) that has Windows Pro X64 (boo!). I've used IFO files in AutoGK to create backups of my DVDs for a couple of years on my old computer. When VirtualDub in AutoGK gets to "video compression," I receive this error message:

    The source image format is not acceptable. (error code -2)
    What does VirtualDub/AutoGK need so that it will continue to run the compressibility test and complete the conversion to .avi?

    Hart
    Quote Quote  
  2. You usually see that error when the frame has been resized to dimensions that are illegal for the compression codec. For example, resizing a 720x480 DVD video to 639x480 will give that error with Xvid because Xvid doesn't allow odd frame widths (or heights).
    Quote Quote  
  3. I chose DivX and the dimensions are set by AutoGK automatically . . . I can't change those settings.
    Quote Quote  
  4. The 32 bit Divx requires the width be a multiple of 4 and the height be a multiple of 2. I don't know it has different requirements on 64 bit Windows.
    Quote Quote  
  5. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date
    Aug 2000
    Location
    Sweden
    Search Comp PM
    http://www.google.com/search?hl=sv&client=firefox-a&rls=org.mozilla%3Aen-US%3Aofficial...S%C3%B6k&meta=

    # If VdubMod fails to encode the first pass with "videosourceavi error: the sourceimage format is not acceptable. (error code -2)" you may have to make a manual change in your Windows registry. See TelemachusMH's comment in http://forum.doom9.org/showthread.php?s=&threadid=51906.

    but it might be something else for winxp 64...
    Quote Quote  
  6. With AutoGK, variables can't be changed as with GordianKnot. The only settings that can be changed is the .avi output to either Xvid or DivX and the size of the file, which I have always left at the default setting.

    I didn't think that X64 would impact on programs that have all X32 files. I use AutoGK X32, VirtualDub X32, VirtualDubMod X32, DivX X32, XviD X32, X32 codecs, etc.

    I'm looking into reinstalling Windows X32 and keeping X64 at the same time. X64 isn't compatible with most software and hardware yet.
    Quote Quote  
  7. The info that seemed to have helped was:

    It sounds to me that you don't have a YV12 vfw interface. If you install Xvid or Divx 5 you will have the interface. However, that may not fix it. Try setting this registry key:


    Code:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\VIDC.YV12Change the value there to "xvid.dll" or "divx.dll".

    TelemachusMH
    I'm not used to working with registry keys. Is he/she saying that I need to change

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\VIDC.YV12 to either

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\xvid.dll

    or

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32\divx.dll?

    or am I wrong to think that it's the last part of the string that needs to be changed?
    Quote Quote  
  8. Double click on vidc.yv12 and use the dialog that pops up to enter divx.dll or xvid.dll:

    Quote Quote  
  9. I changed the registry key but AutoGK still can't compress the IFO file.
    Quote Quote  
  10. I've been working on finding a way to get AutoGK work since yesterday. Today, I decided to download some more codecs but I didn't want the program to be "confused" with too many. I did a lot of looking around the net to see what codecs and codec packs were available. I didn't want a codec pack to install another copy of something I already had. I already had Gordian Knot Rip Pack so I decided to download K-Lite Codec Pack 2.85 Standard. Since K-Lite has AC3 filter and ffdshow, I uninstalled those 2 program and installed K-Lite. I also changed the registry setting that was shown in an earlier post. Maybe the combo did the trick because AutoGK works fine again.

    It looks like I don't need an X64 version of TMPGenc.

    I hope this helps someone else.
    Quote Quote  
  11. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    I would be careful recommending any codec packs, especially k-lite, as a solution to anything. You may well find many other things are broken because of it. Also, when troubleshooting, it is good practice to make one change at a time to isolate what the resolution was, instead of taking a scatter gun approach and hoping for the best.

    It's great you have resolved your problem, don't get me wrong, but be careful recommending a solution when you don't know exactly what the solution was.
    Read my blog here.
    Quote Quote  
  12. I should say that AutoGK can only compress into Xvid, not DivX. I changed the registery setting vidc.yv12 to DivX because I like DivX better than Xvid, so I went back into the registry to change it to Xvid, hoping that Auto GK can convert to Divx. The registry value is no longer there.
    Quote Quote  
  13. I changed the registry value yesterday with no negative impact on my computer.

    I added K-Lite today and AutoGK started compressing files in XviD format.

    I didn't go willy-nilly, changing or installing registry values or codec packs. I can no longer find vidc.yv12 in my registry but I can uninstall K-lite. I've used it in my old pc and it never caused a problem. I didn't recommend anything to anyone. I just reported on my progress to get AutoGk to compress files, albeit Xvid.

    I'm still looking for a way to get AutoGK to compress using DivX. If you can come up with the answer to that, I'd be very happy.
    Quote Quote  
  14. I seem to recall there is a problem with AutoGK and some recent versions of Divx. You should try a 5.x version instead of 6.x.
    Quote Quote  
  15. Hi jagabo . . . that did the trick. I downloaded and installed DivX 5.x and now auto GK can compress files.

    If would be nice if programs weren't so picky.

    Much thanks to all of you
    Quote Quote  
  16. Member
    Join Date
    Mar 2007
    Location
    United States
    Search Comp PM
    I have installed AutoGk 2.27 or 2.4 having the video compression error The source image format is not acceptable. (error code -2) in DivX format. I installed latest DivX 6.5. any suggestion to fix this.
    Quote Quote  
  17. Read the post just above yours. Install "DivX 5.x" (not 5.5 or 5.6 but 5.x. It's the one that solved the problem for me.

    Hart
    Quote Quote  
  18. Member
    Join Date
    Mar 2007
    Location
    United States
    Search Comp PM
    Originally Posted by HartsVideo
    Thanks. I download divx521.exe and it works fine.
    Quote Quote  
  19. I kept getting a "failed to set data for vidc.yv12" message when starting autoGK in xp, and the program refused to work at all. I eventually managed to sort it by uninstalling autoGK and reinstalling it with a different folder name, although i wish i knew why it happened in the first place.. very odd. This was one of the few places that popped up when I did a google search for some related help. I thought id add a reply as my own solution may well work if anyone else has the same issue.
    Quote Quote  



Similar Threads