VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. Member
    Join Date
    Apr 2001
    Location
    United States
    Search Comp PM


    What I am trying to do, is play some anime AVI's which are widescreen (around 700px X 360px). I have a 16:10 aspect ratio monitor which I normally like, but not in this case.

    No matter what player I use... Zoom player. BS player, Windows Media, Winamp video player, Power DVD... all AVI files will only play in a 4:3 box in the center of the screen, no matter what I do!

    DVD's play widescreen just fine in many of these same programs, only AVI files just refuse to play widescreen...

    With BS player, I can somewhat fake it using the "Pan and Scan" feature, zooming in until the width matches my monitor. But then, my 4:3 AVI's are cut off on the top and bottom.

    With Zoom player (which I thought was a godsend until now), I seemingly can't get the right settings. No matter what boxes I check off under "Aspect Ratio", it doesn't let me simply zoom in and out on the native resolution. It flat out refuses to properly play a widescreen AVI without black bars on the top and bottom... and the left and right!

    I know for certain that the AVI's are widescreen, as I can open them in "Total Video Player" (which I refuse to use, because it's clunky) and it will simply show the native resolution on the screen, and blow it up to fill my widescreen properly, too. I just don't want to think this is my only solution...

    Basically, my question is... is there any way to NATIVELY open a widescreen AVI file, and have fullscreen work properly? Without being confined into a 4:3 box in the center of my screen?

    I simply want to be able to play widescreen AVI's at widescreen, and full screen AVI's as 4:3 ratio - just as I would with my normal DVD's.

    Thanks in advance for any help...
    Quote Quote  
  2. Member
    Join Date
    Apr 2001
    Location
    United States
    Search Comp PM
    Oh, good lord....

    Seems like Murphy's Law has attacked me again, but this time it worked out well. I decided to post this in case others might have the same issue.

    The culprit was ffdShow.

    Specifically, it was the "subtitles" plugin. For some reason, in the Subtitles window, "Letterbox 4:3" was checked off. I don't know if it defaults to this, or if I checked it inadvertently at some point.

    It basically assumed every video MIGHT have subtitles attached to it, therefore it resized every movie to 4:3 to display the subs at the bottom of that 4:3 window.

    Sorry for the mess, folks.
    Quote Quote  
  3. Member j4gg3rr's Avatar
    Join Date
    Nov 2005
    Location
    Australia
    Search Comp PM
    I guess it's time you ditched all those playes and started using the No 1 player this side of the moon.
    Media Player Classic.
    Combined with ffdshow, nothing comes close.
    Hint: Play with the numpad keys after you install MPC.
    Quote Quote  
  4. Member j4gg3rr's Avatar
    Join Date
    Nov 2005
    Location
    Australia
    Search Comp PM
    I use MPC's own filter for subs.
    But by default ffdshow displays the subs always on the bottom of the pitcure, never under it with borders at any aspect.
    Stretch the window virtically and the subs won't move under the pitcure into the border.

    Where as by default, MPC's internal filter displays the subs relative to it's own window resizing.
    Stretch the window virtically to make borders and the subs will move under the picture as you stretch.

    Remember these are default behaviours, both filters can be made to do the opposite of each other.
    Quote Quote  
  5. Member
    Join Date
    May 2007
    Location
    United States
    Search Comp PM
    I'm having the exact same problem, however, the ffdshow options appear to have no effect whatsoever on the videos I'm trying to play. Any other help or clues to what the problem could be? It's a definite aspect ratio problem with my wide screen monitor, the sides, top, and bottom, of the movies appear to be cut off.
    Quote Quote  
  6. Member
    Join Date
    May 2007
    Location
    United States
    Search Comp PM
    Alright, they did have some effect, but they're still not allowing me to see the entire picture. I got it so it displays the top and bottom of the picture ok, but it's still editing off the left and right part of the picture. Any help? Is there an alternative to ffdshow?
    Quote Quote  
  7. Member
    Join Date
    May 2007
    Location
    United States
    Search Comp PM
    I got it! It was in the borders setting, it acted like a video zoom, grr, it was almost hidden, I can't believe more people don't have this problem. Oh well, good luck all, hope I helped anyone in the future having this problem. You helped me track it down, so thanks a lot!
    Quote Quote  



Similar Threads