VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. Member
    Join Date
    Jan 2007
    Location
    Canada
    Search Comp PM
    Hey forum folks!

    I'm stuck. I've been having a bit of a burning issue (video, data, isos, anything). My drive used to work fine (burned 4gb in 6 min), but about 2 weeks ago it started taking a long time to burn (usually 45 min for 4 gb of data). Nero, ImgBurn, CDBurnerXP, every program I use is having the same problem. The burn always succeeds, but always takes a long time. Nero says "6 min remaining", but it still takes forever. I've uninstalled & reinstalled Nero with no luck. I've heard that people have had this type of problem with Nero InCD, so I disabled that, with no luck.

    I'm running an HP system, my drive is TSSTcorp cd/dvdw ts-h652l (16x +- RW), with plenty of HD space, RAM, & dual amd64 processors. My system is running perfectly otherwise, and it used to work just fine, so I can't seem to figure out what the problem is.

    Please, ANY help would be appreciated.



    Here's my last ImgBurn log file, if it's any help to anyone:
    //****************************************\\
    ; ImgBurn Version 2.1.0.0 - Log
    ; Friday, 12 January 2007, 19:51:29
    ; \\****************************************//
    ;
    ;
    I 19:03:09 ImgBurn Version 2.1.0.0 started!
    I 19:03:09 Microsoft Windows XP Media Center Edition (5.1, Build 2600 : Service Pack 2)
    W 19:03:09 Drive D:\ (FAT32) does not support single files > 4 GB
    I 19:03:09 Initialising SPTI...
    I 19:03:09 Searching for SCSI / ATAPI devices...
    I 19:03:09 Found 5 DVD-ROMs and 1 DVD±RW/RAM!
    I 19:03:50 Operation Started!
    I 19:03:50 Source File: C:\Documents and Settings\HP_Administrator\My Documents\Downloads\Psychonauts\Psychonauts\Psycho nauts.iso
    I 19:03:50 Source File Sectors: 2,020,096 (MODE1/2048)
    I 19:03:50 Source File Size: 4,137,156,608 bytes
    I 19:03:50 Source File File System(s): ISO9660
    I 19:03:50 Destination Device: [0:0:0] TSSTcorp CD/DVDW TS-H652L 0603 (E (ATA)
    I 19:03:50 Destination Media Type: DVD+R (Disc ID: YUDEN000-T02-00) (Speeds: 4x, 6x, 8x)
    I 19:03:50 Destination Media Sectors: 2,295,104
    I 19:03:50 Write Mode: DVD
    I 19:03:50 Write Type: DAO
    I 19:03:50 Write Speed: MAX
    I 19:03:50 Link Size: Auto
    I 19:03:50 Test Mode: No
    I 19:03:50 BURN-Proof: Enabled
    I 19:03:51 Filling Buffer...
    I 19:03:51 Writing LeadIn...
    I 19:04:07 Writing Image...
    I 19:50:34 Synchronising Cache...
    I 19:50:40 Closing Track...
    I 19:50:43 Finalising Disc...
    I 19:50:59 Image MD5: b6db6ee49f27842d3ebe8fb09a6a2636
    I 19:50:59 Operation Successfully Completed! - Duration: 00:47:08
    I 19:50:59 Average Write Rate: 1,450 KB/s (1.0x) - Maximum Write Rate: 2,182 KB/s (1.6x)
    I 19:51:29 Close Request Acknowledged
    I 19:51:29 Closing Down...
    I 19:51:29 Shutting down SPTI...
    I 19:51:29 ImgBurn closed!
    It says "maximum write rate: 1.6x", which is weird concidering my drive is 16x & my media is 8x, no?
    Quote Quote  
  2. Mod Neophyte Super Moderator redwudz's Avatar
    Join Date
    Sep 2002
    Location
    USA
    Search Comp PM
    I don't see it in the log, but that sounds like the writer is in PIO Mode. Easy enough to check:

    To check DMA/PIO mode within Windows:

    Control Panel>System>Hardware>Device Manager>IDE ATA/ATAPI controllers.

    From there, right click on one of the channels and choose 'Properties>Advanced Settings'. All drives should be DMA mode. The 'Current Transfer Mode' for Hard drives is usually DMA 4-6 and DVD burners DMA 2-4, DVD ROMs usually DMA 2. If you see any in PIO mode, that can slow things down.

    Changing them back may be easy or complicated. First see if you can change them in that window. If not, I usually uninstall the channel the drive is on and let the OS reinstall it. This will usually take a reboot. This will not damage any files on the computer.

    From there, if no luck, get back to us.
    Quote Quote  
  3. Member
    Join Date
    Jan 2007
    Location
    Canada
    Search Comp PM
    Thanks for the quick feedback redwudz. The writer wasn't in PIO mode. I checked the IDE ATA/ATAPI controllers in the device manager. There were 3 of each type (3 primary, 3 secondary, 3 dual), and dma was selected in the primary & secondary ones. I removed all 9 anyways for good measure, rebooted, it reinstalled the drivers, rebooted again, tried a data DVD burn, and it worked perfectly. So thanks again!

    Now you've got me curious. So what are those IDE controllers anyways? How did they get screwed up? Did removing & reinstalling them reset them to default settings or something?
    Quote Quote  
  4. Mod Neophyte Super Moderator redwudz's Avatar
    Join Date
    Sep 2002
    Location
    USA
    Search Comp PM
    Here's a little longer explanation I found. Sorry, it is long. I couldn't find a link for it:



    DMA reverts to PIO
    The stuttering DVD drive
    General description

    DMA is an abbreviation for Direct Memory Access, an access method for external
    devices where the data transfer is not done by the central processor, but by a
    small special processor called DMA controller. It uses a procedure called cycle
    stealing, where the central processor memory access cycles are delayed for very
    short times to intersperse DMA controller memory access cycles. Some newer,
    faster DMA modes are called UDMA (Ultra DMA).
    The alternative, slow and inefficient data transfer mode is called PIO,
    Programmed Input-Output, where the central processor transfers data byte for
    byte or word for word. This requires many processor commands for each data word
    and therefore causes a high and unwanted processor load.
    Possible causes for falling back to PIO mode
    The most frequent use why a CD or DVD port falls back to PIO mode is a scratched
    or otherwise unreadable CD or DVD.
    However, there are a few reasons why a computer may use PIO instead of DMA,
    particularly when it's the hard disk port that falls back, not a CD/DVD drive
    port. For example, David Duberman reported in 2005 that some Dell computers have
    DMA disabled in their BIOS by default for the second hard disk. So it is a good
    idea to check the BIOS settings first.
    Other reasons can show up in the event log, so check this first and see if you
    can find repeated Atapi errors recorded. If so, you likely have a hardware
    defect. You can use the procedure described below, but your computer will
    probably fall back to PIO mode again and again, until you solve the underlying
    problem, which may be located inside the device, on the motherboard, or in the
    IDE data cable and its connectors.
    The trap
    Windows contains a trap in which quite a few computers seem to get caught sooner
    or later. The trap was described in a Web article whose link no longer works
    (and also in another one mentioned below):
    The crucial paragraphs are:
    PIO mode is enabled by default in the following situations:
    ...
    For repeated DMA errors. Windows XP will turn off DMA mode for a device after
    encountering certain errors during data transfer operations. If more that six
    DMA transfer timeouts occur, Windows will turn off DMA and use only PIO mode
    on that device.
    In this case, the user cannot turn on DMA for this device. The only option for
    the user who wants to enable DMA mode is to uninstall and reinstall the
    device.
    Windows XP downgrades the Ultra DMA transfer mode after receiving more than
    six CRC errors. Whenever possible, the operating system will step down one
    UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).
    ...
    Of course, drive firmware being quite complex and certainly containing
    programming defects of its own, it is not all that difficult to produce such
    errors. In my case a scratched DVD and later also an unreadable (overburned) CD
    did the trick, got the drive to choke and Windows to disable DMA for good. Later
    my hard disk hiccupped just once and also went back to PIO for good.
    I had been using my laptop for DVD viewing for years, until I inserted a
    borrowed and heavily scratched DVD. The player and apparently even the DVD drive
    choked on it, and when I finally got the DVD to play, I found that playing was
    jerky and processor load was 100%, roughly half of which was system overhead.
    This indicated that the drive had reverted from the usual UDMA (Ultra Direct
    Memory Access) mode 2 to PIO (Programmed Input Output) mode. No amount of
    resetting or changing the relevant registry parameters from 1 (try DMA) to 2
    (force DMA) helped. Stubbornly the drive kept using PIO mode, and Windows even
    changed these settings back to 0 (use PIO only).
    The following text will refer to the secondary IDE port because that is more
    often affected, but essentially the same also holds for the primary IDE port, to
    which the main hard disk is connected in most computers.
    Before you begin to work on the problem, log on as Administrator or as a user
    with administrator rights.
    Check Your IDE Port Mode
    First check what mode your secondary IDE port is currently working in. Go to
    Device Manager: right-click on My Computer, select Properties, click on the
    Hardware tag, click on the Device Manager button, click on the plus sign to the
    left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel,
    click on Extended Settings and check whether it is set to DMA when available.
    Directly underneath that setting is a grey field that shows the actual working
    mode of your IDE channel. You want the highest possible DMA or Ultra DMA mode
    there, and you definitely don't want PIO mode.
    Normally you don't have to use the registry editor for this, because the normal
    settings are also available through the properties dialog for the IDE port, but
    if you want to look at it anyway, the parameter for the secondary IDE port can
    be found through regedit.exe at
    HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\Scsi\Scsi Port 1
    It is named Scsi only for historic reasons. Scsi Port 0 is the primary IDE port,
    to which presumably your hard disk is connected.
    After trying various remedies—in vain—I found the abovementioned article and
    went to work again. I uninstalled the DVD drive in Device Manager and rebooted,
    but that did not help either.
    So I searched for more and better information, then I went on and did the
    following.
    Re-enable DMA using the Registry Editor
    My thanks go to my fellow MVP Alexander Grigoriev who taught me this method.
    Run REGEDIT. Go to the following key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}
    It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE
    channel, 0002 the secondary, but other numbers can occur under certain
    circumstances. You have to go through these subkeys and check the DriverDesc
    value until you find the proper IDE channel.
    Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the
    device in question is attached as master or slave, but it can't actually hurt to
    delete both. Reboot. The drive DMA capabilities will be redetected.
    Open Device Manager again and check whether the device is now actually using DMA
    mode. If so, congratulations, you've made it (at least until the next time
    Windows disables DMA).
    2005-10-24 – Tomáš Souček wrote, if this doesn't work, check also the dword
    value MasterDeviceTimingModeAllowed, whose default value is hex 0xFFFFFFFF. If
    you have a much smaller value, you can try to set it back to its default and
    reboot for a test.
    Alternative Method—Uninstalling the Port
    1. Uninstall the secondary IDE port
    To do that, open Device Manager as follows. Right-click on My Computer, select
    Properties, click on the Hardware tag, click on the Device Manager button, click
    on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on
    Secondary IDE Channel, click on Uninstall. Deactivating is not enough.
    Reboot to make the changes active and permanent.
    After booting Windows will automatically reinstall the IDE channel and the DVD
    (or CD) drive. This Plug-n-Play process can take a little while, so give it a
    minute after the boot process finishes.
    2. Reactivate DMA
    But this is not enough, because unfortunately Windows does not automatically
    activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA
    first.
    For that, go to Device Manager again. Right-click on My Computer, select
    Properties, click on the Hardware tag, click on the Device Manager button, click
    on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the
    secondary IDE channel, click on Extended Settings and change the relevant
    setting from PIO only to DMA when available.
    On Windows NT and 2000 you now have to reboot a second time, but Windows XP
    applies the change instantly. Then you can go to the same place in Device
    Manager again and check whether the device is now actually using DMA mode. If
    so, all is well.
    3. Driver is not intended for this platform
    If you keep getting the following error message:
    There is a problem installing this hardware.
    IDE channel
    An error occurred during the installation of the device. Driver is not
    intended for this platform.
    2005-03-30 – Johannes B. wrote: The reason for this error is often that Daemon
    Tools or Alcohol 120% are installed. In this case the solution described below
    would not work. But when you uninstall these programs and then restart Windows,
    it will then install the device drivers without any further problems.
    If these programs are not installed, then one possible way out is to rename
    C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to
    something like atapi.old.
    If that's not possible, you can try it from the repair console (boot from the
    Windows install CD and select the repair console).
    If Windows always automatically recreates atapi.sys, you can try renaming it in
    safe mode or from a command line window or you can try to rename or remove it in
    the driver cache as well.
    Desensitize Your Computer's IDE Channels
    There's a bit more to it. The following article offers a way to reduce the
    incidence of this problem, although it still doesn't solve it altogether.
    IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
    http://support.microsoft.com/kb/817472/
    Do read this article because it contains a useful long-term workaround. But you
    have to go through the procedure described here to re-enable DMA first. Assuming
    you've done that, insert the ResetErrorCountersOnSuccess registry values
    mentioned in this article into both the primary and the secondary IDE port
    registry keys as described.
    Unfortunately this is only a half solution, because when you enter an unreadable
    DVD, you will get 6 errors in a row, and the IDE channel will revert to PIO
    mode, but at least when you pull out the DVD in time and then insert a good one,
    the error counter will be reset and it will at least be a bit more difficult for
    Windows to hobble your IDE drive.
    Quote Quote  
  5. Member
    Join Date
    Jan 2007
    Location
    Canada
    Search Comp PM
    Well I certainly learned alot. Hopefully this thread will help others with the same issue. Thanks again for your info!

    Take care.
    Quote Quote  
  6. I had the exact same problem...

    I followed your advice... and...

    (1) Created a Recovery Restore Point (just in case)...

    (2) Deleted the Driver for the drive (inside Control Panel>System>Hardware>Device Manager>IDE ATA/ATAPI controllers>Primary IDE Channel>Properties>Drive>Uninstall...

    (3) Rebooted.

    It automatically reinstalled the driver and now it's in DMA mode and writes FAST to the DVD-R drive again...

    THANK YOU !

    (Don't ever delete this thread!!)
    Quote Quote  
  7. Mod Neophyte Super Moderator redwudz's Avatar
    Join Date
    Sep 2002
    Location
    USA
    Search Comp PM
    Glad it worked for you. But remember you aren't deleting the channel, just uninstalling it with the uninstall command, though I don't think you can actually delete it. But I wouldn't want to find out.

    I don't know if Vista has this same Windows 'feature' as reverting to PIO, but it would be a nice thing to eliminate from the OS. Or at least let it reset itself automatically with a reboot.
    Quote Quote  



Similar Threads