VideoHelp Forum


Try D·V·D Fab Video Downloader and rip Netflix video! Or Try D·V·D Fab and copy Blu-rays! or rip iTunes movies!
+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. Member
    Join Date
    Dec 2006
    Location
    Venezuela
    Search Comp PM
    Hi all!

    I'm trying to convert FLV videos to AVI (or any other format which allows me to use Quicktime). It doesn't work all the time (I rather should say it seldom works). When I drop the file to the main window, and play it with the mp player inside ffmpegX, it works (meaning the FLV file is OK... this happens with all FLV files I try). But then, 95% of the encodings I try, fail (encoding finishes immediately, and resulting file is zero KBs). Reading the forum I noticed one clue: I tried to change the audio settings to "invert mapping" to see any improvement, but it's the same: no success. Oh, the FLV are taken from Youtube, I forgot to mention that (I don't think it matters anyway).

    I have an iMac OS 10.4.8, 2GHz, 512MB RAM, 250MB, if that's useful for you. Please any help will be extremely welcome: I'm starting to drive crazy with this , I've been almost two days tryng to make it work. Apart from that, I must say the soft is cooool, I use it a lot

    Thanks everyone!!

    PS: By the way, after the encoding finishes straight away, the "i" icon display this next message, in case it is inspiring for any of you

    Encoding started on Sun Dec 17 19:25:30 VET 2006
    MEncoder dev-CVS-060307-04:23-4.0.1 (C) 2000-2006 MPlayer Team
    FIXME:Hardenabling SSE and SSE2 without detection
    Mac OSX static build for ffmpegX
    CPU: Intel (Family: 6, Stepping: 8)
    CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    success: format: 0 data: 0x0 - 0x1571f38
    libavformat file format detected.
    VIDEO: [FLV1] 320x239 0bpp 29.970 fps 0.0 kbps ( 0.0 kbyte/s)
    [V] filefmt:35 fourcc:0x31564C46 size:320x239 fps:29.97 ftime:=0.0334
    ================================================== ====
    Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
    AUDIO: 22050 Hz, 2 ch, s16le, 80.0 kbit/11.34% (ratio: 10000->88200)
    Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
    ================================================== ====
    Opening video filter: [expand osd=1]
    Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
    Opening video filter: [scale w=320 h=239]
    ================================================== ====
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffflv] vfm: ffmpeg (FFmpeg Flash video)
    ================================================== ====
    Forcing output fourcc to 58564944 [DIVX]
    MP3 audio selected
    VDec: vo config request - 320 x 239 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is undefined - no prescaling applied.
    Quote Quote  
  2. Explorer Case's Avatar
    Join Date
    Feb 2004
    Location
    Middle Earth
    Search Comp PM
    The video size seems to be 320x239, which may not be valid values for many codecs, as many require 16x16 macroblocks.
    Try setting your target video size to 320x240.
    Quote Quote  
  3. Member
    Join Date
    Dec 2006
    Location
    Venezuela
    Search Comp PM
    Thanks very much for the fast answer, but it doesn't seem to work. I set the target to 320x240 but no success neither. I ignore the logic of the software, but I also tried to encode either video or either audio, to see if the problem was in video OR in audio, but it didn't work in none of those attempts (one encoding only video, the other encoding only audio).

    The log is exactly the same as before, except of course for line 19, which said Opening video filter: [scale w=320 h=239] and now says Opening video filter: [scale w=320 h=240] .

    I also tried this with and without the inverse mapping for audio, with no difference. Any clue?

    Thanks again!!!!
    Quote Quote  
  4. Member
    Join Date
    Dec 2006
    Location
    United States
    Search Comp PM
    I am having the EXACT same problem..... When you hit encode, using any preset or custom setting, the Progress window comes up in less than a second and says it is completed. However, when you locate the file is is 0 KB.

    I have no light to shed on this issue.... I guess misery loves company!
    Quote Quote  
  5. Member
    Join Date
    Jan 2007
    Location
    United Kingdom
    Search Comp PM
    Same problem with me as well. Any solution so far?
    Quote Quote  
  6. Member
    Join Date
    Jan 2007
    Location
    United States
    Search Comp PM
    These problems mirror mine on OS 10.4.8 exactly. Any answers anyone? Thanks
    Quote Quote  
  7. Member
    Join Date
    Feb 2007
    Location
    United States
    Search Comp PM
    I have exactly the same problem. If someone could help solve this, you'd be helping many people. Thanks
    Quote Quote  
  8. Member
    Join Date
    Feb 2007
    Location
    United States
    Search Comp PM
    Hi all, I've just been messing around with this, and had the same problem. I was able to fix the problem by changing the scaling method in options to bilinear, rather than fast bilinear. Hope that helps!
    Quote Quote  
  9. Member
    Join Date
    Apr 2006
    Location
    Singapore
    Search Comp PM
    Originally Posted by Momo
    Hi all, I've just been messing around with this, and had the same problem. I was able to fix the problem by changing the scaling method in options to bilinear, rather than fast bilinear. Hope that helps!
    I had exactly the same problem as outlined by topic starter, and without changing the resolution from 320x239 to 320x240 but merely changing the scaling method immediately produced a valid .avi file. Interestingly the .avi has a resolution of 320x240!

    Thanks momo for the tip!
    Quote Quote  
  10. Member
    Join Date
    Feb 2007
    Location
    United States
    Search Comp PM
    Hi again, I just wanted to add another comment for people struggling with converting flv to avi, usually from off of youtube. I found a great program called iSquint that will convert the flv files to mp4, without the messing up the audio to video syncing. You might want to check it out...
    Quote Quote  
  11. Member
    Join Date
    Mar 2007
    Location
    United States
    Search Comp PM
    I wish I would of seen this earlier! I just posted a topic having problems converting .mov files to .FLV files, I'm going to try the suggested method also because mine finished encoding right away, finished .FLV file is 0KB.

    I hope this works, I'm at work now so its a PC, can't test this out till I get home later.
    Quote Quote  
  12. Member
    Join Date
    Apr 2006
    Location
    Singapore
    Search Comp PM
    I just found an alternative method.

    QuickTime will play a .flv fiile if you have Perian installed.

    Your QuickTime Pro will then be able to export to any supported format.
    Quote Quote  
  13. Member
    Join Date
    Mar 2007
    Location
    United States
    Search Comp PM
    I was still not able to get a MOV file to convert to an .FLV file. Has anyone else experienced this problem?

    I'm downloading Perian now! My mac is not intel based, so I'm not sure if this will work for my G4 but we'll see.
    Quote Quote  
  14. Member
    Join Date
    Apr 2007
    Location
    Switzerland
    Search Comp PM
    I HAD the same problem... and I discovered what was wrong

    1) My hard-disk's name was MCINTOSH HD. There is a space and ffmpegx doesn't like it. I changed the name to MCINTOSHHD.

    2) When converting unsuccessfully (0 kb) from/to flv files in the (i) information text you can read "Codec type mismatch for mapping #0.0 - #0.0@
    In that case: in the audio tab, choose "invert mapping"

    Quote:
    "See, normally video comes before audio in the layout and organization of a multimedia file. Sometimes though (and it’s happening more frequently), codec creators are switching things up for a bit of fun. They’re putting the audio first. I can only assume it’s somehow related to compression - but this switch causes ffmpegX to freak out and cease encoding. Luckily, this is a one check-box fix. Simply open your file and navigate to the audio tab. Then check the box titled “Invert Mapping”. This will let ffmpegX know about the alternate structure of your file, and make the appropriate changes".

    Now the conversion WORKS.
    Quote Quote  



Similar Threads