VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 16 of 16
Thread
  1. In a previous post in response to a question of mine, someone said that there was an audio offset function under the Source Range menu. Now where exactly is that in TPMGenc. I am using version 12 and have looked a lot for it. I may just be missing something, is it named something else?

    Only if ATI could JUST save in MPEG, instead of .mp2 when doing MPEG2 capture!!!

    Steve
    Quote Quote  
  2. Member
    Join Date
    Feb 2001
    Location
    Sweden
    Search Comp PM
    You know can load the mp2 file into winamp and then make a diskwrite output to wave, right?


    Thanx/
    Lars
    Quote Quote  
  3. Member
    Join Date
    Apr 2001
    Location
    United States
    Search Comp PM
    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR size=1 color=black></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>You know can load the mp2 file into winamp and then make a diskwrite output to wave, right?</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR size=1 color=black></TD></TR></TABLE>

    I discovered this... this a WONDERFUL solution!

    What I do with my Radeon captures for MPEG-2:

    I open up the .mp2 video in DVD2AVI. This'll make a project file, and demux the audio stream. Great part about it is it will TELL YOU the EXACT delay, in ms. Usually mine come out with -99ms.

    Then run it though the "Diskwriter" Plugin on Winamp. Works FAST FAST FAST. Now open the WAV file in TMPGEnc as the audio source (it will still have the same delay).

    Now, under "Settings", find the window with optional checkboxes on it (filters). Select "Source Range". Under this, you can select your 'IN' and 'OUT' frames, and right in the middle you can set the audio offset in ms. So for my example that shows -99ms, you would type in "99ms" to bring it back in synch.

    Any questions, let me know.
    Quote Quote  
  4. Okay, I think I found it, you say the middle one I need to change to 99 when my file has -99 (my file is having -80 but that is besides the point). The 3 settings I have are Volume, Fade in, Fade out. For some reason I don't think those are what I need exactly, but if they are, I just adjust Fade in to 90, and everything should be okay (right now it is default set to 500) ? If not, where should I go exactly? Since I am seeing nothing else similar to this.

    Steve

    <font size=-1>[ This Message was edited by: SluSignGuy on 2001-07-19 08:41:19 ]</font>
    Quote Quote  
  5. Member
    Join Date
    Sep 2000
    Location
    Northern Virginia
    Search Comp PM
    nah, not "Options".

    click on the "Configure" button down at the bottom, then click on the "Advanced" tab and then double click on the "Source Range" filter. audio offset is at the bottom...
    Quote Quote  
  6. Member
    Join Date
    Apr 2001
    Location
    United States
    Search Comp PM
    I'm not sure on 12 (are you using plain BETA, or a versionlike 12a - 12h?) I use 12e personally to make VCD's,

    I let you slightly astray, but this should be right (looking at 12e version now)

    At the bottom of your main screen, next to the profile info, there should be the buttons "Configure", "Load", "Save". Click "Configure".

    The first tab here is for output Video bitrate, size, etc. The next one is "Advanced", and on the bottom of this tab should be a whole list of options. The first should be "Source Range".

    Just make sure if you modify it, that it gets checked when you're done, or it won't apply to your encoded video.
    Quote Quote  
  7. Member
    Join Date
    Apr 2001
    Location
    United States
    Search Comp PM
    I jst double-ed up on hitechjunkie. He's right too.
    Quote Quote  
  8. YES!! I found it, I will give it a go (I just editted my previous message because I found something else) It was labeled Source Frame Range (which was throwing me off). But I will give it a try, I can't right now, but I will. You help has been SO APPRECIATED!

    You rock man!

    Steve
    Quote Quote  
  9. Member
    Join Date
    Sep 2000
    Location
    Northern Virginia
    Search Comp PM
    for anyone that has ALREADY encoded a VCD and has discovered that the audio is out of synch, you can use this neat tool called "MP3 Cutter". just use TMPGEnc to demux the video and audio tracks into separate files, load the audio file into MP3-Cutter and edit accordingly.

    i used MP3-Cutter recently for the second disc of a two disc VCD encode of "Nurse Betty". i encoded the entire movie to one MPEG file and split it but after burning both discs, i discovered that the audio on the second disc was lagging a bit. i demuxed the audio/video, edited the audio, remuxed the new audio with the video and burned it to produce a perfectly synched second disc.

    beats reencoding!!
    Quote Quote  
  10. Member
    Join Date
    Sep 2000
    Location
    Northern Virginia
    Search Comp PM
    don't know if it's already listed in the Tools section, but you can download MP3-Cutter from here...
    Quote Quote  
  11. Okay, I have done everything, I even upgraded my version of TMPGEnc to the lastest version, I think it is h, but I can be mistaken. The sound is still off, but not as far off as it was. The one thing that may be throwing everything off is the mpa file (audio file created from DVD2AVI), it cannot be converted to wav, so I am just using the .mp2 file that I get from TMPGEnc when demultiplexing. Could this throw it off? I doubt it would. But are there any other fixes.

    BTW when Encoding it takes a while, you said it was quick for you.

    Steve
    This project has proved to be a lot more tedious than expected. Does anyone know if there is some capture software that goes DIRECTLY into SVCD format AND it will work with an ATI AIW Radeon.

    BTW thanks to you all for your assistance, I would be no where w/o this site or forum.
    Quote Quote  
  12. Member
    Join Date
    Apr 2001
    Location
    United States
    Search Comp PM
    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR size=1 color=black></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    The one thing that may be throwing everything off is the mpa file (audio file created from DVD2AVI), it cannot be converted to wav, so I am just using the .mp2 file that I get from TMPGEnc when demultiplexing.</BLOCKQUOTE></FONT></TD></TR><TR><TD><HR size=1 color=black></TD></TR></TABLE>

    Just try to open the file with Winamp. It should open and play fine. If not... just change the extension (Command Prompt, ren *.mpa *.mp2)! All it is as an .mp2 audio file, regardless of extension.
    Quote Quote  
  13. Okay, it is still not working this is what I am doing. Tell me if anything is wrong.

    Capture the MPEG-2 Video with my ATI AIW Radeon
    The file saves as .mp2
    I rename the file to .m2p
    Use DVD2AVI
    In DVD2AVI I make 2 files FROM the .m2p file
    One file is a .d2v
    The other is a .mpa
    Rename the .mpa to a .mp2
    I convert the .mp2 to a .wav in WinAmp
    Run TMPGEnc.exe
    In the Boxes at the Bottom of the screen I place my .d2v in the top.
    I put my .wav in the second one.
    I click the setting button
    Go to Advanced
    Double Click Source Range
    I set Audio Gap Correct to 81
    I click OK
    I click start
    (It starts, but it takes like 7 minutes for a 2 minute clip)
    It finishes
    I open the file
    And the Sound is still off, but by not as much

    Where am I going wrong, if I even am?
    Steve
    Quote Quote  
  14. <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR size=1 color=black></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2001-07-19 08:46:21, hitechjunkie wrote:
    for anyone that has ALREADY encoded a VCD and has discovered that the audio is out of synch, you can use this neat tool called "MP3 Cutter". just use TMPGEnc to demux the video and audio tracks into separate files, load the audio file into MP3-Cutter and edit accordingly.

    i used MP3-Cutter recently for the second disc of a two disc VCD encode of "Nurse Betty". i encoded the entire movie to one MPEG file and split it but after burning both discs, i discovered that the audio on the second disc was lagging a bit. i demuxed the audio/video, edited the audio, remuxed the new audio with the video and burned it to produce a perfectly synched second disc.

    beats reencoding!!
    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR size=1 color=black></TD></TR></TABLE>

    How do you measure the delay?
    Quote Quote  
  15. Member
    Join Date
    Sep 2000
    Location
    Northern Virginia
    Search Comp PM
    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR size=1 color=black></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2001-07-19 12:41:44, sunjkl wrote:

    How do you measure the delay?
    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR size=1 color=black></TD></TR></TABLE>

    excellent question!!

    i use TMPGEnc to do the following:

    1) demux the audio/video tracks to separate files
    2) load the audio/video files like you're gonna re-encode
    3) bring up the "source frame range" filter
    4) click on "show audio"
    5) scroll to frames in the movie where there are obvious loud noises (gun shots, doors slamming, explosions)
    6) modify the "audio offset", forward scrolls right to left, until the obvious visual audio blips coincide directly with what is in the video frame (the flash of a gunshot, for example)
    7) watching the audio blips, scroll to other parts of the movie to confirm your offset is accurate
    load the audio track in MP3-Cutter and edit accordingly

    not the best way to do it, but it's worked for me for three different movies/XVCDs...
    Quote Quote  
  16. Member
    Join Date
    Sep 2000
    Location
    Northern Virginia
    Search Comp PM
    just had to use the above procedure again over the weekend. audio levels for this particular movie were on the low side so the audio blips were extremely difficult to see.

    i wound up using a part of the movie where someone screams, which showed up as a stream of wavy blips. after adjusting the offset, turns out the audio was about 460ms behind the video, which is the biggest offset i've seen (the other three movies had audio lagging between 50-150ms). i loaded the mp2 file into MP3-Cutter, cut out just under half a sec, re-multiplexed it with the video and when played back, was in synch again.

    Quote Quote  



Similar Threads