VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Member
    Join Date
    Jun 2006
    Location
    Spain
    Search Comp PM
    Hi all,

    I want to re-encode a video with mencoder (let's say stereo.avi [xvid+mp3]) so that sound becomes mono.

    That's what I do:

    mencoder stereo.avi -ovc copy -oac mp3lame -lameopts cbr:br=128:mode=3 -o mono.avi

    Ok, this doesn't work, this still has 2 channels.

    I've also tried the following:

    mencoder stereo.avi -ovc copy -oac mp3lame -lameopts cbr:br=128:mode=3 -af pan=1:0.5:0.5 -channels 1 -o mono.avi

    That also doesn't work

    What am I doing wrong?

    Any help is appreciated, thx a lot.
    Quote Quote  
  2. Member
    Join Date
    Jul 2002
    Location
    United States
    Search Comp PM
    Try ffmpeg instead, a little easier imho:

    ffmpeg -i stereo.avi -vcodec copy -acodec mp3 -ac 1 -ab 128 mono.avi
    "The software said Win XP or better, so I Installed Linux"
    Quote Quote  
  3. Member
    Join Date
    Jun 2006
    Location
    Spain
    Search Comp PM
    Hi, thx for your answer.

    Does ffmpeg use lame for encoding mp3?

    Anyway, I'd like to do it with mencoder so if anyone knows how to do it i'll be very happy if u post.

    Thank you.
    Quote Quote  
  4. Member
    Join Date
    Feb 2012
    Location
    Canada
    Search PM
    The mencoder option that worked for me was:

    mencoder -af channels=2:2:0:0:0:1 ...
    or
    mencoder -af channels=2:2:1:0:1:1 ...

    The difference between the two is the channel that I'm selecting as the audio source (left vs. right). Useful for hardcoding videoke files.
    Quote Quote  



Similar Threads