VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 52
Thread
  1. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    I authored a DVD and generated subtitles for my DVD. However, the problem is that I can't see any subtitles when I played it on PowerDVD after I finished compiling. I tried recompiling but it still doesn't work. Can anyone please help me? I read numerous threads on this topics but none seem to work though...
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  2. Member mats.hogberg's Avatar
    Join Date
    Jul 2002
    Location
    Sweden (PAL)
    Search Comp PM
    No idea. Had nothing but success with subtitles and DVD-Lab Pro. (importing from .srt)

    /Mats
    Quote Quote  
  3. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    Have you tried switching them on in PowerDVD ? You need to select a subtitle language and make sure that subtitle is ticked.
    Read my blog here.
    Quote Quote  
  4. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    Originally Posted by mats.hogberg
    No idea. Had nothing but success with subtitles and DVD-Lab Pro. (importing from .srt)

    /Mats
    I used .srt but failed. Can I change the .srt format using Subtitle Editor? If so, which format will not bring any problems when imported?

    @guns1inger: Yes, tried.

    What margins should I set?
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  5. Member mats.hogberg's Avatar
    Join Date
    Jul 2002
    Location
    Sweden (PAL)
    Search Comp PM
    Do you see the subs track in DVD-Lab after importing the .srt?

    /Mats
    Quote Quote  
  6. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    How do you mean you failed with .srt files ? Did you generate the subtitle stream in the editor before compiling the disc ?
    Read my blog here.
    Quote Quote  
  7. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    I saw the subs track and I generated the .srt subtitle stream. What I mean by failed is I can't see any subtitles when I played it using Power DVD.
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  8. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    open the video_ts folder in DVD Shrink and see what streams it sees. It will tell you if a subtitle stream exists.
    Read my blog here.
    Quote Quote  
  9. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    There is something under Subpicture in DVD Shrink but when I played the movie in DVD Shrink, the subtitles did not appear. Could it be that subtitles extracted from OGM files cannot work with DVDLab Pro?
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  10. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    If they are true .srt files they should. When you loaded them into the subtitle editor in DVD Lab Pro, did you see the timecodes and text ?

    Just out of curiosity, which version of DLP are you using ?
    Read my blog here.
    Quote Quote  
  11. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    Time code as in Start Time and End Time? If so, I see them and there are text. I'm using version 1.53. What do you mean as in true .srt files?

    Could it be that subtitles extracted from OGM files cannot work with DVDLab Pro?
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  12. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    It depends on the format. DLP accepts .srt format files. It also accepts subtitles in the formats .sub, .ssa, .son and .sst.
    Read my blog here.
    Quote Quote  
  13. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    I extracted .srt files from an OGM file. Still no solution, I presume...
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  14. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    Erm, can I remake the .srt file? If can, how?
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  15. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    Can you post them so I can have a look ?
    Read my blog here.
    Quote Quote  
  16. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    Post?

    http://www.megaupload.com/?d=K0P0RLLR if you want the subtitle file, that is.
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  17. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    I can load and generate them without issue. The only anomally is the final line, which has a zero timecode. I excluded this from the generation process. Otherwise they work OK for me.

    This suggests it is something in your process that you are omitting that is cuasing your problem.
    Read my blog here.
    Quote Quote  
  18. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    What process could I be omitting?
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  19. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    I don't know, as I am not sitting at your shoulder while you work. I took your subtitle stream and ;

    1. Opened DLP 1.53 and created a new project - movie only in this case
    2. Added a sample clip to the video stream
    3. Double-clicked the subtitle stream to open the subtitle editor
    4. Imported the .srt file
    5. Deleted the zero timecode line at the end of the stream
    6. Clicked Generate subtitles and let DLP create the bitmaps and then the final stream
    7. Once that was done, clicked close
    8. Compiled the DVD and tested with PowerDVD. Subtitles were there as ordered.

    How does this compare to what you are doing ?
    Read my blog here.
    Quote Quote  
  20. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    I did everything you did except I didn't clicked close. After generating, the Subtitle Editor closed by itself.
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  21. Member
    Join Date
    Aug 2005
    Location
    Right here
    Search Comp PM
    I've been following this post, because it's such an odd thing...

    Could it be something really stupid, like you have set the height the subs will show out of the range you can see, or the color font being black and showing on black bars?

    Just for the case it can help...
    They that give up essential liberty to obtain a little temporary safety deserve neither liberty or safety. (Benjamin Franklin).
    Quote Quote  
  22. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    Originally Posted by NormaJ
    I've been following this post, because it's such an odd thing...

    Could it be something really stupid, like you have set the height the subs will show out of the range you can see, or the color font being black and showing on black bars?

    Just for the case it can help...
    I'm not too sure about the height or margins. Help is appreciated on that. About the color, I doubt it since I don't see any black bars. The subtitles are just missing.

    By the way, could anyone provide me what margins you all use?

    *sigh* I think I have to hardsub my movies.
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  23. Member
    Join Date
    Aug 2005
    Location
    Right here
    Search Comp PM
    I work with all the defaults settings here, becasue it works for me. But I've searched Mediachance page for any tip. So, when you are at the subtitle creating step, you see at the top right there is a folder, and right to this, a little button with -. This is to mess with subtitle properties.

    You may want to read their great help tutorial. Please cick the subtitle item, on the left hand.

    http://www.mediachance.com/dvdlab/Helppro/index.htm
    They that give up essential liberty to obtain a little temporary safety deserve neither liberty or safety. (Benjamin Franklin).
    Quote Quote  
  24. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    The sub editor should not close by itself. I think it may the zero reference line at the end that is causing your problem. I use the default margins and colours and have no problems seeing them in 16:9 and 4:3
    Read my blog here.
    Quote Quote  
  25. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    Originally Posted by guns1inger
    The sub editor should not close by itself. I think it may the zero reference line at the end that is causing your problem. I use the default margins and colours and have no problems seeing them in 16:9 and 4:3
    I tried to delete it but it keeps on appearing after I click on the several lines above it. About the close by itself situation, actually after it finishes generating, a message appears "Subtitle Stream has been created." and after I click Okay, the entire Editor closes.
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  26. Always Watching guns1inger's Avatar
    Join Date
    Apr 2004
    Location
    Miskatonic U
    Search Comp PM
    Try just clicking on the eye beside it.

    The other thing to do it go to the mediachance forums and look there for similar problems, or report it there. The author freqents them, as do many good DLP users. If this is a common problem, they wil have the answer. I can't offer you much more, as I cannot recreate the problem using your subs on my setup.
    Read my blog here.
    Quote Quote  
  27. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    Thanks for all your time. If all else fails, time for me to hardsub my movies. *feeling sad*ack, exams coming near.
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  28. Before hardsubbing try another authoring programs as Muxman or GFD
    Quote Quote  
  29. Member
    Join Date
    Dec 2005
    Location
    World of Cooking
    Search Comp PM
    Sounds good to me.
    Best food is not cooked with love or feelings, but cooked with Monosodium glutamate.
    Quote Quote  
  30. The root of all evil träskmannen's Avatar
    Join Date
    May 2005
    Location
    Belgium
    Search Comp PM
    Are you sure that the subtitles are not there? I do not think you can watch subtitles in DVD Shrink (I may be wrong) and it is not enough to only choose a language in Power DVD, you must also check "Display subtitles" in the same menu as you use to choose subtitle language.

    If you still cannot see any subtitles, try opening the VOB-files in SubRip and choose "Only Show SubPictures". This will tell you if the subtitles really are there and that the text is correct. If that is the case, try using DVDSubEdit to change colour and position of the subs until you are satisfied.

    If they are not there, something must have gone wrong in the DVD Lab process. I looked at the .srt-file that you are using, and it looked a bit fishy to me when I open it in Notepad, no clean line breaks etc. Open it in Subtitle Workshop and choose save as..., and scroll down until you can double-click "SubRip". This should fix it. Try authoring in DVDLab again.
    Quote Quote  



Similar Threads