VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 10 of 10
Thread
  1. I'm having trouble with this. Either I'm doing it wrong or it's not possible. I open them in quicktime just fine. I cut/paste one to the other and export as mp4. I choose pass through. The audio doesn't let me choose that though. So I try deleting the audio and just having the video passthrough. It works. I try opening it in quicktime though and it crashes. That is my problem. Now I'm going to combine the VOB from both DVDs and try that with ffmpegX. (The whole video is on 2 DVDs)

    Step by step:
    I have two VOBs. 1.vob + 2.vob
    Each VOB is exported with the same settings, which is the iPod H.264 preset.
    Result is 1.mp4 + 2.mp4. Both play great in quicktime.
    In quicktime, I copy 2.mp4, then paste it at the end of 1.mp4.
    file/export/movie to mpeg-4. In options, video is passthrough. Audio won't let me set passthrough. That is problem #1. I delete audio track and try again with just video at passthrough. It exports. I open the file from that and quicktime crashes. Problem #2.

    I hope that I made it clear enough. Basically, all I'm after is getting the 2 joined. Thanks for any help if you can offer it.
    Quote Quote  
  2. I went through the steps again but this time I used Mpeg4(ffmpeg) I got problem #1 again though problem #2 was gone. (Still couldn't get audio to passthrough)
    Quote Quote  
  3. I figured out a way to do it. Here's how:

    1) Open both mp4's and export them as mp4 in quicktime with video set to passthrough and the audio to AAC. (see image)

    2) Take files from that and open them in quicktime and export as mp4.

    3) Now both video and audio can be done as passthrough with a resulting combined file that won't crash quicktime.

    Why that works and nothing else, i have no clue. Could be something with ffmpegX. Hopefully someone can look into it.
    Quote Quote  
  4. 117 views. No one will reply. I guess I'm screwed.
    Quote Quote  
  5. Member
    Join Date
    Nov 2005
    Location
    United States
    Search Comp PM
    Well, perhaps. The MP4 container features of FFMPEGX are still pretty young, so you can't join MP4 files in FFMPEGX...yet.

    As for using Quicktime...well, this isn't really the forum for it, is it? Apple has its own forum server for Quicktime Pro support. You'll have better luck over there.

    I'm afraid I don't know what is causing the Quicktime crash, and there is little detail about the format of the original files to go on. Anyhow, good luck to ya!
    - macr0t0r
    When did email start feeling like work?
    Quote Quote  
  6. Originally Posted by macr0t0r
    I'm afraid I don't know what is causing the Quicktime crash, and there is little detail about the format of the original files to go on. Anyhow, good luck to ya!
    I think I was clear on that. I said that the original file is a VOB. Output is mp4 container under the iPod H.264 preset. If this is a problem with ffmpegX, I'd like to confirm it with others. I can try going to Apple about it.
    Quote Quote  
  7. Member
    Join Date
    Nov 2005
    Location
    United States
    Search Comp PM
    Ah, I see. You are appending the converted files. Sadly, I only deal with MPEG4, not the H.264 (waaaaay to slow for the miniscule size reduction, if you ask me). My process for concatenating files in Quicktime is as such:
    1: Open 1.mp4 and 2.mp4 into Quicktime.
    2: At the 2.mp4 window, press CMD-A (select all) and CMD-C (copy).
    3: At the 1.mp4 window, press CMP-V (paste).
    4: You should see the new footage added at the end.
    5: Select File-Save As and go to the MPEG-4 options.
    6: Select MP4 format, and set Pass-thru for both Video and Audio (I just did it, and I CAN select Pass-thru for both).
    7: Save.

    By the way, the encoder "Mpeg4(ffmpeg)" is not compatible and has issues (which you found out). You need to use the XVID encoder.

    Now, I think there is a glitch in the fact that you can NOT select pass-thru for Audio. My mp4 files come from FFMPEGX using the iPod-TV setting (which is MPEG4-XVID video encoder). This -should- be using the same audio encoder. Perhaps it is the H.264 packaging that has glitches.

    In any case, I would suggest you use the iPod-TV preset and then squeeze the resolution and bitrate to your desired settings. It seems that everywhere I go, people are talking about compatibility/sync/slow-encode/glitches with all of the H.264 encoders (even Quicktime has issues). Yah, it's a little smaller, but not really worth the hassle. The XVID MPEG4 encoder WORKS. Just use that.
    - macr0t0r
    When did email start feeling like work?
    Quote Quote  
  8. Ok, so then H.264 really is messed up, it's not just me. I tried iSquint and it works much better than ffmpegX for both mpeg4 and x264. (In case people would like to know)
    Quote Quote  
  9. Member
    Join Date
    Nov 2005
    Location
    United States
    Search Comp PM
    Really? That would be odd, since iSquint uses the same ffmpeg and x264 encoders as FFMPEGX. It must be using different settings. Well, I'm glad you found a solution!
    - macr0t0r
    When did email start feeling like work?
    Quote Quote  
  10. Member
    Join Date
    Jan 2006
    Location
    United Kingdom
    Search Comp PM
    If you are joining two H.264 videos together using quicktime, you don't have to re-export as MP4.

    Just paste one onto the end of the other and then hit 'Save as...' and save it as a self-contained .MOV file - the iPod will play it fine.
    Quote Quote  



Similar Threads