VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. Member
    Join Date
    Dec 2005
    Location
    United States
    Search Comp PM
    I have an iMac G5 1.8MHz 1GB RAM running OS X 10.4.3 with over 200 GB of space on the hard drive. QuickTime Pro is installed along with MPEG-2 for QuickTime. I made a 2+ GB recording using EvolutionTV. The recording works and no audio/video sync problem. When I use ffmpegX 0.0.9u to create a VOB the audio is a few seconds slower than the video. Here's what I did for ffmpegX ...

    Source Format: Video (Mpeg-2, 720x480, 8000 kbps, 29.97 fps) Audio: (mp2, 48,000 Hz, 192 kbps)

    Target Format: Video (ffmpegmpeg2, 720x480, 8000 kbps, 29.97 fps) Audio: (ac3, 48,000 Hz, 192 kbps, normalize). I set some of the parameters for Target Format to match the Source Format.

    Options: The only option I selected was 'High Quality'.

    The resulting output for VOB, as I said, was out of sync with the audio a few seconds slower than the video and this was true for the entire VOB output.

    I've played around with ffmpegX 0.0.9u for about a week - trying different Target Formats and options only to experience the same out of sync problem. Rest assured if I come up with a fix I'll post it.

    Are there any fixes??? I remember reading a post about a problem with 'memcoder' but don't know if this applies here. The creation date for 'memcoder' I have installed is December 6, 2005. There is no version number but I believe I'm using the latest release.

    Thanks!!!

    Jim

    Quote Quote  
  2. Try enabling "Decode with Quicktime", does it improve?
    Quote Quote  
  3. Member
    Join Date
    Dec 2005
    Location
    United States
    Search Comp PM
    ADDED TODAY 12/26/05: WELL ... I THOUGHT I CAME UP WITH A SOLUTION but after watching the DVD content ... the audio and video were in sync for about the first 15 minutes and then the audio was just a hair faster than the video, enough to notice. So the solution I thought I came up with was close but no cigar. Bottom line is I still need help with the audio sync problem. So what follows isn't a solution at all but I'll leave it posted so others can avoid spending time on what I learned didn't work ...


    I CAME UP WITH A SOLUTION !!! TOOK AWHILE !!! It's not elegant but it worked. I'll take you through the steps.

    FIRST. I tried the same setup like in my original post but enabled the option 'Decode with QuickTime'. The outcome was the same. Still a audio sync problem.

    SECOND. I remembered about a week ago when I first downloaded, installed and registered ffmpegX 0.0.9u I created a VOB from an MPEG-4 recording from TV. So I rechecked the VOB and there was no audio sync problem. So I thought that if I convert the MPEG-2 Muxed file I was having the audio sync problem with into an MPEG-4 first using ffmpegX, and then convert the MPEG-4 into a VOB that this might be the solution. It was!!!

    In converting the MPEG-2 to an MPEG-4 the source and target files, using all the defaults, were as follows:

    SOURCE FILE: MPEG-2

    Video: Mpeg-2, 720x480, 8000 kbps, 29.97fps
    Audio: mp2, 48000 MHz, 196 kbps

    TARGET FILE: MP4

    Video: ffmpeg mpeg4, 720x480, 1516 kbps, 29.97 fps, no crop
    Audio: aac, 48000 MHz, 196 kbps

    This created the file S-video.mpg.ff.mp4. I opened and played this file in QuickTime Pro 7.0.3. It worked perfectly. Audio and video in sync.

    So then I converted the MP4 file to DVD (VOB files) as follows:

    SOURCE FILE: MP4

    Video: mpeg4, yuv420p, 720x480
    Audio: aac, 48000 MHz, stereo

    TARGET FILE: DVD

    Video: ffmpeg mpeg2, 720x480, 4000 kbps, 29.97 fps, no crop
    Audio: ac3, 48000 MHz, 448 kbps, normalize

    These settings were the defaults. For Options I selected 'High Quality' and 'Decode with QuickTime'. 'Letterbox' was not selected.

    OUTCOME: I sampled portions of the outcome with Apple's DVD Player 4.6.1. The audio and video were in sync.

    What did I learn in this process. Well, I'll probably be recording in MPEG-4 format from now on. This way I can save a step in the process I outlined above.

    If you know of a better, more efficient approach I'd appreciate learning what else works!!!

    Thanks and hope this helps you out!!!

    Jim

    Quote Quote  
  4. Member
    Join Date
    Dec 2005
    Location
    United States
    Search Comp PM
    Am still having the audio/video sync problem. I've tried about everything I could like demuxing, muxing and then authoring but the problem continues.

    Any suggestions or solutions would be greatly appreciated!!!

    Thanks in advance.

    Jim
    Quote Quote  
  5. Member
    Join Date
    Dec 2005
    Location
    United States
    Search Comp PM
    Don't know if this provides any leads or not but I used MovieGate 2.0.0 to process the MPEG-2 Muxed file to create the VOB files. MovieGate only processes MPEG-2 files.

    The audio and video were in sync.

    Wish I could get ffmegX 0.0.9.u to work!!! It has alot of options I'd like to use.

    Thanks ...

    Jim
    Quote Quote  
  6. Member
    Join Date
    Dec 2005
    Location
    United States
    Search Comp PM
    PROBLEM SOLVED ...

    I'm using EvolutionTV to record TV programs. The recording is NTSC using the MPEG2 codec. EvolutionTV has a MovieGate plug-in that authors the VOB files. The VOB files are complete and the audio and video are in sync.

    THE PROBLEM

    The problem was that I wanted to use ffmpegX 0.0.9u to author the VOB files using the file output by EvolutionTV. In all instances, after about 25 or so minutes into the movie, the audio and video were no longer in sync.

    THE SOLUTION

    SO ... I opened the MPEG2 output from EvolutionTV in MovieGate 2.0.0. I then started the authoring process and opened the folder where the files were created. MovieGate first demuxes the file into a .mp2 and a .m2v. The .m2v file is then converted into a .wav file. After this MovieGate normalizes the audio and creates a .ac3 file. At this point I clicked 'Stop' to stop MovieGate from processing any further.

    What I was left with was a .m2v file and a .ac3 file. I was able to use ffmpegX 0.0.9u from 'Tools', 'Mux' where the .m2v file was selected for 'Video' and .ac3 was selected for 'Audio 1'. ffmpegX 0.0.9u created a muxed file, e.g., track-1.mpg and created the AUDIO_TS and VIDEO_TS folder with all the respective files. I played the VOB files. The audio and video was complete and in-sync. In addition I could get MPEG2 Works 4 to work with the .m2v and .ac3 files as well.

    I tested Toast Titanium 6.1.1 using the muxed file (track-1.mpg) created by ffmpegX 0.0.9u to author the VOB files for 'DVD-Video'. The audio and video was complete and in-sync.

    So problem solved!!! If the out-of-sync problem is haunting you maybe this might give you a lead or two.


    Jim
    Quote Quote  



Similar Threads