VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Okay I have these mpeg1 files (VIDEO: MPEG-1 352x240 29.97 fps (4:3) NTSC, 1150 kbps; AUDIO: MPEG-1, Audio Layer-2, 44100 Hz Stereo, 224 kbps), and using virtualdub I could tell that the original mpeg1 files are not quite in sync the sound is always a bit late .5-1.0 seconds. So I use virtualdub to create the uncompressed .wav file. Then I open the .wav file with gold-wave and change the play-back rate from 44100 to 44080 or 44070 depending on the audio delay in the mpeg. Then I resample it back to 44100 of course, then I save it. Then I use the ffmpegGUI beta build 3 program to convert the uncompressed altered .wav file back to mp2, 192 bitrate and to 48000 hz (should I be only using dvd author to convert the mp2 file to 48000 hz?). Okay so now i have my fixed mp2 file and finally I use TMPGEnc to multiplex the m1v file (that i got from demultiplex the original mpeg1 file) with the new mp2 file. So now i have a nice new and audio sync'd mpeg1 file. I play it in virtualdub and the audio is pretty much spot on with the video, all the action sequences sync up and the lips sync up pretty much perfectly. Atleast within to a degree that I can't notice at all.

    Okay so then I use TMPGEnc DVD author 1.6 program to create all the menu crap okay so now I output the video and audio folders. So at this point I'm all set and ready to burn to my DVD-R 4.7GB taiyo yuden disc. The burn goes fast but I load it up and still get slow audio where its still 1-2 seconds off. But in virtualdub all the altered mpeg1 files were spot on. Any ideas?

    Could it be because I used ffmpeggui beta build 3 to change the uncompressed fixed .wav file to 48000 sample rate and not 44100? But at some point the 44100 files have to be resampled to 48000 cuz TMPGEnc author does that for me aswell.

    Okay I just caught the fact that I was using ffmpeggui beta build 3 and was using the default bitrate of 192 kbps instead of 224 kbps which i bolded above as the default mp2 file has. So is this finally the solution to my problems? The fact I overlooked that entirely? Ugh oh my god all those hours spent, now I have to redo them.
    Quote Quote  
  2. Yeah bitrate shouldn't matter when it comes to video/audio sync should it? Its quality right, so yeah that can't be it. I don't get it, why when I burn it all goes to hell.
    Quote Quote  
  3. Mod Neophyte Super Moderator redwudz's Avatar
    Join Date
    Sep 2002
    Location
    USA
    Search Comp PM
    You are right, bitrate is not your problem. You have found a unique way to correct sync problems which apparently doesn't work. Generally, sync is as simple as the audio length does not match the video length.

    If the sync is the same throughout the video, then you just need a offset of the audio, either plus or minus. VD can do that. I generally use VD Mod. In that, you select 'Streams', 'Stream list', then 'Full Processing', 'Interleaving'. This should give you a menu that has 'Audio Skew Correction'. You can input a plus or minus number to correct the sync. Other versions of VD should have a similar setting.

    To make the offset amount a little easier to figure, you might look into Hypercube Time Stretcher. Or just experiment a little with VD settings.
    Quote Quote  
  4. Okay I'll try what you said. But using gold-wave changing the playback rate did correct the audio sync for the mpeg files because in virtualdub the files were all spot on. If I try your method won't it make the mpeg1's unsync'd? The mpeg1 files are perfectly sync'd until I convert and burn them.

    But yeah I'll try that. Thanks
    Quote Quote  
  5. Actually after studying the mpegs I converted and burned to dvd. I realized that in each mpeg so far the video for the beginning opening credits are will speed up in certain areas quite rapidly. But it seems to vary from each video mpeg I select in the menu, but it always seem to be the opening credits. So instead of the issue begin the audio is too slow it seems that the video is far too fast for the audio to keep up with it. After the opening credits and a few minutes into the actual show it doesn't seem gradual as much as a fixed 2.5-3.5 seconds. Now that I've looked through a few chapters it seems that in almost any area of the episode it will speed up. So it isn't just the beginning, so I can attribute this to bad frames? But how can this be when the mpeg1s on my computer run in sync flawlessly? Is it my burner or the program I might be using?

    Please give me somewhat detailed instructions as to what you might investigate further and try to surmise my issue.
    Quote Quote  



Similar Threads