VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Page 3 of 3
FirstFirst 1 2 3
Results 61 to 86 of 86
Thread
  1. Member
    Join Date
    Sep 2005
    Location
    Earth
    Search Comp PM
    Hmmm... is this fixable, or is this a problem with the H.264 codec?
    Quote Quote  
  2. It is a problem with the mencoder demuxer. I'm checking how it can be fixed. If anyone has an idea, please post it.
    Quote Quote  
  3. Member
    Join Date
    Sep 2005
    Location
    Earth
    Search Comp PM
    Have you contacted the mencoder developers? Maybe they have experienced this issue.
    Quote Quote  
  4. I'm also doing that.
    Quote Quote  
  5. Originally Posted by major
    Apparently this happen only with NTSC FILM sources. When audio is not encoded at the same time as the video, the demuxer framerate detection seem to fail during the first one or two seconds.
    Don't have NTSCfilm DVD.
    Just idea.

    1)How about putting softskip in -vop chain.

    2)mp4box option ;
    hinting options
    -delay tkID=TIME: sets track start delay in ms.
    import options
    ":delay=delay_ms": sets imported media initial delay in ms

    3)-oac faac -ovc x264 -of lavf -o "OUT".mp4
    then,
    -ovc copy -o "OUT".264

    if you could give me POST name in mplayer-dev-eng archive, I can translate to JP & ask ppl here, or Search mplayer patches, or Search other mp4box/mpeg4ip commands.
    Quote Quote  
  6. I may try with softskip. The problem with the delay is that we don't know the delay and whether it is constant. And the lavf muxer is broken for compliant MP4.
    Quote Quote  
  7. Member
    Join Date
    Aug 2005
    Location
    Earth (North America)
    Search Comp PM
    So, mencoder encodes video and audio separately. There is no way to merge the audio into the video, because we are already doing that. The frame rate changing for NTSC in mencoder only applies to video, and not audio. Why can't mencoder apply the same frame skipping rules to the audio? Granted, that requires the developers of mencoder to do some work, however if the audio is broken into frames like video and is processed the same way, then the resulting file should be in sync. However, that would require some fairly drastic changes to mencoder to treat the audio as such.

    Until that time, are there any other encoders that ffmpegX is capable of using with only slight changes necessary to create H.264 video?

    (And if I'm wrong, don't hesitate to tell me so. Learning experience and all that)
    Quote Quote  
  8. >Why can't mencoder apply the same frame skipping rules to the audio?

    I guess broken is Video Skipping Rules, not Audio.
    If MEncoder makes correct Video, Total Duration Time of Video & Audio is same.
    MEncoder must be making some kind of Zero-data-Frames.
    which do not contain real data, just tell "keep previous on Display" to Players/Decoders.
    it's usufull 4 reducing FileSize;
    Picture"A",Picture"B",Picture"B",Picture"C",,,,
    Picture"A",Picture"B","keep previous",Picture"C",,,,
    But,How to tell "keep previous" is different by container.
    "keep previous" in AVI-language is not understandable in MP4-language.
    Thus, MP4 Players just decode next frame and brake A/V Sync.

    Same thing must be taking place in decoding too. I mean inside MEncoder,Decoding Sourcefile before Filtering/Encoding.
    "This frame is same as previous, lets not decode it, so I can save time for filters & encoders "

    MEncoder is designed to make AVI.
    he/she may doing many spacial treatings only good for AVI, but nogood for other containers.
    e.g. some frame skipping rules may do bad for non-AVI containers.
    http://www.mplayerhq.hu/DOCS/HTML/en/menc-feat-dvd-mpeg4.html#menc-feat-dvd-mpeg4-muxing

    For other containers. Dev-work seems started in early 2005.
    So far, he/she got various output containers.but its unstable as major-san say. Now I agree.

    IMHO, fastetst fix is finding MEncoder commands that kills his/her spacial treatings for AVI.
    from here;
    http://www.mplayerhq.hu/DOCS/man/en/mplayer.1.html
    or here;
    http://itdp.fh-biergarten.de/~itdp/html/

    >are there any other encoders that ffmpegX is capable of using with only slight changes necessary to create H.264 video?

    "x264". building from Sourcecode was VERY EASY.
    cause its simple,only encode, nofilters. I think MEncoder is better on MacOSX.
    So far, "pipe" MEncoder Filters to X264 seems not works.

    (And if I'm wrong, don't hesitate to tell me too. Learning experience and all that)
    Quote Quote  
  9. Originally Posted by BAL_050905
    MEncoder must be making some kind of Zero-data-Frames.
    which do not contain real data, just tell "keep previous on Display" to Players/Decoders.[..]
    IMHO, fastetst fix is finding MEncoder commands that kills his/her spacial treatings for AVI.
    I'm already using the harddup filter which disables these special frames.
    Quote Quote  
  10. Not trying to nag but any news?

    This is my encoding line

    mencoder.exe -ovc x264 -oac copy dvd://1 -dvd-device k: -x264encopts subq=1:4x4mv:8x8dct:me=3:frameref=1:bframes=3:b_py ramid:weight_bass=1:bitrate=900 -ofps 24000/1001 -endpos 5:00 -o c:\test.avi
    Quote Quote  
  11. But here you obtain an AVI file, not MP4.
    Quote Quote  
  12. Member
    Join Date
    Sep 2005
    Location
    Earth
    Search Comp PM
    major, any news from the mencoder guys about a fix for h.264?
    Quote Quote  
  13. Not still but things should get fixed somewhen. I hope to find alternate methods soon.
    Quote Quote  
  14. hi,

    So far,encode as AVC-inAVI,then extract .264 results best. but still have v-a diff around 0.096sec. its not noticeable for me, but somebody may.

    win user may say AVC-in-AVI is no good, but we not using vfw codec handler anyway, so stream can be OK.

    PLAN B.
    also "-fps 24.000" or "30.000" results very close to above.
    using divisor of Audio frequency.
    My usual Audio frequency is 48000hz, so I should try "-ofps 48000.000" for perfect sync
    Quote Quote  
  15. I was thinking indeed to first encode into AVI then extracting the video from there. About plan B, why should we use non-standard 24fps or 30fps?
    Quote Quote  
  16. PLAN B.
    because I get confused after reading these.
    although English is difficult to me, but it seems AVC - in - AVI may make thigs more complexed.

    - http://forum.doom9.org/showthread.php?t=62723)
    -- Plz see "5) What do i have to especially look at, when i mux MPEG-4 video from AVI to MP4? "
    -http://forum.doom9.org/showthread.php?s=&threadid=80430
    --"MPEG-4 B-frames in AVI/VFW hackery description"
    -http://forum.doom9.org/showthread.php?p=708728
    -http://www.bunkus.org/videotools/mkvtoolnix/avc-status.html

    PLAN A+.(AVC - in - AVI+)
    YAMB(Win's mp4box GUI ) seems to have options, which pullouts AVC from AVI safely, and shows commandlines.
    Don't have Win, but...

    $ mp4box -aviraw video /Volumes/XXX/XXX.avi
    worked like this,
    Extracting AVI video (format h264) to /Volumes/XXX/XXX_video.h264
    but after mux with ffmpeg2's aac.mp4, resulted almost same A-V diff as r4.

    others not tested yet.
    -nodrop:
    forces constant FPS when importing AVI video
    -packed:
    forces packed bitstream when importing raw ASP

    thx 4 reading.
    Quote Quote  
  17. Member dragon_1's Avatar
    Join Date
    Jul 2005
    Location
    i don't know
    Search Comp PM
    hi guys well i say for play anything h.264, cuz i had the same problem playing an MKV h.264 i used CCCP and it worked for me but you must Uninstall all other individual codecs, filters (like DirectVobSub, ffdshow, CoreVorbis, CoreAAC, etc.) http://www.kickassanime.org/wiki/index.php?title=CCCP
    Quote Quote  
  18. Member
    Join Date
    Sep 2005
    Location
    Earth
    Search Comp PM
    Any news?
    Quote Quote  
  19. Member
    Join Date
    Sep 2005
    Location
    Earth
    Search Comp PM
    major, any ideas on what to do about the sync issue?
    Quote Quote  
  20. The problem is in mencoder.. however the x264 engine seem to work well?
    Quote Quote  
  21. Member
    Join Date
    Sep 2005
    Location
    Earth
    Search Comp PM
    But if the problem is mencoder, how do I go about encoding a video if all ffmpegX uses is mencoder for H264? Should I use Quicktime? Handbrake sucks, as it gives me the "no title" error half the time, and isn't as powerful as ffmepgX.
    Quote Quote  
  22. Originally Posted by bigbubba
    But if the problem is mencoder, how do I go about encoding a video if all ffmpegX uses is mencoder for H264? Should I use Quicktime? Handbrake sucks, as it gives me the "no title" error half the time, and isn't as powerful as ffmepgX.
    If you are using the new version of ffmpegx select x264 right underneath h264 in the video tab. x264 does not use mencoder, I do believe that it uses the x264 engine.
    Quote Quote  
  23. Member
    Join Date
    Dec 2004
    Location
    Atlanta, Georgia USA
    Search Comp PM
    x264 rocks and will work, but I'm waiting for 2-pass encoding to be enabled first. Once that is done, all your mencoder troubles will be gone.

    -STS
    Quote Quote  
  24. Originally Posted by Metallirat
    Originally Posted by lhawkins
    I'm suprised by the different experiences we are all having... When I said that Fight Club was out of sync, it was only about a half a second by the end of the film, certainly not anything like 15 seconds. I am encoding it again with the new r3 version but I won't know until morning whether it worked any better or not.
    Yeah, Fight Club was off, Boondock Saints was off by a different amount. My House DVD was weird because the video was like it was in fast forward the whole time. Different with every one.
    The reason you are having sound sync drift of 1/2s is because the 23.976 fps on most of these features is generated from a process called 'inverse telecine' which takes true 29.97i footage which has been cut on an Avid, and attempts to reconstruct true 23.976 progressive frames from it during the MPEG-2 encoding. Unfortunately, the pro machines which do inverse telecine can lose track of the pulldown sequence (sometimes lost due to an edit). This results in small groups of 29.97i frames mixed in with the progressive (flagged) frames. If a transcoder does not handle this mixed timebase correctly (tricky, imho) the audio sync will drift.

    Some DVDs, mostly major features with massive FX are posted entirely digitally and printed back to film. In these cases (ie. Matrix 1,2,3) there is no inverse telecine and the stream is a pure sequence of 23.976p.

    I cover the tech details in my blog, here:
    http://www.digigami.com/mpressionist/blog/2004_11_12_archives.html

    BTW, if it is a 'directors cut' released straight to DVD, the problems are exacerbated, primarily because there is no conforming back to a film negative. So you end up with 29.97i willy nilly through the entire flick.

    Gen
    Gen Kiyooka
    Digigami
    MegaPEG.X MPEG-2 Encoder Macintosh
    MPressionist.X MPEG-2 Analysis Macintosh
    Quote Quote  
  25. Member
    Join Date
    Dec 2004
    Location
    Atlanta, Georgia USA
    Search Comp PM
    Major,

    Merry Xmas, and Happy New Year to you kind sir.

    After NYE, will a 0.0.9u R3 be released where 2-pass is turned on for X264 encoding?

    Sorry to be a pest!

    -STS
    Quote Quote  
  26. Thank you. I'm working indeed on 0.0.9v which will support 2-pass x264.
    Quote Quote  



Similar Threads