VideoHelp Forum

Try DVDFab and download streaming video, copy, convert or make Blu-rays,DVDs! Download free trial !
+ Reply to Thread
Results 1 to 24 of 24
Thread
  1. I can't seem to get toast to accept Mpeg2 from ffmpeg. I have tried both the ffmpeg and mpeg2enc option? I don't want to author it to a DVD using ffmpeg I want to use toast to create the menu.
    Quote Quote  
  2. Don't worry I have worked it out. Toast requires 29.98 frames per second NTSC and won't accept NTSC film.
    Quote Quote  
  3. Toast will accept 23.98 MPEG-2 sources, but you have to enable 3:2 Pulldown. I have had success using the mpeg2enc engine, but never with ffmpeg. I suspect if you had a movie with 23.98 as the source, you might experience some audio syncing issues if you do a conversion 29.97 rather than encode to 23.98 w/ 3:2 Pulldown.
    Quote Quote  
  4. Yeah I found this out already... But I had success by just dropping the mpv file that ffmpeg encoder creates and then selecting the audio when toast prompts that there is no audio with the mpv file. If I insert the .mpg file as ffmpeg creates, the audio gets out of sync once toast multiplexs it again.
    Quote Quote  
  5. Falcon500, so you are saying that you were able to get a perfectly playable/fully synced DVD using ffmpeg from 23.98 source? PLEASE tell me what you did exactly. I have posted my problems with ffmpeg numerous times before, but Major always ignores the posts.

    From the sound of it, it seems you took your source 23.98 and encoded to MPEG-2 29.97 using ffmpeg engine. Did you use the post-processing PullDown tool? Did you create an AC-3 track with ffmpegX, or did you stick with PCM? At any rate, you took the video track and dropped it into Toast under the DVD Video option. Then you let Toast create the VOB and menus, etc. after associating the video with the audio? I only ask, because Toast always wants to re-encode (at a higher bitrate) the .mpv MPEG-2 tracks I get from the ffmpeg engine.

    And also, if it is at all available to you, have you had success in getting .mpv MPEG-2 ffmpeg engine tracks to be recognised by DVD Studio Pro? This would be the main benifit of ffmpegX for me, as encoding with the ffmpeg engine at 1Mbps/sec less than Apple's MPEG-2 encoder produces nearly identical results, plus would allow me to put close to 4 hours on a DVD. But I have thus far never been able to use ffmpeg engine generated MPEG-2 in DVD SP.

    Thanks for any help you can provide.
    Quote Quote  
  6. Originally Posted by csdesigns
    have you had success in getting .mpv MPEG-2 ffmpeg engine tracks to be recognised by DVD Studio Pro?
    - I opened a mpeg-2 system stream at NTSC framerate (29.97 no pulldown). Encoded it with "fast DVD" quick preset to NTSC framerate. Opened the elementary stream in DVDSP successfully.

    - I opened a mpeg-2 system stream at NTSC FILM framerate (23.976 fps w/pulldown). Encoded it with "fast DVD" quick preset to NTSC FILM framerate. Then processed the elementary stream with the Pulldown tool. The resulting file movie.m2v.pulldown.m2v was successfully imported in DVDSP.
    Quote Quote  
  7. Major, great to hear from you and thanks for answering my question. A couple of further questions though. Sorry to be such a pain.

    First, what exactly is a "system stream"? I know of transport, elementary, and program streams, but not this. But besides that, I have finally gotten it to work! Thanks so much. I tried just a couple of very small files (one each of NTSC, Film, and HD), but if the success continues with the full-length movies/tracks, I will certainly register the app. I think the problem I have had in the past is that I used either a complete custom preset or the DVD or DVD lo-bitrate presets. But starting with the Fast DVD as you mentioned worked. Any reason for this?

    A couple of caveats though. Is it possible to process a QT reference file? When I capture TV for instance, I generally just edit out the commercials in QT and instead of saving the movie anew, I do a reference save as. It seems ffmpegX can't read the movie correctly and therefore won't produce any output.

    Also, what if I want to crop 4:3 to 16:9? Everytime I attempt to do this, it doesn't crop, instead it fits the 4:3 to 16:9 (shrinking the 4:3 in essence). I have followed the rule for ffmpeg cropping. Otherwise, it appears I will have to crop first in Cleaner.

    Thanks again for all your help Major.
    Quote Quote  
  8. @csdesigns

    What I did was use the fast DVD setting that enables the ffmpeg engine. As you said I opened a 23.97 fps source file and changed the audio to Mp2 and 224 as my source was only MP3 so I didn't see any need to encode it in AC3. I changed the frame rate in the video tab to 29.97 fps. After it encoded I was left with a .mpv file a mp2 file and a .mpg file. If I dropped the .mpg file into toast the multiplexing (authoring I presume to vob + menus) would leave the resulting DVD out of sync. So I then added the .mpv and then toast informed me that it had no audio so I clicked yes and selected the .mp2 file. After Toast had finished authoring the disc as an image I mounted it and was able to play it with DVDplayer in sync.

    The original source file was 41' 51'' long and the files produced by ffmpeg were 41' 49'' for the mpv file and 41' 51'' for the mp2 file.

    With your advise I have tried it again this time with the DVD setting enabling the mpeg2enc engine and setting the output file to 23.97fps but I checked the box under the options tab "Set 3:2" and I get a video file that toast accepts.

    I don't have DVD studio pro to try it out sorry...

    Next one I try I will use the fast DVD engine again (ffmpeg) and try the pulldown tool under the tool menu at the end to see if I can get the audio and video synced and toast to accept it...

    What is the better Mpeg 2 encoding engine. I know that ffmpeg is the fastest but what has the better quality. I have found using the ffmpeg engine for Mpeg 2 that I can't get a very high bit rate file. When I select 6000Kbit/s for the video I still end up converting my 42 min source file to a 622mb file. When I use Mpeg2enc engine at 4000Kbit/s I get a file 1.1 GB in size?
    Quote Quote  
  9. I changed the frame rate in the video tab to 29.97 fps...So I then added the .mpv and then toast informed me that it had no audio so I clicked yes and selected the .mp2 file. After Toast had finished authoring the disc as an image I mounted it and was able to play it with DVDplayer in sync.

    Hmmm. Pretty surprised to hear you had success with syncing with that method. Good to know for the future! I am assuming that the DVD image was fully tested to end and the audio was still in sync at the 40 min mark.

    Major helped me out with the DVD SP problem, so that is good.

    Personally, I prefer the ffmpeg engine for MPEG-2. To me, it is much faster and produces better looking files. But the mpeg2enc engine seems to have better error correction (less chance of a higher action scene becoming pixelated) and hits target bitrates more closely. Now that both engines are working for me for DVD SP though, I am quite happy to have the choice.
    Quote Quote  
  10. I am assuming that the DVD image was fully tested to end and the audio was still in sync at the 40 min mark.
    I was surprised this method actually worked as well ... Maybe I was just lucky this time. In the past when working with Mpeg1 files I had to open the audio into Quicktime and add it scaled to the video file so it was in sync.

    I did test the DVD in apples DVD player all the way to the end. It was still in sync at the 40 min mark.

    I have found the same as you with ffmpegs engine. It seems to produce better quality Mpeg2 for a smaller file size.
    Quote Quote  
  11. Originally Posted by csdesigns
    what exactly is a "system stream"?
    A MPG file.

    Originally Posted by csdesigns
    Is it possible to process a QT reference file?
    Not currently, you have to save it self-contained.

    Originally Posted by csdesigns
    Also, what if I want to crop 4:3 to 16:9?
    DVD video has a standardized image size, which is the same for 4:3 and 16:9, so no crop is needed. To obtain the 16:9 aspect, the aspect flag should be enabled. To do so, use the special "DVD 16:9" autosize choice. To add black bars with "fast DVD", enable "Decode with Quicktime".
    Quote Quote  
  12. Major, thanks for the clarifications. I thought a system stream might be a .mpg file, but was a little confused because isn't a program stream .mpg too? Also (going back to the other thread I started), I have always been told that the technical differences between MJPEGb and a were very few. Is that wrong?

    As far as the cropping issue, I did select the "DVD 16:9" autosize choice. The content I am working with is 4:3 letterboxed, so I wanted to crop the letterboxing to a 16:9 movie and set anamorphic settings in DVD SP. But selecting the DVD 16:9 size choice forces all the 4:3 (including the letterboxing) to fit into a 16:9 image proportionately scaled. Therefore, there are now black bars all around the image. Anyway, I took the file into Cleaner 6 and cropped it to 16:9 and changed the codec to 99% Photo-JPEG.

    All seems to be well now. Thanks again for your support Major, and excellent work this app!
    Quote Quote  
  13. Originally Posted by csdesigns
    Major, thanks for the clarifications. I thought a system stream might be a .mpg file, but was a little confused because isn't a program stream .mpg too?
    SS is a term introduced with mpeg-1, while PS is used with mpeg-2.

    Originally Posted by csdesigns
    I have always been told that the technical differences between MJPEGb and a were very few. Is that wrong?
    They are indeed quite similar.

    Originally Posted by csdesigns
    The content I am working with is 4:3 letterboxed, so I wanted to crop the letterboxing to a 16:9 movie and set anamorphic settings in DVD SP.
    You can enter crop values in the Filters tab (ffmpeg engine uses a top-bottom-left-right format).
    Quote Quote  
  14. "You can enter crop values in the Filters tab (ffmpeg engine uses a top-bottom-left-right format)."

    Right, but doing so seems to have no effect. The autocrop button is greyed out as well when using the ffmpeg engine. I am inputting the values into the correct fields for cropping, but it is essentially being ignored. The resulting file produces a 16:9 movie with black bars on the sides of a 4:3 image. The 4:3 is scaled to fit in the 16:9 space proportionately. This was the same with both a Photo-JPEG and MJPEGb source.
    Quote Quote  
  15. Check if your crop values are divisible by 16.
    Quote Quote  
  16. I have tried cropping values that are multiples of 16, 8, and even 18. None of it seems to work correctly. Always the same image sizing. The files I have tested were MJPEGb at 640x480 and 720x486, and Photo-JPEG at 584x438. Here is the log I received, and it appears nothing went wrong (also appears it didn't try to crop).

    From "Fast DVD" preset
    • Encoding started on Wed Aug 11 13:14:48 CDT 2004
      Input #0, yuv4mpegpipe, from 'pipe:':
      Duration: N/A, bitrate: N/A
      Stream #0.0: Video: rawvideo, yuv420p, 720x480, 29.97 fps
      Output #0, rawvideo, to '/Volumes/Hitchock/Videos/Compression/Source/movie.mpv':
      Stream #0.0: Video: mpeg2video, 720x480, 29.97 fps, q=2-20, 4000 kb/s
      Stream mapping:
      Stream #0.0 -> #0.0
      [mpeg2video @ 0x2ea1f8]rc buffer underflow
      bench: utime=4.030s
      video:4983kB audio:0kB global headers:0kB muxing overhead 0.000000%
      Input #0, mov,mp4,m4a,3gp, from '/Volumes/Hitchock/Videos/Compression/Source/com10.mov':
      Duration: 00:00:10.0, bitrate: 73270 kb/s
      Stream #0.0: Video: mjpeg, 640x480, 29.97 fps
      Stream #0.1: Audio: pcm_s16be, 48000 Hz, stereo, 1536 kb/s
      Output #0, ac3, to '/Volumes/Hitchock/Videos/Compression/Source/movie.ac3':
      Stream #0.0: Audio: ac3, 48000 Hz, 5:1, 448 kb/s
      Stream mapping:
      Stream #0.1 -> #0.0

    Quote Quote  
  17. Which were your cropping values?
    Quote Quote  
  18. For instance, from the 640x480 movie: I tried 80/80/0/0, 64/64/0/0, 48/48/0/0, 32/32/0/0, 36/36/0/0, 38/38/0/0, 54/54/0/0, and even 100/100/0/0. I also tried making a 16:9 AVI using the ffmpeg engine. This produced the "squished" video appearance where all of the 4:3 was scaled to fill the 16:9 image. Using the mencoder engine greatly distorted the video image and it was unrecognizable, as though it was being reflected on a chrome bumper.
    Quote Quote  
  19. The DVD appearance is specific to DVD and making tests with AVI is not relevant.
    When you changed the crop values, did the resulting image look the same in all cases? Was "Decode with Quicktime" enabled, or disabled?
    Quote Quote  
  20. major wrote:
    • The DVD appearance is specific to DVD and making tests with AVI is not relevant

    Yes, I didn't give specific enough details I guess. What I did for the AVI was select the normal 16:9 size option, not the DVD 16:9 option. I download many TV episode AVIs that are 16:9 and was trying to test an encode similar to that.

    major wrote:
    • When you changed the crop values, did the resulting image look the same in all cases?

    Yes, it always looks the same.
    Quote Quote  
  21. Was "Decode with Quicktime" enabled, or disabled?
    Quote Quote  
  22. With "Decode with Quicktime" checked, the resulting video produces the black bars on the left and right sides. Without it checked, I get the following log and a 0K sized file:
    • Input #0, mov,mp4,m4a,3gp, from '/Volumes/Hitchock/Videos/Compression/Source/com10.mov':
      Duration: 00:00:10.0, bitrate: 73270 kb/s
      Stream #0.0: Video: mjpeg, 640x480, 29.97 fps
      Stream #0.1: Audio: pcm_s16be, 48000 Hz, stereo, 1536 kb/s
      Output #0, vob, to '/Volumes/Hitchock/Videos/Compression/Source/movie.mpg':
      Stream #0.0: Video: mpeg2video (hq), 720x480, 29.97 fps, q=2-20, 4000 kb/s
      Stream #0.1: Audio: ac3, 48000 Hz, 5:1, 448 kb/s
      Stream mapping:
      Stream #0.0 -> #0.0
      Stream #0.1 -> #0.1
      Wed Aug 11 14:59:26 CDT 2004

    I exported a DivX AVI and "None" AVI from QT and tried those as sources. With the decode with QT option checked, the black bars were the same. Without it checked, the video was "squished" from 4:3 to fill 16:9. Still no cropping occuring.
    Quote Quote  
  23. I found there is indeed a strange issue linked to the recently added speed improvements for biprocessor machines, which seem to break cropping. I'll fix this in 0.0.9o.
    Quote Quote  
  24. Cool.
    Thanks for all your help, dedication, and speedy support today and yesterday!

    -CS
    Quote Quote  



Similar Threads