VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. Guest
    Hello.

    First, a confession. I've only been using this software for a few days, so I can't completely parse the terminal log and make sense of everything. However, I'm very impressed with the results. I only have a few small problems.

    I'm trying to convert a quicktime movie (was a DV file which I saved as a self-containing quicktime movie after editing it down) to a divx file. I selected a lot of encoding features which slowed the encoding time but really bumped up the quality. However, I have no sound in the finished product. I then tried some 5 second tests with VBR vs. CBR, and I even exported the qt sound track as an AIFF and tried appending it within ffmpegX. No luck. Here's the terminal log... a line that pops out at me is "Cannot find codec for audio format 0x61766476." Perhaps this is my problem.

    Anyway, thanks in advance for your help.


    MEncoder dev-CVS-030226-15:00-3.1 (C) 2000-2003 Arpad Gereoffy (see DOCS)

    AltiVec found
    Reading /Users/frommer/.mplayer/codecs.conf: can't open '/Users/frommer/.mplayer/codecs.conf': No such file or directory
    Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
    Using built-in default codecs.conf
    File not found: 'frameno.avi'
    Reading config file /Users/frommer/.mplayer/mencoder: No such file or directory
    success: format: 0 data: 0x0 - 0xA951D931
    QuickTime/MOV file format detected.
    --------------
    MOV track #0: 6357 chunks, 0 samples
    Image size: 720 x 480 (24 bpp)
    Display size: 720 x 480
    Fourcc: cvd Codec: 'DV/DVCPRO - NTSC'
    --------------
    MOV track #1: 6357 chunks, 0 samples
    *** constant samplesize & variable duration not yet supported! ***
    Contact the author if you have such sample file!
    Audio bits: 16 chans: 2 rate: 48000
    Fourcc: avdv
    --------------
    MOV: longest streams: A: #1 (6357 samples) V: #0 (47626 samples)
    [V] filefmt:7 fourcc:0x20637664 size:720x480 fps:29.97 ftime:=0.0334
    ================================================== ========================
    *** Try to upgrade /Users/frommer/.mplayer/codecs.conf from etc/codecs.conf
    *** If it still does not work, read DOCS/codecs.html!
    Cannot find codec for audio format 0x61766476.
    ================================================== ========================
    Opening video filter: [expand=-1:-1:-1:-1:1]
    Expand: -1 x -1, -1 ; -1 (-1=autodetect) osd: 1
    Opening video filter: [scale=320:240]
    Opening video filter: [lavcdeint]
    ================================================== ========================
    Requested video codec family [qdv] (vfm=dshow) not available (enable it at compilation)
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffdv] vfm:ffmpeg (FFmpeg DV decoder)
    ================================================== ========================
    Writing AVI header...
    VDec: vo config request - 720 x 480 (preferred csp: Planar 411P)
    Could not find matching colorspace - retrying with -vop scale...
    Opening video filter: [scale]
    VDec: using Planar 411P as output csp (no 0)
    Movie-Aspect is undefined - no prescaling applied.
    SwScaler: reducing / aligning filtersize 1 -> 1
    SwScaler: reducing / aligning filtersize 3 -> 2
    SwScaler: reducing / aligning filtersize 1 -> 1
    SwScaler: reducing / aligning filtersize 5 -> 4

    SwScaler: BILINEAR scaler, from Planar 411P to Planar YV12 using C
    videocodec: libavcodec (320x240 fourcc=58564944 [XVID])
    High quality encoding selected (non real time)!

    Skipping frame!
    New_Face failed. Maybe the font path is wrong. 0mb A-V:0.000 [0:0]
    Please supply the text font file (~/.mplayer/subfont.ttf).
    subtitle font: load_sub_face failed.
    Pos:1589.1s 47625f ( 0%) 6fps Trem: 0min 0mb A-V:0.000 [514:0]
    Writing AVI index...
    Fixing AVI header...

    Video stream: 514.801 kbit/s (64350 bps) size: 102256011 bytes 1589.056 secs 47625 frames
    Using GNU internationalization
    Original domain: messages
    Original dirname: /sw/share/locale
    Current domain: mplayer
    Current dirname: /usr/local/share/locale


    MEncoder dev-CVS-030226-15:00-3.1 (C) 2000-2003 Arpad Gereoffy (see DOCS)

    AltiVec found
    Reading /Users/frommer/.mplayer/codecs.conf: can't open '/Users/frommer/.mplayer/codecs.conf': No such file or directory
    Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
    Using built-in default codecs.conf
    File not found: 'frameno.avi'
    Reading config file /Users/frommer/.mplayer/mencoder: No such file or directory
    success: format: 0 data: 0x0 - 0xA951D931
    QuickTime/MOV file format detected.
    --------------
    MOV track #0: 6357 chunks, 0 samples
    Image size: 720 x 480 (24 bpp)
    Display size: 720 x 480
    Fourcc: cvd Codec: 'DV/DVCPRO - NTSC'
    --------------
    MOV track #1: 6357 chunks, 0 samples
    *** constant samplesize & variable duration not yet supported! ***
    Contact the author if you have such sample file!
    Audio bits: 16 chans: 2 rate: 48000
    Fourcc: avdv
    --------------
    MOV: longest streams: A: #1 (6357 samples) V: #0 (47626 samples)
    [V] filefmt:7 fourcc:0x20637664 size:720x480 fps:29.97 ftime:=0.0334
    ================================================== ========================
    *** Try to upgrade /Users/frommer/.mplayer/codecs.conf from etc/codecs.conf
    *** If it still does not work, read DOCS/codecs.html!
    Cannot find codec for audio format 0x61766476.
    ================================================== ========================
    Opening video filter: [expand=-1:-1:-1:-1:1]
    Expand: -1 x -1, -1 ; -1 (-1=autodetect) osd: 1
    Opening video filter: [scale=320:240]
    Opening video filter: [lavcdeint]
    ================================================== ========================
    Requested video codec family [qdv] (vfm=dshow) not available (enable it at compilation)
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffdv] vfm:ffmpeg (FFmpeg DV decoder)
    ================================================== ========================
    Writing AVI header...
    VDec: vo config request - 720 x 480 (preferred csp: Planar 411P)
    Could not find matching colorspace - retrying with -vop scale...
    Opening video filter: [scale]
    VDec: using Planar 411P as output csp (no 0)
    Movie-Aspect is undefined - no prescaling applied.
    SwScaler: reducing / aligning filtersize 1 -> 1
    SwScaler: reducing / aligning filtersize 3 -> 2
    SwScaler: reducing / aligning filtersize 1 -> 1
    SwScaler: reducing / aligning filtersize 5 -> 4

    SwScaler: BILINEAR scaler, from Planar 411P to Planar YV12 using C
    videocodec: libavcodec (320x240 fourcc=58564944 [XVID])
    High quality encoding selected (non real time)!

    Skipping frame!
    New_Face failed. Maybe the font path is wrong. 0mb A-V:0.000 [0:0]
    Please supply the text font file (~/.mplayer/subfont.ttf).
    subtitle font: load_sub_face failed.
    Pos:1589.1s 47625f ( 0%) 5fps Trem: 0min 0mb A-V:0.000 [515:0]
    Writing AVI index...
    Fixing AVI header...

    Video stream: 515.597 kbit/s (64449 bps) size: 102414099 bytes 1589.056 secs 47625 frames
    Encoding completed on Tue Nov 25 06:18:11 CST 2003
    Quote Quote  
  2. joda
    Guest
    I've got the same problems but have managed to encode by saving audio and video separately (foo.mov and foo.wav), then adding the wav in the external audio input.

    Could it be the timecode track from FCP that mess things up?
    Quote Quote  
  3. joda
    Guest
    Try to choose audiotrack 1 in the audio encoding window, no need for separating audio and video then.

    Cheers.
    Quote Quote  



Similar Threads