VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors. Consider supporting us by disable your adblocker or Try ConvertXtoDVD and convert all your movies to DVD. Free trial ! :)
+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. Member
    Join Date
    Oct 2003
    Location
    Canada
    Search Comp PM
    I searched these forums but couldn't find an answer. I've setup a SVCD in VCDEasy so that there are 3 "pages" to make your selection from. Each page is an mpeg that runs infinitely. When you press 1, 2, 3 or 4 on the remote I want it to run the respective mpg. I've set it all up properly and when I run the SVCD on my PC it works fine. I click Next and it goes to page 2, then I click 3 and it loads the 3rd thumbnail, etc.. When I put the same CDRW in my Apex 1225 Next and Previous work but none of the number keys work. Any ideas what I could be doing wrong?
    Quote Quote  
  2. Member
    Join Date
    Oct 2003
    Location
    Canada
    Search Comp PM
    Just wanted to add that I've tested PBC on the player and it works fine if I play a SVCD that was created with NeroVision Express 2. I can press Prev/Next to move between pages and when I press the number keys it correctly plays the selected mpeg. The problem is that NeroVision express is very limited as far as features go, it's decent for someone who want to quickly create a SVCD using a step-by-step wizard but not very good for someone who wants to completely customize their SVCD.

    I've tried authoring with VCDEasy and VCDWizard and both produce the same result; I can press Prev/Next but the numeric buttons are not recognized. I checked the XML that both of those programs produces and I see the <selection> section is created inside <pbc>. I also see <bsn>1</bsn> with 4 select ref= for each mpeg. So the XML appears to be ok.

    I compared the contents of a working CD with that of a bad CD and I noticed that there are mpgs in the \SEGMENT folder of the working CD. There are no files in the \SEGMENT folder of the CD that doesn't work. Could this have something to do with it?

    This is DRIVING ME NUTS. I am not computer illiterate but I seriously cannot figure this out. Does anyone have any ideas or suggestions?
    Quote Quote  
  3. Member
    Join Date
    Oct 2003
    Location
    Canada
    Search Comp PM
    I solved it! woooo!! it's almost 2am, I've been working on it since about 10pm but I finally freaking figured it out. It seems that the /segment folder has to be populated otherwise numeric input isn't recognized (at least not on my apex 1225). So to fix my problem I changed the following in the XML:

    original file:

    <sequence-items>
    <sequence-item src="F:\svcd\menu1.mpg" id="seq1-movie"/>
    <sequence-item src="F:\svcd\menu1tomenu2.mpg" id="seq2-movie"/>
    <sequence-item src="F:\svcd\menu2.mpg" id="seq3-movie"/>
    <sequence-item src="F:\svcd\menu2tomenu3.mpg" id="seq4-movie"/>
    <sequence-item src="F:\svcd\menu3.mpg" id="seq5-movie"/>
    <sequence-item src="F:\svcd\mpeg1.mpg" id="seq6-movie"/>
    <sequence-item src="F:\svcd\mpeg2.mpg" id="seq7-movie"/>
    ..etc

    fixed file:

    <segment-items>
    <segment-item src="F:\svcd\menu1.mpg" id="seq1-movie"/>
    <segment-item src="F:\svcd\menu2.mpg" id="seq3-movie"/>
    <segment-item src="F:\svcd\menu3.mpg" id="seq5-movie"/>
    </segment-items>

    <sequence-items>
    <sequence-item src="F:\svcd\menu1tomenu2.mpg" id="seq2-movie"/>
    <sequence-item src="F:\svcd\menu2tomenu3.mpg" id="seq4-movie"/>
    <sequence-item src="F:\svcd\mpeg1.mpg" id="seq6-movie"/>
    <sequence-item src="F:\svcd\mpeg2.mpg" id="seq7-movie"/>
    ..etc

    So I basically just added the <segment-items> section and moved my "menu choice" mpegs into the section, saved the XML, brought it into vcdxbuild and created the bin/cue with that and voila.

    If I import the XML into VCDWizard and immediately export it and examine it, I see that VCDWizard is REMOVING my <segment-items> section and moving the stuff that was in it into the <sequence-items> section. Anyway, I'm rambling.. just wanted to post this in case someone else out there runs into this problem...
    Quote Quote  
  4. I have ran in to this problem recently and it has also been driving me nuts, I have a Mintek-1600 which I know from friends who have Apex players that there is similarities in the software that runs it. Anyway now I am hoping that your fix will work for me too, I am off to try it out now!! Thanks!
    Quote Quote  
  5. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    VCDEasy is just doing what it expects is the default setup for (S)VCD's--the moving video goes into sequence items (tracks) and the still video goes into segments. Now, of course, still's aren't supported as tracks, but moving video IS supported as segments. It seems this is what you were wanting.
    The easy way to switch this is to add the items to VCDEasy's main screen as usual, and after it has scanned the item(s), all you do is check or uncheck the checkbox next to the items (that's what it's there for), depending on where you want it to reside.
    And yes, MANY players will baulk at PBC navigation if the segment area isn't populated.

    Hope everythings working now...
    Scott
    Quote Quote  
  6. Originally Posted by Cornucopia
    VCDEasy is just doing what it expects is the default setup for (S)VCD's--the moving video goes into sequence items (tracks) and the still video goes into segments. Now, of course, still's aren't supported as tracks, but moving video IS supported as segments. It seems this is what you were wanting.
    The easy way to switch this is to add the items to VCDEasy's main screen as usual, and after it has scanned the item(s), all you do is check or uncheck the checkbox next to the items (that's what it's there for), depending on where you want it to reside.
    And yes, MANY players will baulk at PBC navigation if the segment area isn't populated.

    Hope everythings working now...
    Scott
    I tried checking and unchecking the boxes and that does not make any difference. I also tried to manually edit the XML file but that doesn't work either, I get errors when I try to build the BIN file and it will not complete.
    Quote Quote  
  7. Member Cornucopia's Avatar
    Join Date
    Oct 2001
    Location
    Deep in the Heart of Texas
    Search PM
    Why don't you give us an example of the XML to scrutinize? We might be able to find out a conflict or something...

    Scott
    Quote Quote  
  8. I found out what the problem was!!!! So I don't kill a bunch of CD-R's I have been using a CD-RW disc to test things out on. Well finally I decided that just maybe that was part of the problem, and low and behold I was right. I authored a test cd to a regular CD-R and all my menus, interactivity, everything, works just fine!! For some reason when I write to the CD-RW my DVD player turns off PBC and so it doesn't function as it should. Finally after a week of tearing my hair out I cna get on with making some quality VCD's at last!! woo hoo!!!
    Quote Quote