VideoHelp Forum

Our website is made possible by displaying online advertisements to our visitors.
Please consider supporting us by disabling your ad blocker or buy PlayOn and record Netflix! :)
+ Reply to Thread
Results 1 to 10 of 10
  1. I purchased my panasonic DMR-E50 from Circuit City about 3 months ago. no less than 2 weeks after owning the thing I started recording a DVD and about 2 minutes into the disk I hit stop because I realized I was recording the wrong thing. The data processing went through, you know, the normal stuff, and when the capturing thing got to 100% it just froze there. I got kind of worried after a few minutes, and tried everything as far as buttons on both the remote and the unit itself. My last resort was to unplug it. When I plugged it back in it said "recovering" like it does when a recording messes up, but this time when I hit OPEN after it was done the display said OPEN but the tray did not open, and then the display said CLOSE and just stuck there. I went through about 10 minutes of pressing all the buttons I could and then unplugging and replugging the unit to only get the same results. I decided after that to bring it back to Circuit City (they have a 30 day return policy) I traded it out for the same unit, and also picked up the service plan (good thing I did) I went home and started right where I left off with my recordings, and everything was fine... Until today. Same exact problem, but this time it happened differently. I was recording someting using Flexible-Record (which I was using the first time, too) and about 20 minutes after I started I noticed that the DVD recorder's time had only gone to 48 seconds. SO I knew something was wrong. Same deal as before where none of the buttons would work. This time I actually found a way to eject the disk (I had to hold the power key down for 10 seconds to turn off the machine and then pressed OPEN without even turning it back on and I got my DVD back) The problem now is if I reinsert media (a different disk I may add) it says "This disk is only formatted for playback and not recording" This is with all blank disks now, and I also can't eject them once they're in without doing what I said earlier with the holding down the power button for 10 seconds. I am going to go to Circuit City again tomorrow to pick up a THIRD recorder.

    Basically what I am wondering is if anyone else has ever heard of this problem, and if so what should I do in the future to avoid it. The only thing that was consistant in the two instances is that I was using Flexible-Record both times, the first time I was recording DVD->DVD-R and the 2nd time I was doing VHS->DVD-R, so that's not common.

    Thanks in advance for your help.

    Quote Quote  
  2. Wow ! That sounds like serious problem..... Goos to know.

    I don't know how they mark these thigs, but if there is somebody with same problem it would be good to find manufacturing date and place (if there is that information) Matbe they have bad batch in your store. Who knows.
    Quote Quote  
  3. Well I was thinking that and also hoping that, because the return was made so soon after the 1st purchase I assume the first 2 units were from the same batch. Also, when I got the 2nd unit it was the last one. So I am hoping that the new one I pick up tomorrow will be from a different batch that don't have this problem.
    Quote Quote  
  4. Lucky for me my E50 has never done that. I suggest you try a different brand of media on the third recorder is case it's a media problem.
    Quote Quote  
  5. I have 100 disks of the media I use sitting at home I actually did try a different brand a few days ago, and all it did was "RECOVERING" every 30 seconds. I couldn't successfully record anything on it. (that was TDK) and The brand I have always used and always had a lot of success with is the Imation ones. I also used Verbatim at first which seemed to work pretty well too, but I don't like those because I label my DVDs with white labels and the Verbatim logo shows through and looks kinda crappy. I think I'm going to stick with Imation at least until I use all 100 of these disks up. What other brands do you suggest?
    Quote Quote  
  6. All the media you are using is just fine. It's just very strange that the first two recorders had similar problems back to back. I mean the odds of that are slim to none IMO. Maybe you're doing something in the recorder setup that is causing the problems. Anyway good luck with the third player.
    Quote Quote  
  7. What could cause the problems in the setup? I got the 3rd recorder today btw, no problems yet
    Quote Quote  
  8. Last week I bought an E50 and al was well untill I tried a cheap unbranded disc and had exactly the same problems as above.
    Luckily I managed to eject the disc after removing the power lead and then replacing it, when recovering began I pressed the eject button once, after about 30 seconds the disc ejected.

    I only use quality Panie discs now ( available very cheaply from

    Moral of story if you put s**t in you get s**t out.

    Hope this is of help.
    Quote Quote  
  9. It should have come with a Panasonic dvdrm disk why don't you try that? Always try the media that is made by the same people. The messages you get show to me that the media isn't compatible. The media I use, Accus, are only 80 cents per disk & work 100%.
    Quote Quote  
  10. Datawrite Yellow 1x DVD-R discs work great too and they only cost around 17 for 25 assuming you can still get them somewhere in the UK.


    P.S. Don't use Datawrite Yellow 4x DVD-R discs as I heard theres been a few problems using them in the E50 recorder.
    Quote Quote  

Similar Threads