VideoHelp Forum
+ Reply to Thread
Results 1 to 24 of 24
Thread
  1. Dear VideoHelp,

    First of all, I'm not completely sure if my test video is breaking the rules or not. I like to collect clips of my favorite scenes in movies and watch them over and over again. The particular problem I'm having is from movies captured from a television. So if I am breaking the rules I apologize and please forgive me.

    I have had a problem where my MJPEG AVI file shows up in avidemux discolored and dark. I looked around on the net and found what I thought was a solution which was to go to the avisynth color setting and change it to PC>TV, which made it worse. I then tried TV>PC and that definitely brightened it up and I thought I'd fixed it. I only noticed recently when I saw a film in technicolor which made the color difference much more noticeable. I've spent hours testing different settings and trying to figure out what is wrong.

    I have nailed down the problem but I have limited knowledge or technical ability when it comes to video conversion or computers in general. What I have found is that if I export a frame as a jpeg the colors appear absolutely fine. When I view the video in the avidemux preview or in the rendered x264 output file they are dark and discolored. I think maybe this means that I'm having a playback issue? But I have no problem with any other h264/x264 videos that I have made in other video editors or that have been made by someone else.

    Here's the media info on the original file:
    General
    Complete name : D:\Movie Stuff\TEST\ULTIMATETESTFILE.avi
    Format : AVI
    Format/Info : Audio Video Interleave
    File size : 263 MiB
    Duration : 26s 26ms
    Overall bit rate : 84.8 Mbps

    Video
    ID : 0
    Format : JPEG
    Codec ID : MJPG
    Duration : 26s 26ms
    Bit rate : 83.2 Mbps
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate : 29.970 fps
    Color space : YUV
    Chroma subsampling : 4:2:2
    Bit depth : 8 bits
    Scan type : Interlaced
    Scan order : Top Field First
    Compression mode : Lossy
    Bits/(Pixel*Frame) : 1.338
    Stream size : 258 MiB (98%)

    Audio
    ID : 1
    Format : PCM
    Format settings, Endianness : Little
    Format settings, Sign : Signed
    Codec ID : 1
    Duration : 26s 9ms
    Bit rate mode : Constant
    Bit rate : 1 536 Kbps
    Channel(s) : 2 channels
    Sampling rate : 48.0 KHz
    Bit depth : 16 bits
    Stream size : 4.76 MiB (2%)
    Alignment : Aligned on interleaves
    Interleave, duration : 25 ms (0.74 video frame)
    Here's the media info from the file converted to x264:
    General
    Unique ID : 251429839052319456002713959540601366463 (0xBD27A026F33EC454E2551BEBBC53A7BF)
    Complete name : D:\Movie Stuff\TEST\ULTIMATETESTFILEinterlacex264.avi
    Format : Matroska
    Format version : Version 2
    File size : 54.3 MiB
    Duration : 26s 59ms
    Overall bit rate : 17.5 Mbps
    Movie name : Avidemux
    Writing application : Lavf53.24.0
    Writing library : Lavf53.24.0
    AUTHOR : Avidemux

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 4 frames
    Codec ID : V_MPEG4/ISO/AVC
    Duration : 26s 59ms
    Bit rate : 16.9 Mbps
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 29.970 fps
    Standard : NTSC
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.272
    Stream size : 52.5 MiB (97%)
    Writing library : x264 core 120 r2120 0c7dab9
    Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=dia / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=20.0 / qcomp=0.60 / qpmin=0 / qpmax=51 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
    Default : Yes
    Forced : No
    Matrix coefficients : SMPTE 240M

    Audio
    ID : 2
    Format : AC-3
    Format/Info : Audio Coding 3
    Mode extension : CM (complete main)
    Format settings, Endianness : Big
    Codec ID : A_AC3
    Duration : 26s 59ms
    Bit rate mode : Constant
    Bit rate : 224 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Bit depth : 16 bits
    Compression mode : Lossy
    Delay relative to video : -33ms
    Stream size : 713 KiB (1%)
    Default : Yes
    Forced : No
    I have tried viewing in media player classic and windows media player and they look the same. Both are discolored and dark.

    I have attached 2 screenshots to show what it looks like. Number 1 is a jpg exported from avidemux. The other is from windows media player.
    Click image for larger version

Name:	1wmp.jpg
Views:	81
Size:	389.2 KB
ID:	27218Click image for larger version

Name:	1.jpg
Views:	79
Size:	214.9 KB
ID:	27219

    I appreciate any reply even if it's to tell me that I'm stupid.
    Last edited by Plz Help B4 I Kill Myself; 1st Sep 2014 at 17:55. Reason: Pressed tab+space on accident and posted.
    Quote Quote  
  2. MJPEG and JPEG usually use the full luma range (0 to 255). Almost all other video formats use a limited luma range (16 to 235). So when converting MJPEG to other video types you need to compress the luma range. Not all players realize that MJPEG has full range luma and play it properly. And if you set up your system to display full range MJPEG properly it may be misconfigured for displaying most other video.

    To advise you further we would need to see a sample of your source. Are these something like Black Magic Intensity Pro captures?
    Quote Quote  
  3. Originally Posted by jagabo View Post
    MJPEG and JPEG usually use the full luma range (0 to 255). Almost all other video formats use a limited luma range (16 to 235). So when converting MJPEG to other video types you need to compress the luma range. Not all players realize that MJPEG has full range luma and play it properly. And if you set up your system to display full range MJPEG properly it may be misconfigured for displaying most other video.

    To advise you further we would need to see a sample of your source. Are these something like Black Magic Intensity Pro captures?
    Thank you for replying!I have the Black Magic Intensity Shuttle and I captured the video with Blackmagic Media Express. I remember reading about the luma range and I have messed with all kinds of settings. This is what I've done so far: Adjusted the LAV video decoder settings for RGB Output levels from TV (16-235), PC (0-255), to untouched (As Input). Neither of those helped. (They could be unrelated I don't know what I'm doing.) I forced 0-255 range in the nvidia graphics drivers settings. (Assuming I did that correctly.) I have attached the video file to this post. (Hopefully I have done it correctly.)
    Attached Files
    Last edited by Plz Help B4 I Kill Myself; 1st Sep 2014 at 19:11. Reason: I forgot to thank the wonderful person who replied to my post.
    Quote Quote  
  4. The sample video has darks all the way down to zero. Brights don't get much brighter than 210 or so. I don't know if that's the nature of that scene of if you need to adjust the capture devices proc amp to bring the bright level up.

    So, unless your proc amp it badly maladjusted, you can assume the MJPEG video is full range YUV. Normally when converting to standard video formats like MPEG 2 or h.264 you would convert from full range to video range, 0-255 to 16-235. That would be ColorYUV(levels="PC->TV") in AviSynth.

    I don't know if the colors should be rec.601 or rec.709. When I use ColorYUV(levels="PC->TV").ConvertToRGB(matrix="rec709") I get this:

    Click image for larger version

Name:	rec709.jpg
Views:	26
Size:	164.6 KB
ID:	27236

    I believe that's how the picture should be displayed. The reds are brighter and the skin tones more reddish than when using rec601. You could also get that same output with a single command ConvertToRGB(matrix="PC.709"). But you wouldn't want to convert to RGB when recompressing the video.
    Quote Quote  
  5. jagabo, I must thank you for your help! I barely understand what you're telling me but I've spent my time googling the information. I see that you've definitely solved the problem. It even appears to me that you've masterfully deinterlaced it. It looks like your image has less of the deeper reds and less of the green than the original, but from what I gather from what you're saying is that your image is what it probably SHOULD look like, that it's possible there might be something wrong with my capture device settings. I do have an option in the control panel software thingy for "Calibrate Analog Video In" showing two sliders labeled "Video" and "Chroma". They are currently set at 0db. As you mention, it could be that the scene from the movie is just the way it is. I'm not sure how to check whether it's the scene or my capture device. I do not know how to use AviSynth at all, but I'm going to give it my best darn shot to try and learn how to use it.

    I have tried messing with settings in AviDemux, though. At first I went to the "Scripting Shell" option in Avidemux 2.6.8 and entered in what you wrote. This came up with some errors saying "file1" or something to that degree. I'm under the assumption that this is a function that is beyond my understanding and that it may even be used for something else entirely. After that nonsense, I added the AviSynth Color filter in Avidemux 2.6.8 and set it to PC->TV again. This made it even darker on the file and when I view it in a video player. Here's the exported jpg from avidemux:
    Click image for larger version

Name:	1abc.jpg
Views:	18
Size:	165.2 KB
ID:	27238

    So I remembered that before, in the past, I had downloaded Avidemux 2.5.6 and recalled that this version was quite a bit different. I placed the video in this and I could see the kinds of settings you were talking about. I added the Avisynth colorYUV filter and I had different options available to me. For the "Matrix" drop down I chose Rec.709 and for the "Level" drop down I chose PC->TV. That looks pretty close to the original except it appears slightly brighter. It also looks much worse than yours but perhaps that's because I don't know which interlace filter to choose or maybe I didn't encode it in a high enough quality. I've been using bicubic deinterlacing as it looked better than the others. Yadiff I have seen is more popular but when I use it, there appears some blockiness to edges. Here's that pic:
    Click image for larger version

Name:	1ab.jpg
Views:	16
Size:	142.1 KB
ID:	27239

    I then used the same settings but instead of choosing PC->TV, I tried the option below which was "PC->TV.Y" This looked a bit more like yours but it still has the same problem.
    Click image for larger version

Name:	2b.jpg
Views:	14
Size:	145.4 KB
ID:	27240

    What I don't understand is that when I view them in Media Player Classic or Windows Media Player it looks more orangey and different. Like here:
    Click image for larger version

Name:	1awmp.jpg
Views:	18
Size:	351.9 KB
ID:	27241
    Quote Quote  
  6. I just checked out AviDemux 2.6.8. The AviSynth PC->TV and TV->PC functions are implemented backwards! So you would want to use TV-PC in AviDeumx. But... the filter is causing a shift in the U channel -- all U values (after the TV->PC) are shifted up by 4 units. That's causing the differences in color you are seeing. I thought I might be able to use the individual U adjustments in that filter to fix the problem -- but they aren't implemented. I also tried using just the Y contrast adjustment (those are implemented) instead of TV->PC but the U channel was still shifted up.

    Finally I tried the Contrast filter instead. I was able to get close to the correct levels and chroma without otherwise screwing up the picture. Unfortunately, the Contrast adjustment on that dialog is very crude, moving in 10 percent increments. I set it at 90 percent (touch the Contrast slider and press the Left Arrow key once). The Brightness I set at 16 (touch the slider and press the Right Arrow key 16 times). Leave Y, U and V checkmarked. That gave a black level that was correct but the bright level was a bit high, and saturation a bit too high. That wasn't really a problem for this particular clip since it didn't have very bright brights. Brighter clips might show some clipping of the brights. For a more exact fix you would need to reduce luma contrast to about 86 percent, chroma values to about 88 percent. But the filter doesn't allow that.

    There are other issues -- the black magic series stores the fields in the wrong position. The "top" field is below the "bottom" field instead of above it (I don't think AviDemux has a fix for that). You could encode the video interlaced but an inverse telecine back to 23.976 fps film frames would be better. AviDemux has Decomb Telecide and Decome Decimate in the Interlacing filter -- but it crashed every time I tried to use it.
    Quote Quote  
  7. jagabo, you're a fine human being. Your solution, while not a perfect fix, definitely looks better than before! I have tried the older version of the program Avidemux 2.5.6 and the color filter there allows you to adjust y, u and v levels both positively and negatively. It has 4 different adjustments for the Luma Y, Chroma U, Chroma V, which are: Contrast, Brightness, Gamma and Gain. I've been adjusting these for the past hour to try and make it look better but I have no more time to spend on it. I shall be testing this out more tomorrow. If I can't get it to look like the original, I will start searching the internet on how to use AviSynth and then adjust the settings to your exact fix. Thank you ever so much for all your help!

    Edit: I forgot to mention that in Avidemux 2.6.8 when I try to inverse telecine back to 23.976 fps it crashes for me to. I'm able to do it in Avidemux 2.5.6 but it still looks interlaced or perhaps blocky. I guess it's because the fields in the wrong position like you said.
    Last edited by Plz Help B4 I Kill Myself; 2nd Sep 2014 at 21:51. Reason: I forgot to address the deinterlacing issues.
    Quote Quote  
  8. Originally Posted by Plz Help B4 I Kill Myself View Post
    Edit: I forgot to mention that in Avidemux 2.6.8 when I try to inverse telecine back to 23.976 fps it crashes for me to. I'm able to do it in Avidemux 2.5.6 but it still looks interlaced or perhaps blocky. I guess it's because the fields in the wrong position like you said.
    Yes, the problem is the position of the fields. Most MJPEG decoders have an option to swap fields. But I couldn't find such an option in AviDemux. AviSynth has one. VirtualDub has one.

    There's some other oddness with the chroma channels. Even after swapping the fields the chroma channels are out of order. I haven't figured out exactly what the problem is yet. You can probably avoid it by setting the MJPEG compressor to work in YUY2 (aka YUV 4:2:2, YUYV) rather than YV12.
    Quote Quote  
  9. Well, I've been trying a few things with the information of your last post. I used the Blackmagic Media Express capture program to capture a new test video. I tried capturing in "AVI Motion JPEG" and "AVI 8-BIT YUV". (I tried to see if there was some way to change the MJPEG compresser to work in YUY2 but I couldn't see any options for that.) When I put the AVI 8-BIT YUV file in Avidemux it works perfectly! The only thing I have to do is swap the U and V color channel thingies. The yadiff deinterlacing even worked perfectly too! The MJPEG still has the same problem.

    I downloaded VirtualDub and tried to capture with that to see if it made a difference but it crashed my computer with a blue screen twice. I think it's safe to say that VitrualDub and Blackmagic Intensity Shuttle are not the best of friends. I scrapped that idea because blue screens frighten me. I then tried to edit the test video we've been working on here. When I opened it at first I fainted because the colors were perfect and nothing seemed to be wrong. Once I came to, I started by swapping the fields and deinterlacing it. The colors were fine but the deinterlacing looked like it did before. I removed the swap fields and now I get a perfect image. The only problem is if I choose MJPEG compression in the compression settings in VirtualDub, export the video, then open it up with AviDemux, the same problem exists! In Avidemux the fields and YUV color stuffs are all pooped up again! So I tried a different compression method called Microsoft Video 1 and that darkened the video slightly and didn't look absolutely right. I put that file into AviDemux and had the same problem as before. I then tried the Blackmagic HD 8-bit YUV compression method and put that file into Avidemux which gave me a blank green screen. I finally tried the Uncompressed compression method (Which I guess isn't exactly a compression method but I think you know what I mean.) and I put that file into Avidemux and it appeared upside down, so I used the vertical flip filter and encoded it. It came out darker and it was slightly squished as you can see here:

    Original:
    Click image for larger version

Name:	4thegreatone2.jpg
Views:	18
Size:	422.4 KB
ID:	27254

    Dark and Squishy:
    Click image for larger version

Name:	4thegreatone1.jpg
Views:	19
Size:	371.3 KB
ID:	27255

    The only problem I have with these methods is that the output files are so large. Recording with Blackmagic Media Express, an 8-bit YUV video at 1 minute is just above 7gbs! When exporting uncompressed in VirtualDub, it's 3.61gbs for the 26 second ULTIMATETESTFILE.avi. I can accept this as a fact of life if the MJPEG is unfixable but it sure is a lot of work. I suppose it's probably worth it because of the content's wonderfulness though.
    Quote Quote  
  10. What MJPEG encoder were you using with VirtualDub? Go to it's configuration dialog and see if there is a "swap fields" option. Also look for an "interlaced" option. It often appears as "Assume interlaced if height greater than [___]". 288 is a good value for that.
    Last edited by jagabo; 3rd Sep 2014 at 12:47.
    Quote Quote  
  11. Originally Posted by jagabo View Post
    What MJPEG encoder were you using with VirtualDub? Go to it's configuration dialog and see if there is a "swap fields" option. Also look for an "interlaced" option. It often appears as "Assume interlaced if height greater than [___]". 288 is a good value for that.
    I was using "Blackmagic 8 bit MJPEG Codec." I think it's the same codec that I'm using with the Blackmagic Media Express program. I looked at the options in VirtualDub and it looks like I'm unable to configure the codec. When I click the About button it just gives me what looks like a version number.

    Name:  virtualduboptions.jpg
Views: 95
Size:  93.4 KB

    I might have information that may help. (Or I may not. I'm really just clicking things untill they work.) I've installed ffdshow and x264vfw for VirtualDub and have noticed something. I encoded a video in x264 format and it came out in the same orangey dark mess as before so I looked at the x264vfw configuration settings. One of the drop down boxes said "Convert YUV 4:2:0", I switched that to "Keep Input Colorspace". That had the same results. I then selected "Keep/Accept only RGB" and that came out perfectly! I then took a look at the Color depth options under the video tab in VirtualDub. The Decompression format is set to "Autoselect" and Output format to compressor/display is set to "24 bit RGB (888)". I don't know what any of this means for I know less about video editing and converting than a peanut butter sandwich. From what I've learned in the thread I have a basic understanding of the differences of RGB and YUV but only in the sense that RGB consists of Red, Green, Blue and that YUV has the Luma Y, Chroma U, and Chroma V. That's all though.
    Quote Quote  
  12. The BlackMagic HD 8 bit 4:2:2 Codec should be YUY2.

    The chroma problem I was seeing earlier was an issue with ffdshow's decoding. Forcing it to output YUY2 has fixed it. The video itself appears to be encoded in YUY2 4:2:2 mode. How does the attached file look on your computer (video only)? The colors wander around a bit but I guess that's in the broadcast. Unless the BMI Shuttle has automatic levels/colors controls you can disable.

    The attached file was made with AviSynth and the x264 command line encoder. But I think I can get VirtualDub to output a similar video.
    Attached Files
    Quote Quote  
  13. Your video looks slightly orangey on my screen. Atleast, the red colors look more orange than the deeper color red in the original. I am quite certain the color wandering is part of the movie. It's fairly common for movies from that era. I tried to match your video by using the YUY2 settings and it looks just like yours does. (except not as good visually because I don't know how to encode properly.) Does this mean that I need to change a decoder setting?

    Just to make sure we are seeing the same thing, this is what your video looks like on my computer via WMP:

    Click image for larger version

Name:	jagabovideo.jpg
Views:	13
Size:	343.7 KB
ID:	27264

    I've attached a video that I encoded with the RGB setting. I see why this is a bad idea because it was more than twice the size as the YUY2 4:2:2 file. (Actually, this was probably my fault. I don't know how to use the x264 encoder and I'm pretty sure I'm ruining the settings.) But the colors in this video look EXACTLY like the original video on my computer.
    Attached Files
    Last edited by Plz Help B4 I Kill Myself; 3rd Sep 2014 at 20:25. Reason: Needed to explain the colors better and explain my encoding inadequacy.
    Quote Quote  
  14. Here's a video with the same processing, but flagged as rec.601. The video never left YUV so the only difference is the flag that tells the player how to play it back. Not all players respect the flag.

    VirtualDub has a built in MJPEG decoder and it outputs the frames without the field swap problem. Here's how you can use it:

    1) Start VirtualDub.
    2) Go to Options -> Preferences -> AVI (left pane), enable "Prefer internal video decoders..." (right pane), press Save.
    3) It might be necessary to exit and restart VirtualDub at this point, can't hurt.
    4) Go to Video -> Color Depth. Set both the Decompression Format and the Output Format to "4:2:2 YCbCr YUY2". Press "Save as default" if you want it to remember this setting.
    5) File -> Open Video File
    6) Video -> Filters, Add..l IVTC. When asked, select Reduce Frame Rate, Top Field First (Autodetect should work too). Leave Pattern phase at Adaptive.
    7) Back at the Filters dialog enable the Show Image Formats option in the lower left corner. In the list of filters you should now see what colorspace each filter is operating at (you only have one filter, IVTC, if you're following these instructions). IVTC should show YUYV (same as YUY2).

    Back at the main interface you should now have a properly inverse telecined view in the output pane (you can swap the panes with View -> Swap Input/Output Panes.. It shouldn't have any chroma errors or comb artifacts.

    If you use x264vfw to compress this video you should specify the color matrix in the Extra Options box. For rec.601 enter "--colormatrix=bt470bg", for rec.709 enter "--colormatrix=bt709":

    Name:  extra.png
Views: 85
Size:  52.9 KB
    Attached Files
    Quote Quote  
  15. Oh, I forgot to address the PC vs REC brightness issue in the VirtualDub instructions. The Brightness/Contrast filter works in YUV so you can use it to come close with the levels (the Levels filter works in RGB so you can't use that). Add the Brightness/Contrast filter after IVTC. Set the Brightness to about 7 percent -- that's about at first marker to the right of the center marker on that slider. Set the Contrast to 87%, that's about half way between the center maker and the one to its left. That will get you very close to REC levels.

    Name:  filters.png
Views: 84
Size:  27.5 KB
    Quote Quote  
  16. Woohoo! jagabo, it worked. I ran into some problems though. Your video works great and definitely looks like the original. I followed the instructions exactly but I had a problem trying to save it as an AVI. When it started to encode it gave me error -100 or something like that. I kept messing with the encoding settings but it still didn't work. I closed the program and started up the 32 bit version of VirtualDub and followed the instructions step by step again. I noticed that after I added the inverse telecine the preview image became dark again but I ignored it. When I encoded it with the settings you gave me it came out still the same dark way.

    I then went back to the 64 bit version to give it another go and suddenly the preview was dark for that video too. I decided to untick the box you told me to tick in the preferences that says "Prefer internal decoders..." and everything was fixed. I then proceded to follow the steps again without the prefered internal decoders and it worked flawlessly. I didn't even have to use the added step in post 15, although I have saved the information for later in case I have done something wrong.

    An added note: I couldn't get the swap input output preview to work properly. I'm not even sure the output preview was even working at all. It just sticks to the frame I started and stopped at, still looking interlaced.

    Thank you so much for your help jagabo! This problem has been keeping me awake at nights, which I know is ridiculous, but I couldn't help it. I've learned so much so far in this thread about color spaces and deinterlacing as well! In VirtualDub I was using two IVTC filters one to decomb then one to reduce thinking it worked the same as AviDemux. (Doh!) I imagine this is a common mistake since you emphasize in your instructions that I should only have one filter.
    Quote Quote  
  17. I don't know what was up with the internal MJPEG decoder in VirtualDub. I was using version 1.10.4 but I don't the decoder has changed in quite a while.

    Regarding different intensity/color in the view panes: I would try turning off DirectX display in VirtualDub. That can lead to different views depending on how your system is set up. Go to Options -> Preferences -> Display... and untick the Use DirectX... option. Press Save to save the setting. I think you have to restart VirtualDub for the change to take effect. After that change VirtualDub will always convert YUV to RGB using a rec.601 matrix for the display panes -- this has no effect on other video filtering.

    Regarding the view panes: you can right click on the panes and select Zoom -> 50 percent (or whatever scale you want) to reduce the size so you can see both panes. Each pane has its own Zoom setting. File -> Preview Input (also the little [>I] button at the bottom left) shows the input video with no processing in only the input pane. File -> Preview Output (the [>O] button) displays both the input video and the filtered video in their respective panes. Playback may not be smooth if your computer isn't fast enough to perform the filtering in real time.

    I never use the 64 bit Version of VirtualDub because most of the third party filters aren't available in 64 bit versions. There's not really any advantage to the 64 bit version.
    Quote Quote  
  18. Something to keep in mind: Someone brought up the issue of whether the graphics card is set up to use its own proc amp settings, or the application's proc amp settings, can lead different levels when viewing different videos:

    http://forum.videohelp.com/threads/366677-Best-way-to-Re-encode-Canon-5D-mov-file-afte...=1#post2344274

    In case you're not aware: Media players usually decompress video to YUV and send that to a frame buffer on the graphics card. The graphics card converts that YUV to RGB for the monitor. As it does that conversion it can apply filters, including levels adjustment. It can be set to use it's own proc amp settings for the levels adjustment, or use settings specified by the player. A player may be able to detect whether the source uses REC or PC levels and then tell the graphics driver which matrix to use for the RGB conversion.
    Quote Quote  
  19. I still can't get the internal MJPEG decoder to work properly, it makes the video darker like it does in avidemux. It doesn't seem to mess with the colors though. I did turn off DirectX display in both the 64bit and the 32bit versions. (I will just use the 32 bit though from now on since that's what you use.) I restarted VirtualDub each time I changed the settings too. I'm not too worried about this not working though because if I leave the internal MJPEG decoder unchecked it works absolutely perfectly!

    Thank you for the information on the view panes. Before I was having a problem where the output pane looked exactly like the input pane which wasn't very helpful. I see now that there is a play button for both the input and the output, silly me! Now it seems to work without any problems. (Although, it's not super smooth but that's probably my computer. It's definitely smooth enough!) I also like that you can lock the ratio of the view pane because before I would resize it and it would ruin the picture.

    In the Nvidia Control Panel settings, I have it set "With the NVIDIA settings" Full (0-255) for both monitors. (The other monitor is my television.) Switching it to "With the video player settings" didn't seem to change anything. (Unless I have to restart my computer? I didn't think I had to.) The videos that came out dark still look dark and the videos that are perfect still look absolutely perfect.

    Thanks again for all your help, jagabo! Not only do my movie clips look unreasonably and absurdly beautiful, they're also much smaller in file size and still have the same quality! I know they're just videos but they're fairly important to me!
    Quote Quote  
  20. Originally Posted by Plz Help B4 I Kill Myself View Post
    I still can't get the internal MJPEG decoder to work properly, it makes the video darker like it does in avidemux.
    Super darks (and super brights) should be crushed in the view panes because VirtualDub always uses a rec.601 matrix when it converts YUV to RGB for the display panes (again, that is separate from the filter chain). If you apply the Brightness/Contrast filter as specified earlier you should the see input pane with crushed black but the output pane should show dark details. In the following image I've increased Brightness by 15 percent (and Contrast to 87%) to make the change very obvious:

    Click image for larger version

Name:	bc.jpg
Views:	10
Size:	207.2 KB
ID:	27295

    You can see from the File -> File Information dialog that the internal MJPEG decoder is being used. In the output pane you can clearly see the difference between the black border and the dark background curtain on the left. And there is a little noise and detail in the dark curtain. In the input pane all that dark area is totally black (RGB=0). Try something similar and see if you get the same result. Verify on the Filters dialog that the filter is working in YUV. And make sure the input and output colorspaces (Video -> Color Depth) are set to 4:2:2 YCbCr.
    Quote Quote  
  21. I misunderstood what you were saying before. I think I understand now though. Internal MJPEG decoder does work it's me who doesn't! I did what you said and this was my result:

    Click image for larger version

Name:	VirtualDubCorrectBrightnessAndContrastInternalMJPEGWorks.jpg
Views:	17
Size:	530.1 KB
ID:	27303
    Quote Quote  
  22. So it's working now? Can you save as AVI?
    Quote Quote  
  23. Originally Posted by jagabo View Post
    So it's working now? Can you save as AVI?
    It's working now! I saved this AVI using the internal MJPEG codec and using the brightness and contrast settings you have given me. I am forever in your debt!
    Attached Files
    Quote Quote  
  24. Glad it's all working for you now.

    One thing to watch out for, some editors/players ignore the colormatrix flag and will display with whatever their default colormatrix is. Like the aforementioned VirtualDub.

    One other thing if you want to use other filters in VirtualDub, once you have reduced the luma range in you can safely use RGB filters. So I would use Brightness/Contrast first, just to be safe.
    Last edited by jagabo; 6th Sep 2014 at 21:58.
    Quote Quote