VideoHelp Forum
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Member
    Join Date: Aug 2014
    Location: Russia
    Search PM
    Hi guys, my name is Sergey, I`m russian, hence sorry for my english, hope you`ll understand everythinng.
    I need your help! My hobby is foreign languages - English and German. For practice I watch films in german and english, so usually for convenience I merge 3 sound streams (rus, eng, ger) in one mkv file. Bit now I`ve got a problem. I downloaded a film in mkv (Lord of the rings) in german language and the same in russian, demuxed them and tried to merge in one mkv file. As result I`ve got time mismatch between the video stream and the german sound stream, they`re not synchronous. According to MediaInfo App both mkv`s have framerate 23,976. The length on the russian version (part 1 - fellowship of the ring) is 3:48:18. The length of the german mkv file is 3:48:11. But both files are similar, they are ripped from Blu-ray, they begin from the new line cinema logo and both ends with the logo. Can`t understand where is to find this difference 7 sec. When playing the russian mkv with extracted german stream they are syncronous about first 110 minutes. After 110 minutes begins continuously growing desynchronization. Don`t understand how to compensate these 7 seconds and why it appears if both streams have 23,976 fps.
    As far as I know MediaInfo not always gives the right information about frame rate. I tried to convert the german dts stream to 23.976 via eac3to. Didn`t help. Then I disassembled the german dts file into wavs. The length of each wav is 3:48:18 - right what I need. I assembled all wavs via DTS HD Encoder Suite, choosed frame rate 23,976. It displayd, that the length of the new dts file with the frame rate 23,976 would be 3:48:04, too short for me. I changed fps to 25,000 and the final lengh changed to 3:48:17 - it`s almost what I need, 1 second shorter. I started encoding. But the final dts I`ve got is not 3:48:17, it is 3:44:17. Why?
    I just don`t understand what I`m doing wrong. Could you please help me? Thanks a lot guys and have a nice day!
    Quote Quote  
  2. Member
    Join Date: Jun 2012
    Location: USA
    Search Comp PM
    If you buy the BR instead of illegally downloading it, it will contain all the languages you need in sync.

    Discussing warez is against the rules here.
    Quote Quote  
  3. Member
    Join Date: Aug 2014
    Location: Russia
    Search PM
    Originally Posted by smrpix View Post
    If you buy the BR instead of illegally downloading it, it will contain all the languages you need in sync.

    Discussing warez is against the rules here.
    It is not quite right. I do have a legal copy on blu-ray (bought here), but the version doesn`t contain the german sound stream. Here is the list of languages on blu-ray:
    Russian Dubbed Dolby Digital 5.1
    English DTS-HD Master audio
    Thai Dolby Digital 5.1
    Portuguese Dolby Digital 5.1
    Polish Dolby Digital 5.1
    Czech Dolby Digital 5.1
    Hungarian Dolby Digital 5.1
    No German, as you see. I can even make photos of this blu-ray set, but this is not relevant now. The point is, I`d like to get this film with 3 languages on hard disk in mkv format. I extracted video and ru&eng audio streams from m2ts files and would like to add the german translation and pack up all this into one mkv file for each part.
    I found out what is wrong: the information from MediaInfo is not correct. The german version I downloaded (only cause my legal version doesn`t have it, all I need is only german sound stream from it, nothing more) has according eac3to non-standard framerate:
    1. h264/avc 1280x536 23.970p (160:67).
    I tried to slowdown the whole mkv (eac3to c:\filename.mkv c:\filename_fixed.mkv -slowdown) ang got the following message:
    was asked to modify track2: to 23.976, but the original FPS is not supported.
    The question now is how to force eac3to to convert the file into 23,976 fps? Or maby another one program would fit?
    And I doubt it will help... thanks in any case, hopу to figure something out.
    Last edited by kenobi88; 6th Aug 2014 at 14:54.
    Quote Quote  
  4. There's a DSP for foobar2000 called SoundTouch which can be used with foobar2000's converter. It'll change the duration of audio while converting in increments of 0.01%. There's also an AC3 decoder plugin for foobar2000. You should find them all easily via Google.

    Alternatively, you could try using the stretch option in MKVMergeGUI to stretch only the German audio when muxing. Stretching audio can cause playback problems, but you might get away with it given you probably don't need to stretch it by very much at all. To stretch an audio track when muxing, open the existing MKV with MKVMergeGUI, add the German audio, select it in the lower pane, click on the "format specific options" tab, and there you'll find the option for stretching. The tooltip should explain the format to use. It might take a bit of trial and error to get it right, assuming it will sync eventually.
    Quote Quote