VideoHelp Forum
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Member THRobinson's Avatar
    Join Date: Aug 2009
    Location: Canada
    Search Comp PM
    Just curious... doesn't seem to affect anything but not sure why they're there...

    I have a file, I opened in MKVMerge, unchecked all the chapters, audio, and tags for tracks, then added in a different audio source. Video was fine, audio wasn't so just a quick swap.

    Oddly enough, I opened it back up and 2 of the tags are back

    Tags for track ID 0 (7 entries)
    Tags for track ID 1 (7 entries)

    Anyways... unchecked them and merged in a subtitle srt track that I forgot. Saved the file, and decided to make sure that the two tracks were gone, and now I have a 3rd one for ID 2.

    Attachments/Global/Chapter Editor tabs are all empty... not sure why it keeps adding them. Used the apps literally hundreds of times, never had this before.

    Any ideas?
    Quote Quote  
  2. Member
    Join Date: Sep 2012
    Location: Australia
    Search Comp PM
    They're track statistics tags for programs like MediaInfo to read. It saves them from having to pass through the entire file to figure out what's inside. The MKVMerge GUI was written before the tags were introduced and Mosu has admitted the program shouldn't display them the way it does. MKVMerge GUI is currently being rewritten and most likely the new version will either hide them or at least display them in a less obtrusive manner. MediaInfo is having a similar problem and we'll just have to wait for all the programs to catch up before the tags stop being a nuisance.
    Quote Quote  
  3. Member johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Open mkvmerge and click on muxing/add command line option and select --disable-track-statistics-tags from the drop down list and add and save as default for new jobs.
    I think,therefore i am a hamster.
    Quote Quote  
  4. Member THRobinson's Avatar
    Join Date: Aug 2009
    Location: Canada
    Search Comp PM
    Ah, so just wait for a new version then. Sounds good.

    Tried the command line option, but didn't make any difference.
    Quote Quote  
  5. Member johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    You didn't do it right,it worked for me,check that the line got added.You still have to remove the flags in a file that has them already,it won't add flags to new files.
    I think,therefore i am a hamster.
    Quote Quote  
  6. Member THRobinson's Avatar
    Join Date: Aug 2009
    Location: Canada
    Search Comp PM
    Muxing->Add command line options

    Drop down, pick "--disable-track-statistics-tags" and click add, shows up in the command line options field. Check 'save as default for new jobs' and click OK.

    Tried with the file open, without any files open, closed and reopened the app and checked, the command line is still there, opened the file again and the 3 tags are there. Unchecked the tags, remuxed to a new file. Opened the new file and the 3 tag lines are there again as well.

    Not sure what else to try but, I think the command line was done correctly... maybe just a messed up file?
    Quote Quote  
  7. Member johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Did you try it on a different video?
    I think,therefore i am a hamster.
    Quote Quote  
  8. Member THRobinson's Avatar
    Join Date: Aug 2009
    Location: Canada
    Search Comp PM
    So... I did do it right.

    Like the OP says ... "Used the apps literally hundreds of times, never had this before."

    I opened a few videos and doesn't show the tags at all. I've seen it a few times in the past where tags showed up when I used the app, unchecked them as well as the chapters and foreign subs/audio which is what I usually use the app for, stripping out unwanted stuff, and they're gone.

    This video file, they seem there to stay. Not sure if a new thing because a newer video, or maybe something wrong with the video... plays fine.
    Quote Quote  
  9. THRobinson,
    The process you describe sounds correct. It should remove the existing tags and not create new ones. I say that fairly confidently, given I've removed the existing tags in many MKVs that way. Why it's not working for you, I have no idea. When you first run MKVMergeGUI, before opening any files, what shows when you use the "Muxing/Show the command line" menu? Something like this?

    "C:\Program Files\MKVToolnix\mkvmerge.exe" -o "" "--disable-track-statistics-tags"
    Quote Quote