VideoHelp Forum
+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. I tried to load a clip into VirtualDub-MPEG2 and I got that standard "...can't find WMV3...need VFW...yada yada." After some Googling, it seemed I needed to install FFDShow (which I did).

    However, even after I go into the video configuration app and set the WMV field to WM9 or libavcode, I still get the error when trying to import into VirutalDub.

    Anyone know what I'm doing wrong? I already have both Divx and Xvid installed as well.
    Quote Quote  
  2. VH Wanderer Ai Haibara's Avatar
    Join Date: Jan 2006
    Location: Somewhere on VideoHelp...
    Search Comp PM
    ffdshow has two video configuration options in the Start menu. I'm not at a computer with ffdshow installed, but I believe that for VirtualDub (and anything else that may use the Video for Windows-style codecs, rather than DirectShow filters), you need to select the "VfW Configuration" option in the Start menu.
    If cameras add ten pounds, why would people want to eat them?
    Quote Quote  
  3. Originally Posted by Ai Haibara View Post
    ffdshow has two video configuration options in the Start menu. I'm not at a computer with ffdshow installed, but I believe that for VirtualDub (and anything else that may use the Video for Windows-style codecs, rather than DirectShow filters), you need to select the "VfW Configuration" option in the Start menu.
    Thanks for the info. However I opened VFW Configuration but I'm not seeing any VirtualDub settings there. I also checked into both the other Audio and Video Configuration interfaces that come installed with ffdshow but I'm not sure what should be checked.

    VirtualDub is saying it needs the codec, and I'm very sure I installed what it needs with ffdshow. I just don't know how to link them together so they communicate and make them work properly.

    Thanks a lot in advance!
    Quote Quote  
  4. You enable the WMV3 decoder in ffdshow's VFW decoder configuration:

    Name:  vfw.png
Views: 74
Size:  35.1 KB

    If you're running 32 bit VirtualDub you need 32 bit ffdshow. If you're running 64 bit VirtualDub you need 64 bit ffdshow.
    Quote Quote  
  5. Originally Posted by jagabo View Post
    You enable the WMV3 decoder in ffdshow's VFW decoder configuration:

    Attachment 26704

    If you're running 32 bit VirtualDub you need 32 bit ffdshow. If you're running 64 bit VirtualDub you need 64 bit ffdshow.
    Actauly, I think that might be the problem. I've enabled those settings in the past but my ffdshow is x64 and my VirtualDub is definitely not. However, I'm running VirtualDub-MPEG2 which has not been updated in some time. I use it because it has DVD/VOB import support.

    Can you recommend a newer x64 version that also has this feature that might work with ffdshow?
    Quote Quote  
  6. VH Wanderer Ai Haibara's Avatar
    Join Date: Jan 2006
    Location: Somewhere on VideoHelp...
    Search Comp PM
    Just install the 32-bit version of ffdshow. Both the 32-bit and 64-bit versions can coexist with no problems on a 64-bit Windows system. Then, you can continue to use VirtualDub-MPEG2, if you want.
    If cameras add ten pounds, why would people want to eat them?
    Quote Quote  
  7. I'm a Super Moderator johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Just use handbrake if you need to re-encode your dvds.
    I think,therefore i am a hamster.
    Quote Quote  
  8. Member
    Join Date: Jun 2007
    Location: United States
    Search Comp PM
    Either/or:

    1) Upgrade to the current Virtualdub and use the Directshow plugin

    2) Use Avanti or some such to convert the original audio to uncompressed WAV, then load that with Virtualdub's "Audio from other file" option.
    Quote Quote