VideoHelp Forum
+ Reply to Thread
Page 1 of 2
1 2 LastLast
Results 1 to 30 of 41
Thread
  1. I cam capturing 8MM from a sony handycam using a Plextor PX-AV100U (analog). No compression YUY2. Its raw untouched video. The raw video has the "lines" (see image)

    I know i'm not supposed to de-interlace when converting to DVD, but if I DONT, the video WILL show the lines ON THE TV (using a DVD)(see image)


    Name:  jagged.png
Views: 271
Size:  441.9 KB




    If I DO de-interlace, the DVD looks fine. Am I missing something?
    Last edited by halpme; 27th Jun 2014 at 12:20.
    Quote Quote  
  2. Banned
    Join Date: Nov 2005
    Location: United States
    Search Comp PM
    because you're playing the interlaced dvd on a computer monitor that is designed to only show progressive scan type video, any time you play an interlaced video on a progressive screen you will get those lines.

    if you were to play the dvd on a tv that outputs interlace content, then you wouldn't see any lines.
    Quote Quote  
  3. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    Can you post a few seconds of your source video showing some movement.
    Difficult to diagnose looking at the still.
    Quote Quote  
  4. Member
    Join Date: Jun 2012
    Location: USA
    Search Comp PM
    How are you playing the DVD? On a TV it should be fine, on a computer use a player with a proper deinterlacer such as MPC-HC.
    Quote Quote  
  5. I forgot to mention, the lines are showing up on the TV when played through the dvd. There seems to be no difference on tv.
    Quote Quote  
  6. Member
    Join Date: Aug 2006
    Location: United States
    Search Comp PM
    If the dimensions for the image you posted (674x470) match those from the video, your video is the wrong resolution for DVD. Video must be de-interlaced before re-sizing.
    Quote Quote  
  7. Originally Posted by halpme View Post
    I forgot to mention, the lines are showing up on the TV when played through the dvd.
    Then you're making the DVD wrong. TV is a native interlaced format as is your 8mm video. An interlaced DVD should look the same (aside from compression artifacts) as playing the 8mm video on the camcorder to the TV. To get help you need to outline each step of your process. And provide video samples of the capture, the MPEG 2 video, etc.
    Quote Quote  
  8. Member
    Join Date: Jun 2012
    Location: USA
    Search Comp PM
    Please post a short sample.
    Quote Quote  
  9. I am using virtual dub to capture and ConvertXtoDVD

    VirtualDub with no recompression YUY2. No filters. Capture device is AV100U (Directshow)

    ConvertX is pretty much the default settings.
    Last edited by halpme; 27th Jun 2014 at 12:12.
    Quote Quote  
  10. p.s. the sample was encoded in x264, with same issue in place.

    (would have used raw, but 88MB for 4 seconds? Doubt you guys wanted that
    Quote Quote  
  11. Member
    Join Date: Jun 2012
    Location: USA
    Search Comp PM
    I should have been more specific, please post a short sample of your unconverted capture.
    edit: cross post -- yes, that's exactly what we wanted -- before you introduced the possibility of more errors.

    The clip you posted shows interlaced video that says progressive in the header. It also plays bottom field first when it is actually top field first. The x.264 clip you posted is not DVD legal anyway, it needs to be mpeg2. Where did the cropping at the top and bottom come from?
    Quote Quote  
  12. The AVI still has the luma channels of the two fields relatively intact. The progressive x264 encoding has blended the two chroma channels together -- assuming they weren't blended together before encoding. Indications are that you should be able to make an interlaced DVD from the original cap. I suspect ConvertXtoDVD didn't identify your video as interlaced. See if you can override that and force it to treat the video as interlaced, top field first.
    Quote Quote  
  13. Originally Posted by smrpix View Post
    I should have been more specific, please post a short sample of your unconverted capture.
    edit: cross post -- yes, that's exactly what we wanted -- before you introduced the possibility of more errors.

    The clip you posted shows interlaced video that says progressive in the header. It also plays bottom field first when it is actually top field first. The x.264 clip you posted is not DVD legal anyway, it needs to be mpeg2. Where did the cropping at the top and bottom come from?
    Here ya go guys:

    unconverted raw capture sample
    http://www41.zippyshare.com/v/90021608/file.html


    The black bars on the top and bottom are from the Video > Capture Filter > Video Image.

    The bottom of the raw video has distortion at the bottom (which I read is normal) and I am using the above feature to mask it.
    Quote Quote  
  14. Also:

    Check out this sample in VirtualDub. Video AND Audio are set to direct stream copy (no filters set, and nothing else that I can think of)

    Why is the new video smoother? (but still crappy)
    Attached Thumbnails Click image for larger version

Name:	vdub.png
Views:	15
Size:	739.8 KB
ID:	25956  

    Quote Quote  
  15. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    I tried the wizard in the old TMPGEnc 2.5. This does recognize it, and sets top field first.
    Quote Quote  
  16. Click image for larger version

Name:	Deinterlace Setting.png
Views:	28
Size:	78.9 KB
ID:	25958

    ConvertXtoDVD has one of the best deinterlacers I know of.
    To most people it's a hidden setting they have never even heard about.
    Try checking the box before conversion and see if that works for you.
    Quote Quote  
  17. Originally Posted by transporterfan View Post
    Attachment 25958

    ConvertXtoDVD has one of the best deinterlacers I know of.
    To most people it's a hidden setting they have never even heard about.
    Try checking the box before conversion and see if that works for you.
    Thats exactly how i've been doing it. When I do this, the DVD looks fine. But am I sacrificing any quality?
    Quote Quote  
  18. Member Cornucopia's Avatar
    Join Date: Oct 2001
    Location: Deep in the Heart of Texas
    Search Comp PM
    Again, you should NOT need to do any de-interlacing. IF you captured & processed it correctly.

    Scott
    "When will the rhetorical questions end?!" - George Carlin
    Quote Quote  
  19. Shouldn't think so. You are just blending frames. Any deinterlacer does the same.
    There is little point using anything else unless you want to apply preprocessing filters like Denoise or sharpening.
    ConvertXtoDVD will compress anyway, losing quality (if it requires to). It depends on the length of the input video.
    Controlling ConvertX is almost impossible. It (more or less) compresses arbitrarily.
    Quote Quote  
  20. You do not want to deinterlace. Doing so will lose half the temporal resolution. The video will appear to flicker when motions get large. I don't know anything about ConvertXtoDVD but video editors usually have a function where you can view the source properties and change them when necessary. Make sure it's set to interlaced and top field first. If the program doesn't support interlaced video properly you should switch to something else.

    Standard DVD resolution is 704x480 or 720x480. You should capture at one of those frame sizes if you're making DVDs.
    Quote Quote  
  21. Ok, so i'm starting to think its maybe related to the capture hardware (Plextor PX-AV100U). Its an older device. I have used different software, all uncompressed captures, all output the same.

    When viewing the raw, uncompressed capture video with VLC and setting Video > Deinterlace > On & Deinterlace mode > Yadif

    The video SHOULD "clear up" as it would on a tv, no?
    Quote Quote  
  22. Originally Posted by halpme View Post
    Ok, so i'm starting to think its maybe related to the capture hardware (Plextor PX-AV100U)
    No, you have normal uncompressed YUY2 video. AVI files don't indicate if the content is progressive or interlaced. It's up to you to tell the editor which it is.

    Originally Posted by halpme View Post
    When viewing the raw, uncompressed capture video with VLC and setting Video > Deinterlace > On & Deinterlace mode > Yadif

    The video SHOULD "clear up" as it would on a tv, no?
    Only if it recognizes the video is interlaced (or you force deinterlacing).
    Quote Quote  
  23. I'm totally lost at this point.

    If I have normal uncompressed video, then why isnt it simply transferring to dvd appropriately?

    When using "Any Video Converter" and converting to mpg/dvd (with deinterlace unchecked), the "lines" are gone, but now there's ghosting behind moving objects. This appears on the tv as well.

    Wow, big mess of confusion.

    I just can't seem to grasp whats so unique about the captured video? Obviously something is incorrect, as i've used Any Video Convert and ConvertXtoDVD a hundred times for other video, just not captured video.
    Quote Quote  
  24. Like, I dont get it. If I have a normal uncompressed YUY2 video, then getting it into dvd shouldnt be problematic.

    What is it I need to do or am missing? Try different encoding/burning software?


    Does anyone else want to try and encode & burn that raw uncompressed sample?
    Quote Quote  
  25. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    Here's my encode of your one-second sample:
    Attached Files
    Quote Quote  
  26. Your video already has trails behind moving objects from an over aggressive temporal denoiser. YUY2 AVI encoded to NTSC DVD compatible specs with with HcEnc...
    Attached Files
    Quote Quote  
  27. Ill check those out when im back on a machine....

    ....its a big question but ill just ask.......can anything different be done in vdub while capturing to eliminate these issues? What would you guys suggest doing after capture?

    Obviously the goal is to get the dvd quality equivalent (or close) to the original tape if not better
    Quote Quote  
  28. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    Originally Posted by halpme View Post
    Ill check those out when im back on a machine....

    ....its a big question but ill just ask.......can anything different be done in vdub while capturing to eliminate these issues? What would you guys suggest doing after capture?

    Obviously the goal is to get the dvd quality equivalent (or close) to the original tape if not better
    The main problem is that it's interlaced but marked progressive in the header.
    It has to be treated as interlaced by the mpeg encoder otherwise it will terrible as you saw.

    You should be able to set up Hcenc in it's GUI to select interlaced encoding.
    Quote Quote  
  29. HCGUI doesn't support AVI files as input. He'll have to create an AviSynth script to open the source. And since HCGUI doesn't handle audio he'll have to convert the audio separately. Then maybe mux them together (depending on what DVD authoring software he uses).

    But after a little searching it sounds like ConvertXtoDVD doesn't support interlaced encoding. How can they charge $50 for such software with such a huge gaping hole?
    Quote Quote