VideoHelp Forum
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. Hello, I'm just wondering if I am encoding at a decent speed. It seems unbelievably slow to me, but I am new to this and really have no idea.

    I'm using the QTGMC plugin in Avisynth to deinterlace. Here is the log file from Simple x264


    Code:
    --- SYSTEMINFO ---
    
    Binary Path : C:\Program Files (x86)\MuldeR\Simple x264 Launcher v2
    Avisynth    : Yes
    VapourSynth : N/A
    
    --- SETTINGS ---
    
    Encoder : x264 (H.264/AVC), x64, 8-Bit
    Source  : Avisynth (avs)
    RC Mode : CRF
    Preset  : Veryslow
    Tuning  : Film
    Profile : High
    Custom  : --ref 11 --no-fast-pskip --no-dct-decimate --bframes 5 --b-pyramid normal --direct auto --deblock -2:-1 --subme 10 --partitions all --trellis 2 --aq-strength 0.80 --psy-rd 1.0:0.0 --b-adapt 2 --me umh --merange 48 --thread-input --sar 8/9
    
    --- CHECK VERSION ---
    
    Detect video encoder version:
    
    Creating process:
    "C:\Program Files (x86)\MuldeR\Simple x264 Launcher v2\toolset\x64\x264_8bit_x64.exe" --version
    
    x264 0.142.2431 ac76440
    (libswscale 2.6.100)
    (libavformat 55.37.101)
    (ffmpegsource 2.17.4.0)
    built by Komisar on Apr 23 2014, gcc: 4.8.2 (multilib.generic.Komisar)
    configuration: --bit-depth=8 --chroma-format=all
    x264 license: GPL version 2 or later
    libswscale/libavformat/ffmpegsource license: GPL version 2 or later
    
    Detect video source version:
    
    Creating process:
    "C:\Program Files (x86)\MuldeR\Simple x264 Launcher v2\toolset\x86\avs2yuv_x86.exe"
    
    Avs2YUV 0.24bm2
    
    > x264 revision: 2431 (core #142)
    > Avs2YUV version: 0.24.2
    
    --- GET SOURCE INFO ---
    
    Creating process:
    "C:\Program Files (x86)\MuldeR\Simple x264 Launcher v2\toolset\x86\avs2yuv_x86.exe" -frames 1 C:\Users\Desktop\rose.avs NUL
    
    C:\Users\Desktop\rose.avs: 702x480, 30000/1001 fps, 42238 frames
    
    Resolution: 702x480
    Frame Rate: 30000/1001
    No. Frames: 42238
    
    --- ENCODING VIDEO ---
    
    Creating input process:
    "C:\Program Files (x86)\MuldeR\Simple x264 Launcher v2\toolset\x86\avs2yuv_x86.exe" C:\Users\Desktop\rose.avs -
    
    Creating encoder process:
    "C:\Program Files (x86)\MuldeR\Simple x264 Launcher v2\toolset\x64\x264_8bit_x64.exe" --crf 18.0 --preset veryslow --tune film --profile high --ref 11 --no-fast-pskip --no-dct-decimate --bframes 5 --b-pyramid normal --direct auto --deblock -2:-1 --subme 10 --partitions all --trellis 2 --aq-strength 0.80 --psy-rd 1.0:0.0 --b-adapt 2 --me umh --merange 48 --thread-input --sar 8/9 --output "E:\Users\My Videos\Rose.mkv" --frames 42238 --demuxer y4m --stdin y4m -
    
    y4m [info]: 702x480p 8:9 @ 30000/1001 fps (cfr)
    x264 [info]: using SAR=8/9
    x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
    x264 [info]: profile High, level 3.1
    I've tried both "placebo" and "very slow"; both were virtually identical in terms of time of encoding, taking about 95 minutes. Simple x264 says I am averaging about 7 fps. Both files were about 460MB in size. Is this acceptable?

    Thanks in advance.
    Quote Quote  
  2. Member
    Join Date: May 2014
    Location: Down the road, last house on the right
    Search Comp PM
    Yes, those would be about right. Assuming your computer info from your profile is correct.
    Quote Quote  
  3. Originally Posted by Dougster View Post
    Yes, those would be about right. Assuming your computer info from your profile is correct.

    Hey, thanks for the quick reply. I actually now only have 1 GTX 570 (on one the fans died and it overheats far to easily), and I also have an SSD drive now but I am encoding to my HDD so I don't think I would get any benefit from that. Overall it could be slower I guess, and I am VERY happy with the quality.

    Thanks again for the reply. Time to let this do it's thing for a few hours!
    Quote Quote