VideoHelp Forum
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. Hey everyone, I've got a quick (and probably simple) question.

    When I "autoplay" a DVD on my computer it looks great. However, when I rip it, all of the sudden playing that same DVD has interlacing. Why is that?

    The particular DVD I am using does not have any protection on it, but just to test I've used AnyDVD and then used Windows explorer to drag the .vob files to a folder on one of my HDDs. Same thing.

    Like I said, this is probably a very simple question, but I guess I don't fully understand enough yet to grasp this. Why would it play fine from the DVD, but as soon as it's moved to my HDD there is progressive interlacing?

    Thanks in advance.


    EDIT: I just realized something. When I am autoplaying the DVD, I am using WMP. However, when I am using the .vob files on my HDD, I open them in VLC. I decided to right-click "autoplay with VLC" and sure enough, the interlacing is visible. Why is this? It's seems odd to me.
    Quote Quote  
  2. Member Cornucopia's Avatar
    Join Date: Oct 2001
    Location: Deep in the Heart of Texas
    Search Comp PM
    A few simple answers:
    1. DVD is primarily interlaced
    2. PCs are NOT (they are progressive)
    3. In order to see interlaced material on progressive displays, it must de-interlace
    4. Wmp does it so-so, but automatically, VLC does it only when told to (but gives more deint options)
    5. None of this is odd or surprising, rather it is expected
    6. It's so common and expected, there are guides all over the place here on these topics, which you could have read and learned if you had taken the time and effort
    7. Do so

    Sorry if this sounds abrupt, but the tenor of threads has really taken a nosedive and I have had my fill.

    Scott
    "When will the rhetorical questions end?!" - George Carlin
    Quote Quote  
  3. Member
    Join Date: Jun 2012
    Location: USA
    Search Comp PM
    @scott -- nothing wrong with succinct posts.

    @herdo -- as you've discovered it's a player settings issue. Nothing inherently wrong with your files. Re-reading Cornucopia's answer (see #4) and a little experimentation will "solve" this problem.
    Quote Quote  
  4. Member
    Join Date: May 2014
    Location: Tennessee, US
    Search Comp PM
    Just a suggestion, but IMO the MPC-BE media player does a decent deinterlacing job. VLC player seems variable.

    Most video editors' viewer windows don't deinterlace. For internet display players (UTube, etc.), the videos have been deinterlaced -- and they usually make a wreck of it.

    Cornucopia has a point. 'Puter users ought to know this by now.
    - My sister Ann's brother
    Quote Quote  
  5. Member
    Join Date: Nov 2003
    Location: West Texas
    Search PM
    Playback of DVD-video on my computers has never been very smooth using VLC anyway. I always use something else. Media Player Classic Home Cinema usually works better, or PotPlayer if you need free choices, but Arcsoft TMT is easily the best in my experience.
    Quote Quote  
  6. I recall playing around with VLC and if the video is interlaced, it doesn't seem to pass the interlaced flag along, so the video isn't de-interlaced on playback (by the video card or wherever the de-interlacing would normally be done). When using VLC it's necessary to enable de-interlacing in VLC's own options.

    Here's how it works with ffdshow doing the decoding (if you're not familiar with ffdshow it's a DirectShow decoder which can be used with players such as MPC-HC or WMP etc). I guess it explains what VLC doesn't do. Most players should pass the interlaced flag along to the next filter in the playback chain so the video is de-interlaced if need be.

    Name:  ffdshow2.gif
Views: 61
Size:  20.3 KB
    Quote Quote