VideoHelp Forum
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Member
    Join Date: May 2014
    Location: Österreich
    Search PM
    Hi all,

    i make MKVs out of Blu-Rays using mkvmerge and I have a problem with subtitles. If only one subtitle is included in the mkv file, my players (VLC and XBMC) show them, even if the Standard and Forced Flags are set to "No".

    An example:
    Audio Stream English - Standard and Forced to "Yes"
    Audio Stream german - Standard and Forced to "No"
    Subtitle Stream english (only the forced ones) - Standard and Forced to "Yes"
    Subtitle Stream english (complete subtitles) - Standard and Forced to "No"

    this works fine. Forced Subtitles are show every time. And the complete subtitles are show only when i explicity chose them.

    The other example causes Problems:
    Audio Stream English - Standard and Forced to "Yes"
    Audio Stream german - Standard and Forced to "No"
    Subtitle Stream english (complete subtitles, because no forced subs in the Stream) - Standard and Forced to "No"

    Here my players ALWAYS show the sub-stream, except i disable subtitles at all, but i dont want to do this, because forced subs of another movie won't show then.

    Goal of the hole thing is, that i want my rips in english and german language. And the complete subtitles are only needed if i watch in german.

    I hope you can help

    Thanks in advance
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Always include 2 subtitle tracks? Just one empty if no forced subs.
    Quote Quote  
  3. Member
    Join Date: May 2014
    Location: Österreich
    Search PM
    Thats an opportunity, even it may look not really neat and tidy
    how can i make "empty" subtitle files?
    Quote Quote  
  4. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Add an empty subtiltle.srt file(or with just one subtitle line) in mkvmerge?
    Quote Quote