VideoHelp Forum
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. I've been using virtual dub to trim some segments of some old avi files where the video would stall and have about 10-20 duplicate frames. I select all but the first frame, delete, and save a direct stream copy. One particular part of a video, though, is giving me a headache. When I select the frames in this video, delete them and save a copy, they show back up in the copy. I'm at a loss to explain it, but I've done the same 15 frames about five times, and they always show back up in the copies. Anybody got any ideas?
    Quote Quote  
  2. Member
    Join Date: Nov 2002
    Location: United States
    Search Comp PM
    You need to use smart render instead of direct stream copy. Virtualdub (and most other editors) can only cut on key frames. With smart render, it re-encodes at the cut and direct stream copies the rest. In Videos > Compression, you need to select the original codec so it can re-encode the cut with the same compression.
    Quote Quote  
  3. You need to use smart render instead of direct stream copy. Virtualdub (and most other editors) can only cut on key frames. With smart render, it re-encodes at the cut and direct stream copies the rest. In Videos > Compression, you need to select the original codec so it can re-encode the cut with the same compression.
    Sorry, my internet has been out a couple days because of storms. I'll try that when I get home today. Thanks.
    Quote Quote  
  4. Try holding down the shift key while you navigate in Virtualdub. That'll ensure you land on a keyframe (or use the back and forward buttons with a picture of a key on them). Set the edit points and try deleting that way. If you're setting start and end points which aren't on keyframes VirtualDub might might be ignoring the edit even though initially at appears not to be, especially if the start and end points are quite close together.
    Depending on where the keyframes are you mightn't be able to cut exactly where you'd prefer to. If it's a problem, try the smart rendering function.
    Quote Quote  
  5. Thanks guys. The Smart render did the trick.
    Quote Quote