VideoHelp Forum
+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. Member
    Join Date: Oct 2009
    Location: United States
    Search Comp PM
    Here is my situation.......

    The video files that I am trying to play are mp4 1080p h.264. A typical file will be somewhere in the neighborhood of 2 hours long, 4 gigs in size, with an overall bit rate of 4,800 kbps.

    Some of the files play great but others have constant jitter. I have been pulling my hair out trying to figure out why some videos stream smoothly but others are jerky. I tried several different things........ using a few different video players, changing settings in the video players, updating drivers, etc. etc.

    My computer is not the problem..... i7 quad core, radeon 7700 series video card, tons of ram, etc.

    Finally..... after lots of teeth nashing..... I feel like I may have finally pinpointed the problem.....

    Files with "variable frame rate" have jitter
    Files with "constant frame rate" do not have jitter

    My #1 preferred video player is MPC-HC, and my second favorite is VLC.

    Is there some way to adjust the settings in either of these players so that they can handle variable frame rate videos?

    Or, is there a different player that can do the job?

    Windows Media Player seems to handle VFR better than MPCHC or VLC, but I hate WMP

    Ideas?

    Your help in this matter is greatly appreciated.

    TC
    Quote Quote  
  2. Member
    Join Date: Oct 2004
    Location: Freedonia
    Search Comp PM
    VFR is complete and utter bs. It's a solution in search of a problem that doesn't exist. But as you didn't make those videos I get that this is your problem to deal with.

    One website I found said the following. You can try it as it won't hurt but I'm not going to promise that this will fix your problem for sure as I have no way to test it.

    I used to get something similar, and I eventually managed to fix it like this:

    Go into Settings > Preferences (Ctrl+S)
    Enable "Advanced options"
    Go to Input/Codecs > Access modules
    In both of the DVD sections (with/without menus), increase the Caching value to something like 600ms or more. Default is 300.
    Quote Quote  
  3. I don't have any problem playing VFR video using MPC-HC, although I don't have much of it. How are you determining it's VFR? If it's MediaInfo, you can't take it as gospel.
    You mentioned the word "streaming". How are you playing the video exactly?

    Maybe you could try splitting off a sample and uploading it for others to try.
    Quote Quote  
  4. Member Cornucopia's Avatar
    Join Date: Oct 2001
    Location: Deep in the Heart of Texas
    Search Comp PM
    They don't officially have "jitter", they just have points at which their framerate slows down to where you can tell it is stuttery, where the fusion of individual frames into motion is not yet smooth. That's just "low frame rate" at that point. Probably when it dips below ~18Fps. There is NO way to remove this, as that is how it was recorded - with low frame rates at that point in the program. You can convert to CFR, and you can try interpolating/blending, maybe with motion tracking to "morph" some of those in-between clips, but those are always a somewhat disappointing crap shoot and have their own sets of artifacts.

    Only thing I can suggest is: don't continue to record using this method (if you created them yourself), and find better sources (if you DL'd them).

    I cannot think of a single thing good to say about the usage of VFR, particularly when motion-compensated VBR encoding can save nearly as much bitrate.

    Scott
    "When will the rhetorical questions end?!" - George Carlin
    Quote Quote  
  5. Member
    Join Date: Oct 2009
    Location: United States
    Search Comp PM
    When I have had these sorts of problems in the past, they have usually been the result of one of a few different things

    1) damaged files
    2) insufficient processing power
    3) problems with codecs/filters
    4) driver problems


    Because I am failing so far to solve my current problem, I went back to the drawing board.

    I pulled my old "weaker" computer out of the closet. It played the files perfectly. Smooth and clear as can be.

    OLD SYSTEM SPECS
    dual core dell PC
    64 bit windows 7
    video card - Nvidia GeForce GT440

    NEW SYSTEM SPECS
    quad core dell PC
    64 bit windows 8
    video card AMD Radeon 7770

    Soooooooooo........... if you boil all that down, and it indicates that there must be some sort of hangup with Windows 8, and/or the AMD video card.

    And once again, I am stuck.

    Where do you think I should go from here? Is there anything that you can recommend me to try with my new PC other than ripping out the AMD video card or wiping out windows 8 and replacing it with Windows 7?

    Thanks,

    TC
    Quote Quote  
  6. Member
    Join Date: Oct 2009
    Location: United States
    Search Comp PM
    Anybody?

    TC
    Quote Quote  
  7. Member
    Join Date: Oct 2004
    Location: Freedonia
    Search Comp PM
    Originally Posted by True Colors View Post
    Anybody?

    TC
    I responded and you failed to say anything at all about my suggestion, so I'm done here. Gets old making suggestions that get ignored. It would be one thing to say "Tried it and it didn't work" but you're still begging for help and I did make a suggestion that one guy said helped with the same problem.
    Quote Quote  
  8. Turn off all the video "enhancement" filters in your graphics driver's setup applet.
    Quote Quote  
  9. Member
    Join Date: Oct 2009
    Location: United States
    Search Comp PM
    [QUOTE=jman98;2321511]
    Originally Posted by True Colors View Post
    I responded and you failed to say anything at all about my suggestion, so I'm done here. Gets old making suggestions that get ignored. It would be one thing to say "Tried it and it didn't work" but you're still begging for help and I did make a suggestion that one guy said helped with the same problem.
    Well jman, if you must know...... I actually DID attempt your suggestion when you first made it.

    I told you that I use mpchc, vlc and wmp

    You told me to go into my player and press "control S"...... I did that in all 3 players..... and guess what? Nothing happened.

    I also searched for "advanced options" in all three players...... and guess what? There is no such thing.

    I also searched for "DVD" section and could not find anything on that either.

    So...... sorry that I did not take the time out to tell you that your suggestion did not apply to my situation.

    TC
    Quote Quote  
  10. Mod Neophyte Super Moderator redwudz's Avatar
    Join Date: Sep 2002
    Location: AZ, USA
    Search Comp PM
    Do you have the latest video card driver installed? Since the problem is the same with VLC, then it doesn't appear to be a codec issue, so drivers would be the next guess.
    Quote Quote  
  11. Member
    Join Date: Oct 2009
    Location: United States
    Search Comp PM
    Okay, I may have finally found some solutions to my situation.

    The computer that I am using came from Dell. Obviously, they configure everything for you so that you can pull it out of the box and start using it.

    The video card that they included in my system is an AMD Radeon 7770, which is supposed to be a fairly powerful card.

    I did load the newest drivers from the AMD website. HOWEVER, that actually made things worse.

    I called AMD and spoke with a knowledgable rep. He told me that Dell has their own special version of AMD cards. If you can believe it, the dell video card is not compatible with the drivers from the AMD website. He said that I needed to remove the AMD drivers and go back to dell.com and download the video drivers from their site. I did this and it did help a little bit. But it certainly did not fix things all the way.

    Finally I got tired of fighting with all this baloney.........

    So this weekend I ripped out the AMD card and got myself an Nvidia 650 card by Gigabyte.

    Also, I was completely sick and disgusted with Windows 8, so I purchased a new hard drive and loaded Windows 7 on it.

    In the course of doing all this, I discovered a few new things......

    When I started playing videos with Windows 7 and Nvidia, it has worked extremely well. The stuttering is completely gone.

    One tiny little detail caught my eye....... down at the bottom of the MPC-HC player it now says "playing/HW"

    Previously, it said "playing/DXVA" when I having problems with Windows 8 and the Radeon card.

    I am thinking that perhaps this might have been the source of my difficulties all along. I did a search and found this information about how to disable DXVA in MPCHC.........

    GPU drivers are fragile, they foten gives artifacts with 'in the wild' movies.

    Currenty to turn DXVA off user has to go into settings, there find built-in fiters and cear two checkboxes, h.264-dxva and VC1-dxva, and then stop-start video or even restart MPC-HC.
    Part of my wishes that I would have had the opportunity to disable DXVA in my old system in order to see if that one simple thing could have corrected my problem, but oh well. At this point, I am way too far down the road to go back now.

    One other side note..... when I replaced W8 and AMD with W7 and Nvidia, I did experience some video tearing at first. However, after playing videos for a while that seems to have gone away. Not sure why. But I am not complaining!!

    TC
    Last edited by True Colors; 18th May 2014 at 09:29.
    Quote Quote  
  12. DXVA only supports a subset of h.264 features. Disabling it is one of the first things to try when having problems.
    Quote Quote  
  13. Originally Posted by True Colors View Post
    One tiny little detail caught my eye....... down at the bottom of the MPC-HC player it now says "playing/HW"

    Previously, it said "playing/DXVA" when I having problems with Windows 8 and the Radeon card.

    I am thinking that perhaps this might have been the source of my difficulties all along. I did a search and found this information about how to disable DXVA in MPCHC.........
    It sounds like those instructions are outdated. If they worked you're using an older version. Are you using the same version of MPC-HC as before? Until recently it displayed "playing DXVA" regardless of the hardware decoding being used.

    If you go into the LAV Video Decoder configuration you'll see a list of supported hardware decoders. As you now have a Nvidia card it may have defaulted to CUVID and MPC-HC will display "playing H/W". It may also display "playing H/W" even if DXVA is the selected decoder. I'm not sure as DXVA is no longer supported by MPC-HC when running XP.
    Quote Quote  
  14. Member johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Better to buy the original blu-ray since any video you d/l are usually encoded with crappy settings such as vbr settings.
    I think,therefore i am a hamster.
    Quote Quote