VideoHelp Forum
+ Reply to Thread
Results 1 to 10 of 10
Thread
  1. Member
    Join Date: Dec 2002
    Location: United Kingdom
    Search Comp PM
    How can I convert a MKV file to a DVD compliant file to use in Tmpg DVD Authoring works......
    Quote Quote  
  2. Member
    Join Date: Nov 2003
    Location: West Texas
    Search PM
    TMPGEnc Authoring Works 5 supports direct input of an mkv file (as long as it isn't using VC-1 video codec).

    If you are using an earlier version, or are having some issues importing your file, you could use AVStoDVD and change its output from DVD-Video to a muxed mpeg file, then import this into Authoring Works. Of course, AVStoDVD can do the entire process for you and convert all the way to DVD-video, including a menu. You may have some reason for preferring the menu creation in TMPGEnc Authoring Works however.
    Quote Quote  
  3. Member
    Join Date: Dec 2002
    Location: United Kingdom
    Search Comp PM
    Thanks so much for help, I have tried all ways and my Authoring works 4 wont import the muxed file. I have tried AVS outputting a DVD file which works well but there is NO AUDIO.....Any more suggestions
    This is the word pad file that comes with the DVD output if this can help in anyway..
    DVD Video Standard: NTSC
    DVD Titles number: 1
    DVD Size: 4449/4450 MB (100%)
    DVD Output Setup: DVD Folder
    DVD Label: DVD
    DVD Menu: No Menu
    Output Folder: E:\INVISIBLE MAN mpeg
    Delete Temp Assets Files: Yes
    Delete Temp Working Files: Yes
    Edit Command Parameters: No
    Post Process Task: Show Progress Status window

    PREFERENCES

    MultiThread: 1
    AVS Video Source Filter: A2DSource
    AVS Audio Source Filter: A2DSource
    AVS UpSize/DownSize Filter: Lanczos4Resize/Spline16Resize
    Frame Adjust Strategy: 1
    PAL SpeedUp: 0
    Video Resolution: 0
    Video BitRate Min: 2500
    Video BitRate Level 1: 6500
    Video Profile Level 2: 4500
    Video BitRate Max: 8500
    Keep DVD Compliant Video: 1
    AC3 Audio Encoder: 0
    Force FFmpeg for Long Audio: 1
    DVD Audio Format: 0
    DVD Audio BitRate: 192
    Keep DVD Compliant Audio: 1
    Normalize Audio: 0
    Auto Delay Audio: 1
    DVD Audio Language (Primary): EN - English
    DVD Audio Language (Secondary): EN - English
    DVD Subs Language (Primary): EN - English
    DVD Subs Language (Secondary): EN - English
    DVD Subs Font: Tahoma 16pt (255,255,255)
    Chapters Interval: 5
    Use Source Chapters: 1
    DVD Burning Drive: G:\
    DVD Burning Speed: 4x
    Auto Erase DVD RW: 1
    Unload ActiveMovie library: 0
    Adjust ffdshow at runtime: 1
    Save General Settings: 0
    <>

    <02/05/2014 12:03:13>
    TITLE 1 SOURCE FILES
    Video: E:\The Invisible Man (1975) Complete Series\S1E00 - (Pilot) The Invisible Man.avs.mkv
    Info: AVC - 1200 kbps - 718x480 - DAR 1.329 - 29.97 fps (CFR) - Progressive - 1:13:22 hours - 131956 frames
    Audio 1: E:\The Invisible Man (1975) Complete Series\S1E00 - (Pilot) The Invisible Man.avs.mkv
    Info: AC3 - 192 kbps - CBR - 2 ch - 48000 Hz - 16 bit - 1:13:22 hours (0 ms delay)
    [MediaInfoLib - v0.7.61]
    <>

    <02/05/2014 12:03:13>
    AVISYNTH SCRIPT
    Import("C:\Program Files\AVStoDVD\Lib\A2DSource.avsi")

    Video = A2DVideoSource("E:\The Invisible Man (1975) Complete Series\S1E00 - (Pilot) The Invisible Man.avs.mkv", CacheFolder="C:\DOCUME~1\STEWOR~1\LOCALS~1\Temp", FrameRate=29.97, VFR=false)
    # Audio is frameserved by AviSynth just for Preview and Edit purposes.
    Audio = A2DAudioSource("E:\The Invisible Man (1975) Complete Series\S1E00 - (Pilot) The Invisible Man.avs.mkv", CacheFolder="C:\DOCUME~1\STEWOR~1\LOCALS~1\Temp")

    Video = Video.ConvertToYV12()
    Video = Video.Lanczos4Resize(720,480,0,0,0,-0)

    AudioDub(Video, Audio)
    <>

    <02/05/2014 12:03:13>
    START VIDEO ENCODING OPERATIONS
    Encoding Profile: FFmpeg CBR 1-pass
    Target Video FileSize: 4272 MB
    Encoding Parameters: -i "C:\DOCUME~1\STEWOR~1\LOCALS~1\Temp\DVD_0_S1E0 0 - (Pilot) The Invisible Man.avs_1.avs" -threads 1 -aspect 4:3 -c:v mpeg2video -b:v 8139k -minrate 8139k -maxrate 8139k -bufsize 2000k -dc 10 -y "C:\Documents and Settings\Ste Worrall\My Documents\My Videos\DVD_0_S1E00 - (Pilot) The Invisible Man.avs.m2v"
    <>

    <02/05/2014 12:28:03>
    END VIDEO ENCODING OPERATIONS
    Video Source Filter: A2DSource (FFmpegSource2 (cache off))
    Created File: C:\Documents and Settings\Ste Worrall\My Documents\My Videos\DVD_0_S1E00 - (Pilot) The Invisible Man.avs.m2v (1963.9 MB)
    <>

    <02/05/2014 12:29:05>
    START AUDIO DEMUXING OPERATIONS (Track 1)
    FFmpeg Parameters: -i "E:\The Invisible Man (1975) Complete Series\S1E00 - (Pilot) The Invisible Man.avs.mkv" -acodec copy -map 0:1 "C:\Documents and Settings\Ste Worrall\My Documents\My Videos\DVD_0_S1E00 - (Pilot) The Invisible Man.avs_1.ToFix.ac3"
    <>

    <02/05/2014 12:30:09>
    WARNING! Errors found during Title 1 Audio Track 1 demuxing.
    Audio filesize is too low (0 MB)
    Backup Audio encoding routine (FFmpeg Safe Mode) is starting ...
    <>

    <02/05/2014 12:30:09>
    START FFMPEG (SAFE MODE) AUDIO ENCODING OPERATIONS (Track 1) - Trial 1/2
    FFmpeg Parameters: -threads 1 -i "E:\The Invisible Man (1975) Complete Series\S1E00 - (Pilot) The Invisible Man.avs.mkv" -map 0:1 -y -vn -acodec ac3 -ar 48000 -ab 192k "C:\Documents and Settings\Ste Worrall\My Documents\My Videos\DVD_0_S1E00 - (Pilot) The Invisible Man.avs_1.ac3"
    <>

    <02/05/2014 12:30:09>
    END AUDIO DEMUXING OPERATIONS (Track 1)
    Created File: C:\Documents and Settings\Ste Worrall\My Documents\My Videos\DVD_0_S1E00 - (Pilot) The Invisible Man.avs_1.ac3 (0 MB)
    OUTPUT AUDIO INFO: AC3 - 192 kbps - CBR - 2 ch - 48000 Hz - 16 bit - 0 seconds (0 ms delay)
    <>

    <02/05/2014 12:31:11>
    START DVD AUTHORING OPERATIONS
    BatchMux Parameters: -arglist "C:\DOCUME~1\STEWOR~1\LOCALS~1\Temp\DVD_0_BatchMux .ini"
    BatchMux ini file:
    -d "E:\INVISIBLE MAN mpeg\DVD_0\VIDEO_TS"
    -mxp "C:\DOCUME~1\STEWOR~1\LOCALS~1\Temp\DVD_0_MuxMan.m xp"
    -l "C:\DOCUME~1\STEWOR~1\LOCALS~1\Temp\DVD_0_MuxMan.l og"
    -muxman "C:\Program Files\AVStoDVD\MuxMan"
    -prio LOW
    -palette "C:\DOCUME~1\STEWOR~1\LOCALS~1\Temp\DVD_0_Palette. txt"
    -v "C:\Documents and Settings\Ste Worrall\My Documents\My Videos\DVD_0_S1E00 - (Pilot) The Invisible Man.avs.m2v"
    -vidmode 4:3
    -a1 "C:\Documents and Settings\Ste Worrall\My Documents\My Videos\DVD_0_S1E00 - (Pilot) The Invisible Man.avs_1.ac3"
    -a1lang en

    <>

    <02/05/2014 12:35:35>
    END DVD AUTHORING OPERATIONS
    Created Folder: E:\INVISIBLE MAN mpeg\DVD_0 (2004.3 MB)

    CHECK DVD SIZE
    DVD Folder (actual) Size: 2004.3 MB
    vs Estimated Size: 4449 MB -> 54.9% undersize
    vs Assets Size: 1963.9 MB -> Warning!
    <>

    <02/05/2014 12:35:37>
    Log file created by AVStoDVD Release 2.7.3
    <>
    Quote Quote  
  4. Member
    Join Date: Nov 2003
    Location: West Texas
    Search PM
    You're having some real problems with the audio in the original files, and I'm not sure why. They appear to be straightforward AC3, constant bitrate, and AVStoDVD should be allowing them to pass through without being re-encoded if you have set up that program in its default configuration. Looking at your Preferences, it does appear that you have the program set up to keep compliant video and audio intact.

    Install mkvtoolnix and MkvCleaver. Use MkvCleaver to demux the original mkv file into separate video and audio streams. Import the demuxed video file from MkvCleaver into AVStoDVD, then right click in the main window of AVStoDVD and add the audio track. Perhaps if they are demuxed to begin with, you'll get a working mpeg or DVD-video output.
    Quote Quote  
  5. Member
    Join Date: Dec 2002
    Location: United Kingdom
    Search Comp PM
    Thanks for helping, I have tried doing the above but AVS-DVD does not recognise the de-muxed video file that MKv Cleaver outputs....apologies for my being a noob
    Quote Quote  
  6. I'm a Super Moderator johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Try muxing the mkv in tsmuxer to xxx.ts and then import the ts file into tmpg dvd author,if it shows the wrong duration time then it's too old to author the ts properly,You can try multiavchd to author the mkv to dvd-video,make sure you have ffdshow and java installed.
    I think,therefore i am a hamster.
    Quote Quote  
  7. Member
    Join Date: Dec 2002
    Location: United Kingdom
    Search Comp PM
    the MKV wont open in Tsmuxer........
    Quote Quote  
  8. Member
    Join Date: Nov 2003
    Location: West Texas
    Search PM
    All right, I'm not giving up yet. You made a DVD successfully in AVStoDVD using the mkv file as input, yes? The only problem was that it did not have audio. If you have saved this DVD, demux it with PGCDemux and get the video stream that AVStoDVD made. This will be an .m2v file.

    Then take the audio you demuxed straight from the mkv file using MKVCleaver. It should be an .ac3 file.

    You can combine them and make the DVD with these elementary streams. Looking at the input formats that TMPGEnc Authoring Works 4 accepts, it should be able to handle these.

    Or follow johns0's advice and start completely over using MultiAVCHD. Or Video to Video should be able to make a DVD for you from the mkv file.
    Quote Quote  
  9. I'm a Super Moderator johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Load the mkv into the newest mkvmerge and save as a new mkv and load that into tsmuxer,sounds like the mkv has head stripping on it which tsmuxer won't accept,muxing it into a new mkv removes the head stripping feature.
    I think,therefore i am a hamster.
    Quote Quote  
  10. Member
    Join Date: Dec 2002
    Location: United Kingdom
    Search Comp PM
    Problem solved, many thanks for your assistance, But im afraid I have to admit it was my fault all along as much as i tried your expert advice, it would have never had worked becasue "stupid me" had been using the original file, which taking advice from a google search had told me to change the file name from a .MKV to a .AVS so it would open in Authoring works 4. it dawned on me late last night to get the original file with its original filename and process it solely using AVS-DVD and it has worked.....But I do appreciate your advice, and I have also learned that AVS-DVD is a lot better tool than I thought, and also that I should have asked on HERE for your experienced advice before going solo and "googling". Once again THANKS so much for your assistance and expert guidance.
    Quote Quote