VideoHelp Forum
+ Reply to Thread
Results 1 to 11 of 11
Thread
  1. Novice
    Join Date: Apr 2014
    Location: United States
    Search Comp PM
    I have this MP4 and MKV DVD rip of a 20 minute episode (which I already own) that someone else made. Here is what VLC says about both of these files.
    Name:  VLC Info.PNG
Views: 306
Size:  38.0 KB

    The file name mentions x264 and Nero AAC. Is Nero AAC different from regular AAC, which my Blu-ray player supports? Could this be a reason why my Blu-ray player won't play the files? Here is the manual page that lists which formats it can playback.
    Name:  LG Blu-ray Formats.PNG
Views: 261
Size:  88.2 KB

    I'm having difficulty making sense of all this. If uploading the file will help, I can do that, but I will delete it until my problem is resolved. Thanks!
    Quote Quote  
  2. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    nero is just the brand of aac encoder; it won't affect compatibility

    Possibly those Russian? characters in the filename are giving your hardware a difficult time. Try renaming the file to something simple and English, with short length. e.g. "video.mp4"

    If that still doesn't work use mediainfo(view=>text) on the problematic file , copy & paste the results back here
    http://www.videohelp.com/tools/MediaInfo
    Quote Quote  
  3. Novice
    Join Date: Apr 2014
    Location: United States
    Search Comp PM
    Originally Posted by poisondeathray View Post
    nero is just the brand of aac encoder; it won't affect compatibility

    Possibly those Russian? characters in the filename are giving your hardware a difficult time. Try renaming the file to something simple and English, with short length. e.g. "video.mp4"

    If that still doesn't work use mediainfo(view=>text) on the problematic file , copy & paste the results back here
    http://www.videohelp.com/tools/MediaInfo
    Here are the results:

    Format : MPEG-4
    Format profile : Base Media
    Codec ID : isom
    File size : 174 MiB
    Duration : 21mn 17s
    Overall bit rate mode : Variable
    Overall bit rate : 1 143 Kbps
    Encoded date : UTC 2007-12-03 11:38:32
    Tagged date : UTC 2007-12-03 11:38:32

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L5.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 13 frames
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 21mn 17s
    Bit rate : 942 Kbps
    Maximum bit rate : 3 795 Kbps
    Width : 720 pixels
    Height : 480 pixels
    Display aspect ratio : 4:3
    Original display aspect ratio : 4:3
    Frame rate mode : Constant
    Frame rate : 29.970 fps
    Standard : NTSC
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.091
    Stream size : 143 MiB (82%)
    Title : Video
    Writing library : x264 core 57 svn-700
    Encoding settings : cabac=1 / ref=10 / deblock=1:-2:-1 / analyse=0x3:0x133 / me=umh / subme=6 / brdo=1 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=3 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=3 / wpredb=1 / bime=1 / keyint=250 / keyint_min=25 / scenecut=40(pre) / rc=2pass / bitrate=942 / ratetol=1.0 / rceq='blurCplx^(1-qComp)' / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30
    Encoded date : UTC 2007-12-03 11:38:32
    Tagged date : UTC 2007-12-03 11:40:06

    Audio #1
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 21mn 17s
    Bit rate mode : Variable
    Bit rate : 96.0 Kbps
    Maximum bit rate : 109 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 44.1 KHz
    Compression mode : Lossy
    Stream size : 14.5 MiB (8%)
    Title : Russian
    Language : Russian
    Encoded date : UTC 2007-12-03 11:40:03
    Tagged date : UTC 2007-12-03 11:40:06

    Audio #2
    ID : 3
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 21mn 17s
    Bit rate mode : Variable
    Bit rate : 100 Kbps
    Maximum bit rate : 108 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Stream size : 15.3 MiB (9%)
    Title : English
    Language : English
    Encoded date : UTC 2007-12-03 11:40:04
    Tagged date : UTC 2007-12-03 11:40:06
    Quote Quote  
  4. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    The problem is the encoding settings used

    Most current hardware devices are limited to High@L4.1 . That file is High@L5.1 , and too many reference frames

    Sometimes you can patch the level to "fool" the hardware. e.g. using various level editors (h264 level editor) , but if the file uses actual references that high, it wont work
    http://www.videohelp.com/tools/H264-AVC-Level-Editor
    Quote Quote  
  5. Novice
    Join Date: Apr 2014
    Location: United States
    Search Comp PM
    Here are the results for the MKV as well.

    Format : Matroska
    Format version : Version 1
    File size : 159 MiB
    Duration : 21mn 16s
    Overall bit rate : 1 044 Kbps
    Encoded date : UTC 2008-06-09 15:28:23
    Writing application : mkvmerge v2.2.0 ('Turn It On Again') built on Mar 4 2008 12:58:26
    Writing library : libebml v0.7.7 + libmatroska v0.8.1

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L5.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 10 frames
    Codec ID : V_MPEG4/ISO/AVC
    Duration : 21mn 16s
    Nominal bit rate : 936 Kbps
    Width : 720 pixels
    Height : 480 pixels
    Display aspect ratio : 4:3
    Original display aspect ratio : 3:2
    Frame rate mode : Constant
    Frame rate : 29.970 fps
    Standard : NTSC
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.090
    Title : Eng. Video
    Writing library : x264 core 59 r859M ce13bb6
    Encoding settings : cabac=1 / ref=10 / deblock=1:-2:-1 / analyse=0x3:0x113 / me=umh / subme=6 / me-prepass=0 / brdo=1 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=3 / nr=0 / decimate=0 / mbaff=0 / fgo=0 / bframes=16 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=3 / wpredb=1 / bime=1 / keyint=250 / keyint_min=25 / scenecut=40(pre) / rc=2pass / bitrate=936 / ratetol=1.0 / rceq='blurCplx^(1-qComp)' / qcomp=1.00 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=2:1.00
    Language : English
    Default : Yes
    Forced : No

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : A_AAC
    Duration : 21mn 16s
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Title : Eng. Audio
    Language : English
    Default : Yes
    Forced : No
    Quote Quote  
  6. Novice
    Join Date: Apr 2014
    Location: United States
    Search Comp PM
    Originally Posted by poisondeathray View Post
    The problem is the encoding settings used

    Most current hardware devices are limited to High@L4.1 . That file is High@L5 , and too many reference frames
    Do you think the files can play on a PlayStation 3 instead? That's the only other thing I have.
    Quote Quote  
  7. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Same issue with the MKV . Most current devices won't play High@L5.1 , even if they conform to specs that are lower. The presense of that very "label" prevents playback

    Nope , It won't play on a PS3

    You can try that level editor (probably won't work , but worth a try) , otherwise you have to re-encode the files with compliant settings
    Quote Quote  
  8. Novice
    Join Date: Apr 2014
    Location: United States
    Search Comp PM
    Changing the level worked! I was just going to end up connecting my laptop to my T.V. and watch them that way. Thank you so much for your help!
    Quote Quote  
  9. Novice
    Join Date: Apr 2014
    Location: United States
    Search Comp PM
    By the way, I changed the level to 1. What's the best level to choose?
    Quote Quote  
  10. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Probably High@L4.1 - that's the cut off for most devices

    It doesn't always work, but it's worth a try (saves you the time and quality loss from reencoding)
    Quote Quote  
  11. Novice
    Join Date: Apr 2014
    Location: United States
    Search Comp PM
    Originally Posted by poisondeathray View Post
    Probably High@L4.1 - that's the cut off for most devices

    It doesn't always work, but it's worth a try (saves you the time and quality loss from reencoding)
    Thank you again for your help!
    Quote Quote