VideoHelp Forum
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Member
    Join Date: Aug 2013
    Location: Sierra Leone
    Search Comp PM
    Hello,
    I have a bunch of tutorials where the lecturer just stands and speaks. There are no explosions or fast changing scenes; just the occasional transition to his laptop display. So I was wondering if I can take advantage of this to reduce the video size. Presently a 30 minute lecture is about 450MB in size which in my opinion is too much for a 640x360 video. I am currently using MeGui as my x264 encoder and I wonder if anyone has an idea what can be tweaked.
    Thanks
    Quote Quote  
  2. config/check "Show advanced options" and for encoding mode choose "Constant Quality" (last one in the list), choose value like 19 , smaller value , better quality but bigger size, bigger value smaller size but worse quality, just find your CRF value that fits your needs, then use it all the time

    OR

    if you are decided that you have to get 250MB size for example, you press AUTOencode (after you had set audio settings) choose file size in there. Not sure if you have to also select automated 2pass in Config window, or it selects that automatically
    Quote Quote  
  3. If there's a significant amount of noise in the video you can get more compression by applying a noise filter.
    Quote Quote  
  4. Originally Posted by medwatt View Post
    Hello,
    I have a bunch of tutorials where the lecturer just stands and speaks. There are no explosions or fast changing scenes; just the occasional transition to his laptop display. So I was wondering if I can take advantage of this to reduce the video size. Presently a 30 minute lecture is about 450MB in size which in my opinion is too much for a 640x360 video. I am currently using MeGui as my x264 encoder and I wonder if anyone has an idea what can be tweaked.
    Thanks
    Use more refs, enable mb-tree, increase mb-tree window.
    Quote Quote  
  5. Member
    Join Date: Aug 2013
    Location: Sierra Leone
    Search Comp PM
    I've adjusted a few of the suggested changes and I can say the size has reduced dramatically without any dramatic loss in quality. Keep the suggestions coming !
    Quote Quote  
  6. Be careful about using too many reference frames, too many consecutive b-frames, too long GOPs, etc. Many devices have limitations on what they can handle. I would stick with settings that are blu-ray compatible (High#4.1) or even less.

    https://en.wikipedia.org/wiki/H.264#Levels
    Quote Quote  
  7. Member
    Join Date: Aug 2013
    Location: Sierra Leone
    Search Comp PM
    Originally Posted by jagabo View Post
    Be careful about using too many reference frames, too many consecutive b-frames, too long GOPs, etc. Many devices have limitations on what they can handle. I would stick with settings that are blu-ray compatible (High#4.1) or even less.

    https://en.wikipedia.org/wiki/H.264#Levels
    So should I leave it at 3 or notch it up to 4 or 5 ?

    Also does the delta in quantization have to be increase given that frames change slightly ?
    Quote Quote  
  8. High@4.1 as Jagabo suggested is a reasonable limit, for the source pixel size, High@3.1 seems reasonable.
    Changing little individual settings actually may cause a non-standard result. That's ok if you're playing back on PC but sometimes gives problems with standalone players and stuttering with streaming.
    Try High@3.1, crf @21-23 and use very slow. Is the video grainy?
    Quote Quote  
  9. Select
    Level 3.1 for 720480@80.0 (NTSC max) or 720576@66.7 (PAL max) - Full SD
    Level 4.1 for 1,9201,080@30.1 - Full HD (Overkill for Sd content.)
    Of course there is a limit for max. allowable bitrate per level as well.

    In your case for 640x360 videos, Level 3.1 is just more than sufficient.
    Using many reference frames, may choke some hardware players. Software players might not complain about many ref. frames.
    Just tweak 480p29.970 BluRay Compatible settings as suggested above.

    480p29.970 from above link.

    x264 --bitrate XXXXX --preset veryslow --tune film --bluray-compat --vbv-maxrate 8000 --vbv-bufsize 8000 --level 3.1 --keyint 30 --open-gop --colorprim "smpte170m" --transfer "smpte170m" --colormatrix "smpte170m" --sar 40:33 -o out.264 input.file

    I am not much familiar with x264 settings.
    Just try as suggested by others here.
    Originally Posted by blud7
    Try High@3.1, crf @21-23 and use very slow.
    As your source does not have any explosion or high motion scene, these should work good.
    Quote Quote