VideoHelp Forum
+ Reply to Thread
Results 1 to 13 of 13
Thread
  1. Im doing my best to make SUPER encoder detect the second audio stream on my dual audio files (ENG-JAP Animes) but it just cant and plays/encodes only the first audio file it wants ignoring the next, even though SUPER has an option to detect audio streams.

    Ive emailed the author of SUPER about this but they say SUPER can detect audio streams completely disregarding what i say, completely ignoring what i say in a suborn manner. idk if its my files that are the issue or if it is SUPER or not, but no matter what i do it doesnt give me the option to encode/play using the second audio stream, even though MPC-HC from the Klite Codec Pack detects them without any issue at all, what can i be doing wrong? Im at loss here, i really want to make SUPER my default encoder of choice due to its unrivaled codec export support, but this issue is just killing me
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Super and klite....I'm out of here....
    Quote Quote  
  3. Member ozok's Avatar
    Join Date: Oct 2011
    Location: Turkey
    Search Comp PM
    Originally Posted by Baldrick View Post
    Super and klite....I'm out of here....
    LOL

    To op, if SUPER cannot detect the second audio then you should use an other program to see if the problem is with super or you file. Try TEncoder, if it is there TEncoder should detect it.

    Btw why would anyone design such a hideous interface?
    Quote Quote  
  4. Member hech54's Avatar
    Join Date: Jul 2001
    Location: Yank in Europe
    Search Comp PM
    Originally Posted by Baldrick View Post
    Super and klite....I'm out of here....
    Quote Quote  
  5. Sorry for the late reply... i didnt get email notification from this thread, even tho ive set it to instantly send me notifications form here

    Wait, whats wrong with the Klite Codec Pack and SUPER? Its always highly rated by everyone Well, except maybe SUPER's clunky GUI, but its the only encoder that i know that lets you use such a variety of codecs

    TEncoder detects a second audio stream, but when converting it to something else (while using h264 as the codec and mkv as the container) im only given the option of choosing one language for my output file, even when i dont choose the audio stream that i want and leave the selection feld blank, i still get only 1 audio in the output file!

    Heres the MediaInfo report on the file im trying to work with, when i asked the developer and showed him the MediaInfo report he said its because of the file.... is it really from it? Is there something strange about my file? I have the file uploaded somewhere if someone can examine it themselves to see whys it doing this D:


    Format : Matroska
    Format version : Version 1
    File size : 70.5 MiB
    Duration : 23mn 37s
    Overall bit rate : 417 Kbps
    Encoded date : UTC 2009-03-14 09:02:18
    Writing application : mkvmerge v2.3.0 ('Freak U') built on Sep 8 2008 18:32:16
    Writing library : libebml v0.7.7 + libmatroska v0.8.1

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 5 frames
    Codec ID : V_MPEG4/ISO/AVC
    Duration : 23mn 37s
    Nominal bit rate : 338 Kbps
    Width : 704 pixels
    Height : 480 pixels
    Display aspect ratio : 3:2
    Frame rate mode : Constant
    Frame rate : 23.976 fps
    Standard : NTSC
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.042
    Writing library : x264 core 64 r979 6d4af8d
    Encoding settings : cabac=1 / ref=5 / deblock=1:1:2 / analyse=0x3:0x133 / me=umh / subme=7 / psy_rd=1.0:0.0 / brdo=0 / mixed_ref=1 / me_range=32 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=3 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=2 / b_bias=0 / direct=3 / wpredb=1 / bime=0 / keyint=250 / keyint_min=25 / scenecut=45(pre) / rc=2pass / bitrate=338 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=50000 / vbv_bufsize=50000 / ip_ratio=1.40 / pb_ratio=1.30 / aq=0
    Default : Yes
    Forced : No

    Audio #1
    ID : 3
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : HE-AAC / LC
    Codec ID : A_AAC
    Duration : 23mn 37s
    Channel count : 2 channels
    Channel positions : Front: L R
    Sampling rate : 44.1 KHz / 22.05 KHz
    Compression mode : Lossy
    Default : Yes
    Forced : No

    Audio #2
    ID : 4
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : HE-AAC / LC
    Codec ID : A_AAC
    Duration : 23mn 37s
    Channel count : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz / 24.0 KHz
    Compression mode : Lossy
    Default : No
    Forced : No

    Text
    ID : 2
    Format : UTF-8
    Codec ID : S_TEXT/UTF8
    Codec ID/Info : UTF-8 Plain Text
    Language : English
    Default : Yes
    Forced : No
    Quote Quote  
  6. Member ozok's Avatar
    Join Date: Oct 2011
    Location: Turkey
    Search Comp PM
    Originally Posted by Chiggy View Post
    ...
    TEncoder detects a second audio stream, but when converting it to something else (while using h264 as the codec and mkv as the container) im only given the option of choosing one language for my output file, even when i dont choose the audio stream that i want and leave the selection feld blank, i still get only 1 audio in the output file!
    ...
    Well, you said SUPER wouldn't "detect" second audio stream. As far as I can see noone said anything about encoding both streams. Anyway, when I have to encode two audio streams at once, I use TEncoder's "Custom Options" option ("Tools" button > "Custom Options"). Write "-map 0:2" to "FFmpeg" textbox. Make sure ffmpeg is selected as encoder. Generally, 0th stream is video, 1st one is audio and second audio stream is the 2th stream. Note that mediainfo's stream numbers and ffmpeg's stream number may not match.

    You can also use HandBrake, it also supports encoding multiple audio streams though I don't know if this feature is exposed in the official GUI.
    Quote Quote  
  7. Originally Posted by ozok View Post
    Btw why would anyone design such a hideous interface?
    I hear you on that one man, I swear if it werent for its diverse codec and container support i wouldnt come near it with a 10 mile radius, but its one of the few converters that dont call presets like "iphone" "ps3" or "android mp4" as codecs, since the great majority of video converters on the market do that, and instead SUPER gives you full choice of what codec you want to use, as opposed to other converters that work with just 2 codecs at max (*cough cough* Handbrake)

    The only other option close to SUPER codec/container wise is AVANTI, and that one is.... lets just say once you use it SUPER feels like heaven
    Quote Quote  
  8. Originally Posted by ozok View Post
    Well, you said SUPER wouldn't "detect" second audio stream. As far as I can see noone said anything about encoding both streams. Anyway, when I have to encode two audio streams at once, I use TEncoder's "Custom Options" option ("Tools" button > "Custom Options"). Write "-map 0:2" to "FFmpeg" textbox. Make sure ffmpeg is selected as encoder. Generally, 0th stream is video, 1st one is audio and second audio stream is the 2th stream. Note that mediainfo's stream numbers and ffmpeg's stream number may not match.

    You can also use HandBrake, it also supports encoding multiple audio streams though I don't know if this feature is exposed in the official GUI.
    Wait, so its not common for most encoders to convert from an mkv with several streams to something else? Strange... Or do they only do that when the source is a DVD/Bluray?

    I just tried it with Handbrake and while it did seemingly detect 2 audio streams, it encoded only one of them in the output file, however your advice with TEncoder worked! But.... got ended up hardcoding the subs

    So theres nothing wrong with my file based on its MediaInfo report then? According to the SUPER author, and i quote:

    "This MKV has a wrongly encoded subtitle track using the Audio Track position.
    Your file is a one Audio Track
    Get any 2 languages DVD in your PC, click on any VOB file to play the Audio tracks
    ."
    Quote Quote  
  9. Member
    Join Date: Jul 2007
    Location: England
    Search Comp PM
    Originally Posted by Baldrick View Post
    Super and klite....I'm out of here....
    Both available on your(??) website too. Shame on you
    Quote Quote  
  10. Member ozok's Avatar
    Join Date: Oct 2011
    Location: Turkey
    Search Comp PM
    @Chiggy that comment made me smile. If you ever contact him again, ask him what "Audio Track position" is please. I have seen mkv files where subtitle track was the second track after the video or the audio track as the first track. And that file was converted properly in my computer. It shouldn't make much difference, ffmpeg is smart enough to know which track to encode, if you tell it properly ofc.

    Also if you selected ffmpeg as encoder in TEncoder, it cannot harcode subtitles. If you've checked "Enable Subtitles" and selected ffmpeg, it will ask you if you want to switch to mencoder which can hardcode subs. But Mencoder cannot do multiple audio coding thing because you didn't pass the necessary options to it. There is something you miss here.
    Quote Quote  
  11. Originally Posted by ozok View Post
    @Chiggy that comment made me smile. If you ever contact him again, ask him what "Audio Track position" is please. I have seen mkv files where subtitle track was the second track after the video or the audio track as the first track. And that file was converted properly in my computer. It shouldn't make much difference, ffmpeg is smart enough to know which track to encode, if you tell it properly ofc.

    Also if you selected ffmpeg as encoder in TEncoder, it cannot harcode subtitles. If you've checked "Enable Subtitles" and selected ffmpeg, it will ask you if you want to switch to mencoder which can hardcode subs. But Mencoder cannot do multiple audio coding thing because you didn't pass the necessary options to it. There is something you miss here.
    Their developer doesnt respond to anyone anymore if you dont praise their product I guess its a SUPER limitation because it expects streams to be in a certain order or something, ffffff. I guess ill have to use TEncoder for anything that involves multitrack conversion.

    Regarding stream positions however, is there any way to choose their order? for example, if an mkv has 2 audios, is there a way to make one of the other audio tracks be the default one instead of the order they were in in the source file in TEncoder? And is there any way to change the order of the streams without encoding? If i can do it in a lossless, relatively not so complicated way itd be better.
    Quote Quote  
  12. Member ozok's Avatar
    Join Date: Oct 2011
    Location: Turkey
    Search Comp PM
    I think you can use mkvtoolnix to change their orders, though I didn't try it before.
    Last edited by ozok; 23rd Mar 2014 at 16:57.
    Quote Quote  
  13. Thanks man! I looked at the related tools to the one you recommended and realized theres several tools to deal with mkv's of the like, owe you one! All this time ive been trying to use a converter to do their task, silly me...

    And i just realised youre the TEncoder developer himself.. Keep up the great work man!
    Quote Quote  



Similar Threads