VideoHelp Forum
+ Reply to Thread
Results 1 to 8 of 8
Thread
  1. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    Hi all -
    I'm usually pretty good at sorting out these odd Windows problems, but I haven't got to grips
    with this at all. I've got two installs of XP on the same PC. One of them works normally,
    which tells me the HW is OK. However, on the other there's a problem.

    I've got two optical drives, CD burner and DVD burner. When a media is inserted into one device
    the Autoplay box appears (asking you what program do you want to use to open the disk, etc,etc) within
    5 or 6 seconds. However, in the other device, the Autoplay box doesn't appear until at least 60 seconds
    have elapsed.

    It seems there is something happening at the system level that only affects one optical drive.

    Any idea's appreciated.
    Quote Quote  
  2. It sounds to me like one of the optical drives is having a hard time reading discs or "getting ready". Maybe it's on the way out, or maybe it's just slow.

    It could be an oddness with AutoPlay although I doubt it. It does sound more like a hardware issue. What happens if you put a disc in a drive and try to access the contents with Windows Explorer? Does it take a lot longer to see the files when using one of the drives?
    Quote Quote  
  3. Make sure the slow drive hasn't fallen out of DMA mode.
    Quote Quote  
  4. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    Thanks for your suggestions. When the disk is inserted, I can open "my computer" and "explore" the CD contents and it displays
    instantly. Usually, the Autoplay window will eventually open, but some seconds (up to a minute) later.

    The device manager shows that both drives are in UDMA mode 2 on the secondary IDE controller - everything looks good there.

    This install of XP did have some issues a while back, for some reason (possible malware?), some Windows components stopped working.
    One of them being the shell hardware detection (directly related) and another Disk Management.

    I fixed the hardware detection a few weeks ago and Disk Management this morning. Once that was fixed I was able to change the
    drive letter of the offending optical drive to another, unused latter. Once I did that, the problem was alleviated.
    Why it makes a difference I've no idea. I may have to go back into the registry - there are probably a few references to the old
    drive letter I'll have to change.

    Thanks again, real problem not identified, but who cares - it's working now.
    Quote Quote  
  5. I hate AutoPlay with a passion so I haven't had much experience with it. How's this for AutoPlay oddness?
    I have two virtually identical PCs. I installed Windows and programs on one, made an image of the setup, then restored the image to the second PC. Once I adjusted drive letters on the second PC it all worked fine. Except AutoPlay was disabled when I made the image and it's remained disabled on the second PC after restoring the image, but for the first PC I can't seem to stop it. I've checked registry entries, used TweakUI and I've looked for any AutoPlay setting I can find, but if I plug a USB drive into this PC, up pops AutoPlay. I select "take no action", check the box to remember the setting, then when I plug the drive in again, up it pops.....
    Quote Quote  
  6. Member
    Join Date: May 2011
    Location: United States
    Search PM
    Hello: I have moved on from XP,but I remember having similiar issues from time to time..Sometimes certain programs you mave installed alters your optical drives autoplay settings..Try dowloading this little app from microsoft (if you havent already) I would run it from time to time if I had issues with my drives.It did straighten out my problems...http://www.microsoft.com/en-us/download/details.aspx?id=2648
    Quote Quote  
  7. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    Originally Posted by RappinRod View Post
    Hello: I have moved on from XP,but I remember having similiar issues from time to time..Sometimes certain programs you mave installed alters your optical drives autoplay settings..Try dowloading this little app from microsoft (if you havent already) I would run it from time to time if I had issues with my drives.It did straighten out my problems...http://www.microsoft.com/en-us/download/details.aspx?id=2648
    I did try the utility, but to be honest, I don't have much faith in them. This is the error I received.

    >> Repair << [Autoplay V2 Event]
    Step: No steps to take.
    Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.

    However, now that the drive letter is changed, everything is working.

    I had a problem with another Windows component a few months back the "fixit" utility appeared to be doing something, but again failed
    with a similar cryptic message as to the above. In a fit of desperation, I followed the registry until I had found the dll related to the
    function. After manually re-registering the dll, the problem was fixed.
    Don't you thing the fixit should have had the smarts to re-register the dll for you? It's directly related to the component in question!
    Quote Quote  
  8. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    Originally Posted by hello_hello View Post
    I hate AutoPlay with a passion so I haven't had much experience with it. How's this for AutoPlay oddness?
    I have two virtually identical PCs. I installed Windows and programs on one, made an image of the setup, then restored the image to the second PC. Once I adjusted drive letters on the second PC it all worked fine. Except AutoPlay was disabled when I made the image and it's remained disabled on the second PC after restoring the image, but for the first PC I can't seem to stop it. I've checked registry entries, used TweakUI and I've looked for any AutoPlay setting I can find, but if I plug a USB drive into this PC, up pops AutoPlay. I select "take no action", check the box to remember the setting, then when I plug the drive in again, up it pops.....
    I'm not surprised, seems like in Windows, in general, settings are remembered for a while until they
    inexplicably stop working, for no apparent reason.

    The "fix" i thought I'd found regarding switching drive letters was too good to be true, all it did was move the delay
    from one drive to the other. For now I switched the letter back to it's original setting, but the Autoplay delay, so far,
    has not followed it back. I haven't got a clue what's going on.

    Seems like it's just messed up in XP; at least in Vista and newer they improved it - by separating autoplay and autorun,
    giving you control over both independently.
    Quote Quote  



Similar Threads