VideoHelp Forum
+ Reply to Thread
Results 1 to 18 of 18
Thread
  1. Alright, I've tried everything I know here and I'm about ready to throw my computer out the window. Hopefully someone here can help me out! Let me give you as many details as I can.

    Title is issue. I have an MPEG2-TS file that will load into Sony Vegas Pro 10, but only the video file. When I play the file in Windows Media Player, the file plays perfectly fine with audio. Vegas just won't even acknowledge that the file HAS audio.

    The file was recorded via HDMI with AverMedia LGHD Stream Engine, with a 256kbps audio bitrate.

    I'm... about 83% certain I attached a 5MB sample of the video I'm capturing. This file opens in Vegas as video-only. If I didn't do that right, I'm sorry, I'm not a big frequenter of forums and I'm not sure where the proper button lives.

    Anyone who could help me, I would really appreciate it.
    Attached Files
    Quote Quote  
  2. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Several options:

    You can re-wrap into a different container like MP4, MOV , with ffmpeg or using some front end GUI like tencoder

    or you can batch convert the audio to uncompressed pcm wav and import the audio separately

    Or some combination of those, like copying the video, converting the audio to uncompressed and using AVI container

    I would probably do the last option, because your h.264 video doesn't use b-frames and should be safe in AVI container

    Try and see if these samples work ok in your version of vegas and current configuration. Some versions of vegas depends on what codecs you have installed for AVI (VFW) and MOV . For example you might need quicktime installed for MOV, and something like ffdshow to decode h.264 in AVI
    Attached Files
    Quote Quote  
  3. Member Cornucopia's Avatar
    Join Date: Oct 2001
    Location: Deep in the Heart of Texas
    Search Comp PM
    I'm not surprised you are having trouble: Vegas does not, nor has it ever supported AAC (except as handled when within a QT MOV, possibly MP4 also - as long as QT is doing the decoding, not Vegas itself). It's all there in the tech specs.

    What pdr suggested might work, though I think your best bet is Installing QT Pro (good choice for most Vegas Pro power users) and then re-wrapping to MOV container. tsMuxer should be able to do that part. If that doesn't work, then I'd go with the rewrapping to AVI w/ Uncompressed (decompressed) audio idea.

    Scott
    "When will the rhetorical questions end?!" - George Carlin
    Quote Quote  
  4. I have QuickTime Alternative 3.2.2 from 2010, but Vegas will not load that AAC anyway. Would be latest Quick Time different?

    Any kind of remuxing did not help here (ts, m2ts, mp4).

    But AAC audio that I make with NeroAAcEnc and then it is muxed into mp4 with mp4box, Vegas would load. So there must be difference between those two AAC then.
    Quote Quote  
  5. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Different versions of vegas might use slightly different decoding pathways. For example, some MP4's will use Mainconcept .dll to decode, other MP4's will use Quicktime. If you right click the clip in the clip bin, and check the properties it will tell you more information

    The MP4 variants "MP42" will usually call mainconcept, "ISOM" will usually call quicktime . So that is a container difference, not AAC encoder difference. Check what your neroaac/mp4box is using with mediainfo

    Some versions of quicktime / quicktime pro are unstable with certain versions of vegas. Sometimes you get black/green screens . That's why I would recommend the AVI route if you don't have b-frames . You don't need the pro version, unless you want extended MOV export options, and QT alternative should work fine for decoding. And sometimes quicktime just doesn't play nicely on PC's.

    Anyways there are several options

    Try these _Al_ remuxed into MP4
    Attached Files
    Quote Quote  
  6. Vegas 10.0 loads both those last two samples. I have QuickTime Alternative 3.2.2 on system only.

    But I used mp4box, it generates isom IDcodec and Vegas does not load that mp4. For CodecID for audio, your samples show "40" but my sample shows "67" by mediainfo.
    Last edited by _Al_; 13th Mar 2014 at 14:10.
    Quote Quote  
  7. Member Cornucopia's Avatar
    Join Date: Oct 2001
    Location: Deep in the Heart of Texas
    Search Comp PM
    The one in the OP's sample is AAC-LC, not AAC-HE. That may be some of the diff as well.

    Scott
    "When will the rhetorical questions end?!" - George Carlin
    Quote Quote  
  8. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Originally Posted by _Al_ View Post
    Vegas 10.0 loads both those last two samples. I have QuickTime Alternative 3.2.2 on system only.


    OK, but vegas (any version) can act differently on different systems, because vegas partially relies on system installed codecs

    Can you report which dll is being used for those mp4's by the process outlined above?

    Also check the framerate that vegas reports (you might have to interpret the framerate on one or both of them to 30.0)

    For reference, the commandlines used:

    Code:
    ffmbc -i "20140313080713.ts" -vcodec copy -acodec copy -absf aac_adtstoasc ffmbc_mp42.mp4
    Code:
    ffmpeg -i "20140313080713.ts" -vcodec copy -acodec copy -bsf:a aac_adtstoasc -movflags faststart ffmpeg_isom.mp4
    Quote Quote  
  9. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Originally Posted by _Al_ View Post

    But I used mp4box, it generates isom IDcodec and Vegas does not load that mp4. For CodecID for audio, your samples show "40" but my sample shows "67" by mediainfo.

    Probably because you just muxed it but didn't remove the ADTS header. I don't think MP4box does this automatically. See the ffmpeg commandline examples

    eg
    -bsf:a aac_adtstoasc


    2.1 aac_adtstoasc

    Convert MPEG-2/4 AAC ADTS to MPEG-4 Audio Specific Configuration bitstream filter.

    This filter creates an MPEG-4 AudioSpecificConfig from an MPEG-2/4 ADTS header and removes the ADTS header.

    This is required for example when copying an AAC stream from a raw ADTS AAC container to a FLV or a MOV/MP4 file.
    Quote Quote  
  10. fps, it reports 29.971, original is 30

    audio information in properties (even selecting audio1) says nothing much, under general tab there is one dll mentioned : compoundplug.dll, but that might be for video only ...
    Quote Quote  
  11. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Are both reported to be 29.971 fps ? The reason is the timestamps were "off" in the transport stream, so these MP4's were muxed as "variable" frame rate, even though they aren't really . When using them in vegas , you would have to interpret the FPS correctly . Did you test the AVI ? That should show up as 30.0
    Quote Quote  
  12. both show 29.971
    that your avi Vegas 10.0 cannot load at all,and I have latest ffdshow
    Quote Quote  
  13. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Well the OP has to test some of the options and see what works for him. Because even the same vegas version and build can act differently on different computers
    Quote Quote  
  14. best bet was that one with re-encoding audio - re-encoded audio to wav and to load original ts, it loads video with correct frame rate 30fps
    Quote Quote  
  15. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Originally Posted by _Al_ View Post
    best bet was that one with re-encoding audio - re-encoded audio to wav and to load original ts, it loads video with correct frame rate 30fps
    Another option is to force the timescale . It should read as 30.0 in all versions of vegas instead of having to manually interpret it
    -video_track_timescale 30

    But I think there are issues in his sample, there might be A/V mismatch on longer samples, or perhaps it was from the way the sample was made or cut . You'd have to test it out on longer samples to be sure, even with converting the audio only to wav for re-import

    Code:
    ffmpeg -i "20140313080713.ts" -vcodec copy -acodec copy -bsf:a aac_adtstoasc -video_track_timescale 30 -movflags faststart ffmpeg_timescale.mp4
    Attached Files
    Quote Quote  
  16. wow
    -video_track_timescale , it is not even in the manual , where you guys finding this stuff , I tried -r 30, did not work ...
    Quote Quote  
  17. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Originally Posted by _Al_ View Post
    wow
    -video_track_timescale , it is not even in the manual , where you guys finding this stuff , I tried -r 30, did not work ...
    yes it's in the full help, under mp4 muxer AVOptions:

    -video_track_timescale <int> E..... set timescale of all video tracks (from 0 to INT_MAX) (default 0)
    But they are always adding new stuff. A flurry of activity with filters and such over the last few months.

    They also have the worst documentation and explanations ... I'd say on par with avisynth (although avisynth docs have improved somewhat)
    Quote Quote  
  18. Wow! lots of solutions in this thread, gotta thank you guys for all the help. I'm not familiar with every type of audio Vegas does/does not support, so I didn't know about the AAC incompatibility (and tbh, I'm not savvy enough to even know the audio WAS AAC...). The program doesn't look like it supports any output other than AAC, so that's a bummer.

    That said, this post worked out just fine for me. Got ffmpeg installed and used Audacity to export the audio separately as .wav, its a bit of extra work but it works fine for me. Thanks again guys!
    Quote Quote  



Similar Threads