VideoHelp Forum
+ Reply to Thread
Results 1 to 9 of 9

Thread: Choppy encode

Thread
  1. hi y'all

    So I seem to have a problem.

    I have a BR copy of BBC's Human Planet which plays very nice in VLC as BR. Next i fired up Handbrake 0.9.9 which served me fine up until now.

    I tried a vast amount of setting and the end result is always the same.

    Some setting I have tried/changed:

    -mp4, mkv
    -high, stanard profile
    -h.264 level from 3.0 up to 5.something
    -b-frames from 1 to 5, reference also
    -Framerate as source, fixed framerate (source is 25)
    -constant quality from 18 to 30
    -variable quality

    end result is always the same. here's a sample of it from handbrake

    https://drive.google.com/file/d/0B2CaPjqXDBiqRWdPMTljdFNFN0E/edit?usp=sharing

    As you can see, framerate is shitty. What could be causing this?
    Quote Quote  
  2. Any filters enabled under the filters tab? Detelicine or Decomb? Are you positive the source is 25fps?

    The output has a frame repeated twice, then another repeated twice..... and many of the "original" frames have been dropped which makes the output "jumpy".

    I'm not really sure why it's happening, but if checking the source frame rate and disabling filters doesn't fix it, try posting the Handbrake log file.
    Quote Quote  
  3. source framerate is 25fps. Checked with the mediainfo and dbinfo. Filters are all disabled.

    Wait a sec, I'm gonna find the log and post it

    here it is. I started another encode with superfast settings

    -------------------------------------------
    CLI Query: -i "G:\Downloads\BBC_HUMAN_PLANET_HDCLUB\BBC_HUMAN_PL ANET_DISC_1_HDCLUB\00007.track_4113.mkv" -t 1 --angle 1 -c 1 -o "G:\KONVERTOVANO\00007.track 4113-1.mp4" -f mp4 -4 -w 1920 --loose-anamorphic --modulus 2 -e x264 -q 23 --vfr -a 1 -E faac -6 dpl2 -R Auto -B 160 -D 0 --gain 0 --audio-fallback ffac3 --x264-preset=ultrafast --x264-profile=high --x264-tune="film" --h264-level="4.1" --verbose=1
    User Query: False

    [17:21:43] hb_init: starting libhb thread
    HandBrake 0.9.9 (2013052900) - MinGW x86_64 - http://handbrake.fr
    8 CPUs detected
    Opening G:\Downloads\BBC_HUMAN_PLANET_HDCLUB\BBC_HUMAN_PLA NET_DISC_1_HDCLUB\00007.track_4113.mkv...
    [17:21:43] hb_scan: path=G:\Downloads\BBC_HUMAN_PLANET_HDCLUB\BBC_HUMA N_PLANET_DISC_1_HDCLUB\00007.track_4113.mkv, title_index=1
    libbluray/bdnav/index_parse.c:162: indx_parse(): error opening G:\Downloads\BBC_HUMAN_PLANET_HDCLUB\BBC_HUMAN_PLA NET_DISC_1_HDCLUB\00007.track_4113.mkv/BDMV/index.bdmv
    libbluray/bdnav/index_parse.c:162: indx_parse(): error opening G:\Downloads\BBC_HUMAN_PLANET_HDCLUB\BBC_HUMAN_PLA NET_DISC_1_HDCLUB\00007.track_4113.mkv/BDMV/BACKUP/index.bdmv
    libbluray/bluray.c:1725: nav_get_title_list(G:\Downloads\BBC_HUMAN_PLANET_H DCLUB\BBC_HUMAN_PLANET_DISC_1_HDCLUB\00007.track_4 113.mkv) failed (0000000001B59430)
    [17:21:43] bd: not a bd - trying as a stream/file instead
    libdvdnav: Using dvdnav version 4.1.3
    libdvdread: Encrypted DVD support unavailable.
    libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
    libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
    libdvdread: Can't open file VIDEO_TS.IFO.
    libdvdnav: vm: failed to read VIDEO_TS.IFO
    [17:21:43] dvd: not a dvd - trying as a stream/file instead
    [vc1 @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    Input #0, matroska,webm, from 'G:\Downloads\BBC_HUMAN_PLANET_HDCLUB\BBC_HUMAN_PL ANET_DISC_1_HDCLUB\00007.track_4113.mkv':
    Duration: 00:59:07.00, start: 0.000000, bitrate: N/A
    Stream #0.0(eng): Video: vc1 (Advanced), yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 25 fps, 25 tbr, 1k tbn, 50 tbc (default)
    Stream #0.1(eng): Audio: dca (DTS-HD MA), 48000 Hz, 5.1, fltp, 1536 kb/s (default)
    [17:21:43] scan: decoding previews for title 1
    [NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    [17:21:43] scan: audio 0x1: dca, rate=48000Hz, bitrate=1536000 English (DTS-HD MA) (5.1 ch)
    [NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    [NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    Scanning title 1 of 1, preview 3, 30.00 %[NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    [NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    [NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    Scanning title 1 of 1, preview 6, 60.00 %[NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    [NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    [NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    Scanning title 1 of 1, preview 9, 90.00 %[NULL @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    [17:21:44] scan: 10 previews, 1920x1080, 25.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 1:1
    [17:21:44] libhb: scan thread found 1 valid title(s)
    + title 1:
    + stream: G:\Downloads\BBC_HUMAN_PLANET_HDCLUB\BBC_HUMAN_PLA NET_DISC_1_HDCLUB\00007.track_4113.mkv
    + duration: 00:59:07
    + size: 1920x1080, pixel aspect: 1/1, display aspect: 1.78, 25.000 fps
    + autocrop: 0/0/0/0
    + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:59:07
    + audio tracks:
    + 1, English (DTS-HD MA) (5.1 ch) (iso639-2: eng)
    + subtitle tracks:
    [17:21:44] 1 job(s) to process
    [17:21:44] starting job
    [17:21:44] sync: expecting 88675 video frames
    [17:21:44] job configuration:
    [17:21:44] * source
    [17:21:44] + G:\Downloads\BBC_HUMAN_PLANET_HDCLUB\BBC_HUMAN_PLA NET_DISC_1_HDCLUB\00007.track_4113.mkv
    [17:21:44] + title 1, chapter(s) 1 to 1
    [17:21:44] + container: matroska,webm
    [17:21:44] * destination
    [17:21:44] + G:\KONVERTOVANO\00007.track 4113-1.mp4
    [17:21:44] + container: MPEG-4 (.mp4 and .m4v)
    [17:21:44] + 64-bit formatting
    [17:21:44] * video track
    [17:21:44] + decoder: vc1
    [17:21:44] + frame rate: same as source (around 25.000 fps)
    [17:21:44] + filters
    [17:21:44] + Framerate Shaper (0:27000000:1080000)
    [17:21:44] + frame rate: same as source (around 25.000 fps)
    [17:21:44] + Crop and Scale (1920:1080:0:0:0:0)
    [17:21:44] + source: 1920 * 1080, crop (0/0/0/0): 1920 * 1080, scale: 1920 * 1080
    [17:21:44] + loose anamorphic
    [17:21:44] + storage dimensions: 1920 * 1080, mod 2
    [17:21:44] + pixel aspect ratio: 1 / 1
    [17:21:44] + display dimensions: 1920 * 1080
    [17:21:44] + encoder: H.264 (x264)
    [17:21:44] + x264 preset: ultrafast
    [17:21:44] + x264 tune: film
    [17:21:44] + h264 profile: high
    [17:21:44] + h264 level: 4.1
    [17:21:44] + quality: 23.00 (RF)
    [17:21:44] * audio track 1
    [17:21:44] + decoder: English (DTS-HD MA) (5.1 ch) (track 1, id 0x1)
    [17:21:44] + bitrate: 1536 kbps, samplerate: 48000 Hz
    [17:21:44] + mixdown: Dolby Pro Logic II
    [17:21:44] + encoder: AAC (faac)
    [17:21:44] + bitrate: 160 kbps, samplerate: 48000 Hz
    [vc1 @ 0000000001BA1360] Interlaced frames/fields support is incomplete
    [17:21:44] reader: first SCR 0 id 0x0 DTS 0
    [17:21:44] encx264: encoding with stored aspect 1/1
    [17:21:44] encx264: Encoding at constant RF 23.000000
    x264 [warning]: --psnr used with psy on: results will be invalid!
    x264 [warning]: --tune psnr should be used if attempting to benchmark psnr!
    x264 [info]: using SAR=1/1
    x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
    x264 [info]: profile Constrained Baseline, level 4.1
    Quote Quote  
  4. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    [vc1 @ 0000000001B5BC80] Interlaced frames/fields support is incomplete
    Probably a decoding issue since it's interlaced vc-1 . Many decoders/programs have problems with interlaced vc-1

    The options are avisynth + directshowsource with WMDecoderDMO enabled (or I think lav splitter now decodes it correctly now), or DGNVTools .
    Quote Quote  
  5. Damn. So handbrake's deinterlacer doesn't support VC1?
    Quote Quote  
  6. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Originally Posted by bocca View Post
    Damn. So handbrake's deinterlacer doesn't support VC1?
    It's not a problem with deinterlacing, but with decoding .

    If it could decode interlaced vc-1 properly, then you could deinterlace it or encode interlaced ok
    Quote Quote  
  7. Handbrake's latest nightly build seems to have solved the problem
    Quote Quote  
  8. I found an interlaced VC1 sample on the interweb, and Handbrake couldn't cope with it. http://www.mediafire.com/download/tzlnhdynnhq/300-vc1-nodecode.m2ts

    MeGUI seemed to manage it fine. It did spit out an error when I tried to open it but I clicked past that, MeGUI indexed the video using the L-Smash indexer and I was able to de-interlace and re-encode it without a problem.

    If you want to try MeGUI, open the video using the File/Open menu, let MeGUI open it with the File Indexer, add the indexing job to the job queue and run it. When it's done, the script creator will open with a preview for setting up an encode (cropping, resizing etc). Once you're done, save the script and it'll be loaded into the video section for encoding. MeGUI is quite different to Handbrake, but you can always asks questions if you need to. Hopefully it'll also work with your video.
    Quote Quote  
  9. Originally Posted by bocca View Post
    Handbrake's latest nightly build seems to have solved the problem
    I couldn't work out which build or see any definite info, so I thought I'd test out the latest Vidcoder first. Seems if you're an XP user you might have some Handbrake/Vidcoder disappointment to look forward to. Not that it appears the Handbrake developers have gone out of their way to warn XP users they can't run Handbrake at the moment.

    http://forum.doom9.org/showthread.php?p=1671175#post1671175
    Quote Quote  



Similar Threads