VideoHelp Forum
+ Reply to Thread
Results 1 to 20 of 20
Thread

Threaded View

  1. Member
    Join Date: Jan 2014
    Location: Israel
    Search Comp PM
    Some mp4 files taken by my cellphone (haier w910 using bravo camera) stopped
    playing in my pc, while others do play. I tried with several programs such as vlc, windows mp, classical mp, quicktime, sony vegas.

    I have checked with mediainfo and noticed that the bad ones (that do not play) has a tag:

    Xtra : WM/MediaClassPrimaryID

    while the good ones do not have this tag.

    I could not find over the net enough information about such bug, unfortunately.

    Can someone help? Is there a recommended way to remove such tag?

    I am almost sure that I checked these files earlier in the pc. Is this possible that some software added this tag?

    Thanks.
    Yuval
    Quote Quote  
  2. Member
    Join Date: Mar 2008
    Location: United States
    Search Comp PM
    Can you post up one of the files here to the forum so we can inspect it?
    Quote Quote  
  3. Member
    Join Date: Jan 2014
    Location: Israel
    Search Comp PM
    I have uploaded a file named "bad.mp4" to Google drive, ~50MB:

    https://drive.google.com/file/d/0B_ekeVDodQvxZ2lDendZNXEycUU/edit?usp=sharing

    Thanks,
    Yuval
    Quote Quote  
  4. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Grau video repair tool could fix it. It's not free though.
    Attached Files
    Quote Quote  
  5. Member
    Join Date: Jan 2014
    Location: Israel
    Search Comp PM
    Originally Posted by Baldrick View Post
    Grau video repair tool could fix it. It's not free though.
    Well, at least I know now that this is repairable, even if I do not understand what may have caused this problem. Understanding
    the problem is important, as I do want to keep use this cell phone for taking videos...

    It seems that the problem may be either in the file transfer from the camera (using mtp), or in windows 7. All I did with the files were
    to rename and copy to another folder.

    I checked some of the corrupted files, not yet deleted from the cellphone, and tried again to transfer to pc, rename and move to another folder. And this time no corruption. It seems to be one annoying bug, hard to reproduce.

    The repaired file is upside/down, btw, but this is not difficult to fix in video editor.

    Thanks,
    Yuval
    Quote Quote  
  6. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    But you can try remux your mp4 files with the free mymp4boxgui. Just add the mp4 and make a new mp4.
    Quote Quote  
  7. Member
    Join Date: Jan 2014
    Location: Israel
    Search Comp PM
    Originally Posted by Baldrick View Post
    But you can try remux your mp4 files with the free mymp4boxgui. Just add the mp4 and make a new mp4.
    I tried your suggestion now, but unfortunately it did not work well. I tried also to demux the corrupted file (bad.mp4) with mymp4boxgui, but both the aac and h264 resulting files were not good.
    Quote Quote  
  8. Member
    Join Date: Mar 2016
    Location: Grenoble, FRANCE
    Search PM
    I have had the same problem and it was also corrupting some important video of my baby. I had 20 video corrupted, some of them with some unique moment of the first weeks of my baby.

    I'm a software developer so I have developped a Windows (7, 8 and 10) application to fix the issue. I was very glad to recover the videos. I have decided to propose it as a Freeware for other users like you. Here it is:

    http://auroraborealissoftware.jimdo.com/english/

    I hope that it will fix your issue too!
    Quote Quote  
  9. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Originally Posted by AuroraBorealisSoftware View Post
    I have had the same problem and it was also corrupting some important video of my baby. I had 20 video corrupted, some of them with some unique moment of the first weeks of my baby.

    I'm a software developer so I have developped a Windows (7, 8 and 10) application to fix the issue. I was very glad to recover the videos. I have decided to propose it as a Freeware for other users like you. Here it is:

    http://auroraborealissoftware.jimdo.com/english/

    I hope that it will fix your issue too!
    Looks a simple and useful software.

    I hope it's okey that I add a mirror download to in this thread. In case your site is down.

    Virustotal tested file:
    https://www.virustotal.com/en/file/e42b47a7339f07d68e9ded80d1089ff1e55d8276db9155701a6...22ac/analysis/
    Attached Files
    Quote Quote  
  10. Member
    Join Date: Mar 2016
    Location: Grenoble, FRANCE
    Search PM
    [QUOTE=Baldrick;2436097]
    Looks a simple and useful software.

    I hope it's okey that I add a mirror download to in this thread. In case your site is down.


    Hi,
    I have generated a version 1.0.0.1. Can you please either remove this link or update it to the new version?
    Thank you!
    Regards
    Quote Quote  
  11. Member
    Join Date: Jan 2014
    Location: Israel
    Search Comp PM
    Originally Posted by AuroraBorealisSoftware View Post
    I have had the same problem and it was also corrupting some important video of my baby. I had 20 video corrupted, some of them with some unique moment of the first weeks of my baby.

    I'm a software developer so I have developped a Windows (7, 8 and 10) application to fix the issue. I was very glad to recover the videos. I have decided to propose it as a Freeware for other users like you. Here it is:

    http://auroraborealissoftware.jimdo.com/english/

    I hope that it will fix your issue too!
    I'm glad you found a solution for your problem, losing valuable baby videos may really be disappointing.
    Your software, however, couldn't repair the bad.mp4 example I posted above. Maybe my file suffers from a different
    problem. I stopped using that phone some time ago, anyhow. However, while I used it I found
    out it's better not to mess with the original mp4 files with any program. Even simple renaming by using the file
    time may change some headers in the file making it unusable.

    Cheers
    Quote Quote  
  12. Member
    Join Date: Mar 2016
    Location: Grenoble, FRANCE
    Search PM
    Oh yes, losing baby videos is really disappointing.
    I'm interested to get your file "bad.mp4" to see what's wrong. I may not find but I could learn new things about this issue.
    Do you mind to share it again? It seems that the Google Drive link doesn't work anymore.
    Thanks!

    Look at this thread:
    https://social.technet.microsoft.com/Forums/office/en-US/74adc717-7778-45d6-a779-573ea...m=w7itpromedia
    They say that the corruption comes from wmpnetwk.exe (Windows Media Player Network Sharing Service)

    Cheers
    Quote Quote  
  13. Member
    Join Date: Mar 2016
    Location: Grenoble, FRANCE
    Search PM
    Thanks for your comment and Ok for the mirroring.
    Cheers
    Quote Quote  
  14. Member
    Join Date: Mar 2016
    Location: Grenoble, FRANCE
    Search PM
    I'm interested to get your file "bad.mp4" to see what's wrong. I may not find but I could learn new things about this issue.
    Do you mind to share it again? It seems that the Google Drive link doesn't work anymore.
    No need, in fact the google drive still has the file.
    Quote Quote  



Similar Threads