VideoHelp Forum
+ Reply to Thread
Results 1 to 24 of 24
Thread
  1. errr....

    It seems Potplayer STILL have problems with showing SOME dvd subtitles during playback !!

    I thought they have rectify that issue since revision 1.5.39145 beta by now http://www.dvbsupport.net/info/potplayer.html

    Have tried the disc in windvd & mpc-hc to check and see if nothing is wrong with the original dvd disc itself..
    And the disc play nice ofcourse !!

    Any suggestion to adjust / workarround anything ... beside going back to windvd or mpc-hc !!?

    cheers,
    Last edited by metagondria; 12th Jan 2014 at 20:30.
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    what kind of problems?
    Quote Quote  
  3. Originally Posted by Baldrick View Post
    what kind of problems?
    Seriouslee?

    I thought i wos very clear about that !!

    AGAIN..

    Pot player DOES NOT show/play all subtitles from a dvd movie i have watched !!!

    Here and there subtitles lines are missing...!!!! Not only that, it happends ALWAY's with the same text lines at specific timeframes ...!!!

    And by the looks of the changelogs from potplayer builds , it has been an issue for an long time they try to fix !!!

    See changelog from build 1.5.39145 Beta →→→→ http://www.dvbsupport.net/info/potplayer.html

    Pot player is an very neat application INDEED, so wonderfull that i even have replaced mpc-hc whit it ..
    But... its just yet not perfected to do an important task like showing all subtitles!!

    Have spent , litteraly hours today trying to workarround it by using different settings/→external filters .. in potplayer ..

    But allas.. to no vail.... seems the subtitle bug in potplayers is persistent ahheh..
    Quote Quote  
  4. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Again? So you have cross posted same question again?
    Quote Quote  
  5. Originally Posted by Baldrick View Post
    Again? So you have cross posted same question again?
    Uhm... forgive me for asking this...

    But is there an question you like me to ask ? Is there anything not clear about my potplayer experience i have explained !?
    Quote Quote  
  6. Member Budman1's Avatar
    Join Date: Jul 2012
    Location: NORTHWEST ILLINOIS, USA
    Search Comp PM
    Metagondria... I read the first line in THIS thread and I thought you said PROBLEMS with showing some subtitles such as wrong characters with Greek or regular font for italics or one line that's too wide for multipoint or a dozen other problems. Until you used the word MISSING it never crossed my mind. Personally I'm surprised Baldrick was so polite to answer after your arrogant reply to his polite question about a vague problem in order to help you.
    Quote Quote  
  7. vanished El Heggunte's Avatar
    Join Date: Jun 2009
    Location: Misplaced Childhood
    Search Comp PM
    @ metagondria: try using an external MPEG-2 decoder for DVD playback.

    Your complaint was not very-clear, and so I assume you're using the internal MPEG-2 decoder of PotPlayer,
    which might be the source of your subtitles problem.
    I suggest the following decompressors: LAV Video, DScaler 5, Cyberlink's decoder (from PowerDVD), or the Arcsoft Video Decoder
    (whichever pleases you most).
    Quote Quote  
  8. Originally Posted by Budman1 View Post
    Metagondria... such as wrong characters with Greek or regular font for italics or one line that's too wide for multipoint or a dozen other problems.

    That ↑ is just plain rubbish !! I did NOT reffered to font size or lettertype or any of the sort !!! However, i wos refering to the original RETAIL DVD SUBTITLES !!!! Some subbed lines that just didnt show up when mr & mrs did the talking in the movie !!

    AGAIN, iam not talking about CUSTOM HOMEMADE bREW Subtitles like you find everywhere on the WWW express..

    N-O = NO, iam talking about the → ORIGINAL RETAIL SUBTITLES ←from the dvd..

    Iam talking about the kind of subtitles from which the font size, color, letttertype CANNOT BE manipulate during playback (on the fly as they say) to my knowledge !!


    Originally Posted by El Heggunte View Post
    @ metagondria: try using an external MPEG-2 decoder for DVD playback.

    Your complaint was not very-clear, and so I assume you're using the internal MPEG-2 decoder of PotPlayer,
    which might be the source of your subtitles problem.
    I suggest the following decompressors: LAV Video, DScaler 5, Cyberlink's decoder (from PowerDVD), or the Arcsoft Video Decoder
    (whichever pleases you most).
    And AGAIN, i dont know how much more clear i can be on this subject !!!

    IAM JUST TALKING ABOUT SOME DVD SUBTITLES LINES THAT ARE MISSING = NOT SHOWING DURING PLAYBACK!!

    YES → DISAPPEARING SUBS !!!


    That it!!

    I didnt mentioned , lettertypes, font size, width, macros, sjabloon , scripts... nothing that complex !!

    Am i talking japanese or something ?

    Have i made it THAT difficult to you ppl to understand (no offense... just saying) !!?


    Now, back to topic at hand shall we

    I have tried lav video decoder as MPEG2 decompressor → no succes...

    As for Dscaler, powerdvd (cyberlink) and Arcsoft ( i asume ur refering to TMT?)
    Don't i need to install these software players/decoders to get it to work in potplayer!?

    Because i can't find anything back in potplayer about these players!

    Well i did find an refference to cyberlink in section Preferences→Devices→dvd/bluray→navigator= cyberlink, powerdvd etc to choose from...
    Is THAT ↑ the setting u want me to tamper with ?

    If yes, then i regret to say it makes no difference too !!

    Also, isnt that a bit of weird that mpc-hc just play fine with pretty much the exact same tools that potplayer uses..

    apart from some cosmetic differences, both mpc and potplayer awfull look similar in terms of usage and possibilitys ..


    thanks for your input El hugente..

    cheers,
    Last edited by metagondria; 13th Jan 2014 at 08:27.
    Quote Quote  
  9. Update to my former self ...

    Well... i have found / solved this lil nuicance as to why some text lines are not showing up during playback !!!


    cherriepoopers,
    Quote Quote  
  10. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    How did you solve it? Some setting?

    It might help others who search for same problem.
    Quote Quote  
  11. Originally Posted by Baldrick View Post
    How did you solve it? Some setting?

    It might help others who search for same problem.

    Do i have ur undivided attention now? (just kidding)!

    Well,... its realy a strange situation because it seems to be related to → ANOTHER DVD-REBUILDER PRO BUG ←TOO !!!!

    I have said that potplayer woudn't show all subtitles during playback ,are u still with me ?

    But what i haven't mentioned is that this only happend when using the dvd-9 → dvd-5 encoded disc !!

    And what i have found out is .. that the playback in potplayer wos flawless ONLY when using the DVD-9 → untouched DVD disc Orrr an DVD9 to ↔ DVD-5 TRANSCODED (not ENCODED) disc

    So yes, transcodes done by software such as Nero Recode, Dvdshrink, dvdfab, rejig etc etc... work aswell to my surprise..

    Cuz, either way .. in both cases the dvd-9 has been shrinked to DVD5 ... Yet only the encoded discs from rebuilder are affected by this behaviour !!

    Yes, i had only subtitle problems when using the DVD-9 → DVD-5 encoded disc !!
    So i figured, this must be another dvd-rebuilder clash ... !!!

    But then again, it MUST be an issue with potplayer AND/or dvd-rebuilder altogheter !!

    Because the encoded dvd-5 disc play just fine in Windvd, MPC-HC and my stand alone player (which is an picky player too!!)

    So for testing purpose and ellimination process, i have used an Transcoder software instead of an Encoder for this movie.
    So i have made an DVD-5 disc through Nero Recode and have tested it again in potplayer.

    And sure enough, LO and BEHOLD i have had NO MORE subtitle rendering problems !?!

    I think its because of an bad encode ...
    OR it might be an rebuild → re-authoring issue instead of an encode bug in rebuilder perhaps !!!

    which is more likely, because dvd-rebuilder have gave me problems before with certain movies before !!

    I have used DVD-rebuilder 1.28 pro latest build since an lONG LONG TIME ago though...

    Well there u have it... DVD-Rebuilder is still NOT PERFECTED iam sure of.

    Because one time i tried to shrink the movie K-19 with harrison ford actor through dvd-rebuilder, and it gave me playback problems too.

    Playback problems in commercial dvd player software like Windvd i might add !!!

    The problem that i have had back then with that movie wos during playback the movie froze at 1 specific scene.
    And alway's at the exact specific timeframe...

    So again , i recoded the movie K-19 through nero recode back then .. and ofcourse the dvd5 recoded disc played just nice ..

    So u see, DVD-Rebuilder still has some bugs to work out ... yet jdobs seems to have abandoned it to focus on his new protegé BD-rebuilder !!


    so there u are,


    cheers
    Last edited by metagondria; 17th Jan 2014 at 16:00.
    Quote Quote  
  12. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Latest beta seems to have fixed some dvd subtitles problems. Maybe it will work with dvdrebuilder shrinked dvds.


    Daum PotPlayer 1.5.44655 Beta


    Fixed a problem where some DVD subtitles doesn't show up
    Quote Quote  
  13. Originally Posted by Baldrick View Post
    Latest beta seems to have fixed some dvd subtitles problems. Maybe it will work with dvdrebuilder shrinked dvds.


    Daum PotPlayer 1.5.44655 Beta


    Fixed a problem where some DVD subtitles doesn't show up

    I know, i nearly check everyday in the hope they'll fix it !!
    I guess, my hopes are an bit steeeEEp!!!


    Just, tried the update ... GUESS WHAT ... Some subs still don't display during playback !!!! FTW !!

    The disc is an rebuilder encode that i have tested in 2 different stand alone players , several software players (mpc, windvd, powerdvd , zoomplayer etc !!!)

    All players subtitles do work just FINE , eXCept in pottie player → this is SHITE (excuse my french) !!


    But Hey thanks.. baldruck for the update anyway's!!

    p.s: if you want to check and test it yourself , its an problematic scene from the movie "Gain & Pain" with mark whalberg and the rock hehe..

    Weird, it only happends with dutch subtitles not english nor french !!
    Last edited by metagondria; 21st Jan 2014 at 19:57. Reason: Deletion!
    Quote Quote  
  14. Member
    Join Date: Jun 2012
    Location: Gurupi
    Search Comp PM
    You can use vobsubfilter instead of the PotPlayer internal module.
    Quote Quote  
  15. Originally Posted by Havokdan View Post
    You can use vobsubfilter instead of the PotPlayer internal module.

    are u refering to VSfilter ?

    If so , then its no use either!! I dont get any subtitle to see using it !!

    Though , i have put VSfilter as an external filter in potplayer yet.. nothing !!

    Maybe, you can teach me the steps to get it to work !!


    MOre over, is vobsub/vsfilter in fact suitable to render retail dvd subtitles ???

    Keep in mind, iam not trying to render external subtitles like .srt .txt or anything of the sort !!!

    NO, iam just trying to watch and read the subtitles from an regular retail dvd !!
    Quote Quote  
  16. vanished El Heggunte's Avatar
    Join Date: Jun 2009
    Location: Misplaced Childhood
    Search Comp PM
    So be it...

    1) try this: Context-Menu => Video => Video Processing Filters => DO NOT USE

    OR

    2) find an older version of PotPlayer which doesn't have that DVD subpictures issue

    OR

    3) forget PotPlayer

    My not-so-educated guess: different from MPC-HC or WMP, PotPlayer interferes negatively in the connection between the DVD-navigation filter and the subtitle pin of the MPEG-2 decoder
    Quote Quote  
  17. Originally Posted by El Heggunte View Post
    So be it...

    1) try this: Context-Menu => Video => Video Processing Filters => DO NOT USE

    OR

    2) find an older version of PotPlayer which doesn't have that DVD subpictures issue

    OR

    3) forget PotPlayer

    My not-so-educated guess: different from MPC-HC or WMP, PotPlayer interferes negatively in the connection between the DVD-navigation filter and the subtitle pin of the MPEG-2 decoder

    1) → NOPE .. disable it did not make it so... pottie player didn't comply !!

    2) errrr.... perhaps... but me dont like the sound of that ... it woud mean that JUST MAYBE i might fix the subs by doing that but brake something else you know !!
    "Updates" are there for an reason .. Like 1 step forward and 2 backwards kind of updates... but progess has been made nonetheless (hence 1 step forward uhuh )

    3) Gladly... the only thing is, that pottie player seems to work very well with heavy interlaced pal material
    → AUTOMATICALLY ← (setting s/w interlacing to auto + → FFmpeg original ← )

    If only i could achieve that in mpc-hc, and config my preffered auto deinterlace method in there , then i woud be settled → done & Done !!!!

    But hard to swallow fact is , i need FFdshow for proper deinterlace in mpc-hc .. And nuicance about that is that i need to manually enable , disable , enable disable deinterlacing all the time in mpc and so and on and on... !!

    Because , dvd movies play just fine and perfect whitout additional s/w (ffdshow) deinterlacing you see !!
    But for some episode dvd discs i need to set an additional proper deinterlacer to get an clean image !!
    Else whitout the additional deinterlace steps the image is kind of distorted / garbled like → suffice to say, JusT PLAIN COYOTE UGGLY !!

    So, that in an nutshel as to why iam stuck to it ... !!


    Ah NUTS.... just when i almost got the right combo to play my enhanced upscaled dvds in true motion darn it ...

    I need time to give it some thought and flush all this ...............
    Last edited by metagondria; 20th Jan 2014 at 20:02.
    Quote Quote  
  18. EDIT!
    ... aaaaaaah.... NUTS.... i guess i yelled to sooOn VICTORY !!!

    Tried pottie player ALLL THE WAY BACK DOWN TO build 1.2.xxxxXXXX = No Subtitle show gr, grrr, brrrr !!
    Last edited by metagondria; 21st Jan 2014 at 00:04.
    Quote Quote  
  19. Mkay... i have nailed it .... as to why some subtitles dont appear !!

    SEems crappy FFdshow = Noshow

    Well actually, ffdshow seems to work just fine with mpc-hc regarding the subtitle display !!

    But ffdshow + potplayer seems to be an BAD BAD MIX for subtitle display !!!!!

    JuST ABSURD !!!!
    Quote Quote  
  20. Member
    Join Date: Jun 2012
    Location: Gurupi
    Search Comp PM
    I don't have dvd to test, but the vsfilter cannot read dvd subtitles right? It works with PotPlayer.
    Quote Quote  
  21. Originally Posted by Havokdan View Post
    I don't have dvd to test, but the vsfilter cannot read dvd subtitles right? It works with PotPlayer.

    Somehow, for some reason VSfilter DID NOT WORK properly in potplayer !!!
    And the filter wos set properly, because other settings like picture flip did work through vsfilter however !! So, i mean the VSfilter partial worked alright but not for subtitles!!

    Anyway, I HAVE NAILED IT TOTALY DOWN NOW ..→ dont need VSfilter anymore ....

    The subtitles DO SHOW UP CORRECTLY using pOTplayer + FFDSHoW now ...

    Have spent many MANYH Many HOURS AND NO SLEEP over this nuicance... but i finaly got the right settings to get this to work .. phewWW..

    However iam currently using FFdshow Old build 1.2.xxx rev/4496 .... so i dont know what my current settings will do using the latest 1.3xx revision !!!

    cause, the more developers update the more they break compatiblity these day's

    cheers,
    Quote Quote  
  22. Update to my Former self ↑ ..

    yep.. tis as i expected.... I have nailed and SOLVED 2 NASTY issues at once.

    1. NASTY ANNOYING DVD MENU navigation ( allot and LOTS of BLACK SCREENS / freez menu etcc !!)
    2. Subtitles missing during playback

    ↑ Both ↑ SOLVED by going back to ffdshowrev.4513 ← ...

    So, this means SOMETHING HORRIBLE went WRONG since FFdshow Revision → 1.3.4515 !!!!

    And i have noticed that the quality subtitles has degraded by going back to older revision...
    The contrast from subtitles seems to high and such !!!

    so something about the lightning rendering through ffdshow is SCREWED UP !!!


    Hope some one (developer hint) found this ↑ helpfull !!

    cheers,
    Quote Quote  
  23. vanished El Heggunte's Avatar
    Join Date: Jun 2009
    Location: Misplaced Childhood
    Search Comp PM
    metagondria wrote:

    Something went horrible wrong since revision 1.3.4515 !!!!

    Some subtitles don't show up in just potplayer however ... mpc-hc its fine !!

    And lots of menu navigation issues such as Black screens , menu hang/freez !!!

    Went back to revision .4513, and the above problems all are fixed by doing that !!

    However, the quality from the embededd dvd subtitles has dropped → too much lightning/contrast arround the edges !!!
    Thanks for the relevant information
    However I want you to know that ffdshow still has some deficiencies regarding the DVD subpictures... Also, you cannot make it process the video without rendering the DVD subtitles at the same time It's a terrible bug or design flaw that will remain unfixed "forever"

    Hope developer reads this !!
    They won't, because they don't exist clsid is alive and well, but he was/is just the project manager, not a highly-skilled developer. Haruhiko Yamagata was the last programmer who had the time/motivation to work on ffdshow's source-code.
    Quote Quote  
  24. Originally Posted by El Heggunte View Post
    Also, you cannot make it process the video without rendering the DVD subtitles at the same time It's a terrible bug or design flaw that will remain unfixed "forever"
    Yezz.. about that ↑ !!

    Though i disabled the rendering of embeded subtitles in ffdshow , it seems ffdshow still process the dvd subtitles to some degree !!!

    I thought the internal splitter (what ever that may be) in mediaplayers woud take over that task once i disabled ffdshow subtitle feature !!!

    But no, it seems ffdshow is STILL needed to display subtitles once you need and use ffdshow to get a few other filters to work !!!

    Because disable ffdshow subtitles option completely through mediaplayer result in NO MORE Subtitle display at all !!!

    Did try to counter that by using different external filters set to Enable/preffer for mpeg2/video_ts (dvd)...
    but to no vail !!

    Oh well, atleast menu animation is decent again and all subtitles are accounted for ^^ !!


    cheers,
    Last edited by metagondria; 21st Jan 2014 at 20:00.
    Quote Quote  



Similar Threads