VideoHelp Forum
+ Reply to Thread
Results 1 to 9 of 9
Thread
  1. Format : Flash Video
    File size : 67.9 MiB
    Duration : 20mn 35s
    Overall bit rate : 461 Kbps

    Video
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Main@L3.0
    Format settings, CABAC : No
    Format settings, ReFrames : 1 frame
    Codec ID : 7
    Duration : 20mn 35s
    Bit rate mode : Constant
    Nominal bit rate : 1 024 Kbps
    Width : 640 pixels
    Height : 480 pixels
    Display aspect ratio : 4:3
    Frame rate mode : Variable
    Frame rate : 30.000 fps
    Standard : NTSC
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.111

    Audio
    Format : Speex
    Codec ID : 11
    Duration : 20mn 35s
    Channel(s) : 1 channel
    Sampling rate : 5 500 Hz
    Bit depth : 16 bits
    Compression mode : Lossy
    Delay relative to video : -8s 804ms

    anyone can help me please ?
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Have you tried ffmpeg or a frontend for it? Like xmedia recode, choose mp4 format, under video tab choose copy, under audio tab choose aac audio.
    Quote Quote  
  3. first i used FLV Extract to demux flv file and i have .264 and .spx then spx to mp3 muxing using Yamb frame rate changed to 15.958 and media delay to -8804

    flv extract info
    File: flv.flv
    Estimated True Frame Rate: 15.9583524665019 (3093000/193817)
    Average Frame Rate: 15.6344373322422 (19181000/1226843)

    but audio is always out sync am i doing something wrong ?

    update: about xmedia recode there is no video tab
    Quote Quote  
  4. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Yes. You should have told you had sync issues....
    Quote Quote  
  5. Originally Posted by Baldrick View Post
    Yes. You should have told you had sync issues....
    this my main problem right now

    Frame rate : 30.000 fps or Estimated True Frame Rate: 15.958 fps ?

    Delay relative to video : -8s 804ms = Yamb Media Delay -8804 ?
    Quote Quote  
  6. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    Frame rate mode : Variable
    Frame rate : 30.000 fps
    If it's variable frame rate, then you need to make a VFR MP4 . Not possible with yamb . When you demux it look at the text file timecodes.

    It's better not to demux it. If you use ffmpeg or one of the GUI's listed above to do it in one step, it should keep the VFR timecodes for MP4 output
    Quote Quote  
  7. Originally Posted by poisondeathray View Post
    Frame rate mode : Variable
    Frame rate : 30.000 fps
    If it's variable frame rate, then you need to make a VFR MP4 . Not possible with yamb . When you demux it look at the text file timecodes.

    It's better not to demux it. If you use ffmpeg or one of the GUI's listed above to do it in one step, it should keep the VFR timecodes for MP4 output
    ok ffmpeg which command ?

    i tried ffmpeg -i flv.flv -c:v copy -c:a aac flv.mp4

    Quote Quote  
  8. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    something is wrong with your video or with ffmpeg - stream 0:0 video is not detected "none"

    Or continue with your demux routine, but use mkvtoolnix to mux the streams along with the timecodes generated by flvextract to make a VFR MKV, then ffmpeg to rewrap into MP4

    Or mp4fpsmod to make a VFR MP4 directly
    Quote Quote  
  9. Originally Posted by poisondeathray View Post
    something is wrong with your video or with ffmpeg - stream 0:0 video is not detected "none"

    Or continue with your demux routine, but use mkvtoolnix to mux the streams along with the timecodes generated by flvextract to make a VFR MKV, then ffmpeg to rewrap into MP4

    Or mp4fpsmod to make a VFR MP4 directly
    everything is ok now thanks for help
    Quote Quote  



Similar Threads