VideoHelp Forum
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member
    Join Date: Dec 2013
    Location: Canada, BC
    Search Comp PM
    EDIT: SOLVED Post #3 For people with (RT) Invalid array index. Array is empty - Line 35926 Error read my EDIT in post #4

    Ok I've been at this for days, I've been lurking on this site forever trying to find my answer. And when I think I found the answer it doesn't work.

    I have .mkv episodes of anime that have .ass subtitles within the .mkv. I'm trying to convert the .mkv with the subtitles to a Blu-ray movie disc(BD-MV) that will be playable in most blu-ray players. It must be a proper BD-MV folder structure that the player will recognize as a regular blu-ray movie. Cause the player in question is old and I'm pretty sure it doesn't play data disks or usb sticks. I can't get the model number at the moment for reason's I don't want to get into.

    Everything I tried does not play the subtitles. Even when I convert .ass to .srt.
    I don't mind if they are soft coded subtitles or hard coded subtitles as long as the blu-ray player will recognize the soft coded subs.
    With hard coded subs I don't want to add another encoding step from like: mkv > mkv+hardcode subs > .mt2s/BD-MV
    I want to directly encode from: mkv > .mt2s/BD-MV+hardcode subs


    If anyone can help with what would be the best way to go about this, I've tried these programs so far:
    SubtitleCreator
    ImTOO Blu-ray Creator 2
    Avidemux
    tsMuxerGUI
    multiAVHD
    Hybrid
    dsrt
    ripbot
    handbreak

    Imtoo blu-ray creator wouldn't recognize .ass files so I converted it to .srt. I added the subtitles in then encoded it to a BD-MV iso so I could test it on my computer without wasting a BD-R. So I mounted the iso with daemon tools and played the BD-MV iso with arcsoft total media theater 6 and ps3. The audio went out of sync half way through and no subtitles showed up in the submenu-subtitles.
    I've tried various methods with other programs sometimes the player would show subtitles 1 - english activated under the submenu but nothing would show.

    I am subscribed to this thread by email so I will maintain discussion, thank you.

    Here is the media info for an episode:

    Format : Matroska
    Format version : Version 4 / Version 2
    File size : 551 MiB
    Duration : 24mn 13s
    Overall bit rate : 3 180 Kbps
    Encoded date : UTC 2013-09-01 02:11:14
    Writing application : mkvmerge v6.3.0 ('You can't stop me!') built on Jun 28 2013 20:09:41
    Writing library : libebml v1.3.0 + libmatroska v1.4.0

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4.0
    Format settings, CABAC : Yes
    Format settings, ReFrames : 4 frames
    Codec ID : V_MPEG4/ISO/AVC
    Duration : 24mn 13s
    Nominal bit rate : 3 072 Kbps
    Width : 1 920 pixels
    Height : 1 080 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 23.500 fps
    Original frame rate : 23.976 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.063
    Writing library : x264 core 120 r2120 0c7dab9
    Encoding settings : cabac=1 / ref=4 / deblock=1:1:1 / analyse=0x3:0x113 / me=umh / subme=8 / psy=1 / psy_rd=0.40:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=8 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=2pass / mbtree=1 / bitrate=3072 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=6144 / vbv_bufsize=15360 / nal_hrd=none / ip_ratio=1.40 / aq=1:0.60
    Default : Yes
    Forced : No

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : A_AAC
    Duration : 24mn 13s
    Channel count : 2 channels
    Channel positions : Front: L R
    Sampling rate : 44.1 KHz
    Compression mode : Lossy
    Delay relative to video : -83ms
    Default : Yes
    Forced : No

    Text
    ID : 3
    Format : ASS
    Codec ID : S_TEXT/ASS
    Codec ID/Info : Advanced Sub Station Alpha
    Compression mode : Lossless
    Default : Yes
    Forced : No
    Last edited by kaitlyn2501; 15th Dec 2013 at 18:35.
    Quote Quote  
  2. Member
    Join Date: Dec 2013
    Location: Canada, BC
    Search Comp PM
    shameless bump, i still haven't been able to figure this out.
    Quote Quote  
  3. Perhaps give multiAVCHD another shot. It'll give you a menu to select between your titles (episodes) as well as selecting subtitle. You can also choose to have the subtitles forced to be shown. I made this youtube video to show how.

    http://www.youtube.com/watch?v=Tb1DlXiXr3U

    PS: I think you need to have Java installed in order to convert your .srt to PGS
    Last edited by videobruger; 15th Dec 2013 at 11:01. Reason: PS
    Quote Quote  
  4. Member
    Join Date: Dec 2013
    Location: Canada, BC
    Search Comp PM
    Thank you for taking the time to help.

    I followed your video perfectly, when I click start and after it finishes I get an error: (RT) Invalid array index. Array is empty - Line 35926
    Then I click "OK" and the program crashes.
    I then check to see if it outputted the Blu-ray.
    It made the file structure but it didn't make the .m2ts video file.

    Everytime I try to use multiAVCHD with these mkv files I get that error.
    So I tried it with .srt instead of .ass and got the same error.
    I tried to convert my .mkv with Haali gdsmux.exe then compiled with multiAVCHD and still got the same error.


    I searched google for that error and I couldn't find any solutions.
    Does anyone know what's wrong your should I post in a bug/technical help forum?

    EDIT: I followed these steps in post #5: http://forum.videohelp.com/threads/336204-multiAVCHD-error?highlight=header
    and they fixed my error!
    I can play subtitles fine now and the blu-ray structure works with my players. The only thing that sucks is I have to mkvmerge all my episode which is a bit tedious to do one by one, but at least it works haha

    thank you
    Last edited by kaitlyn2501; 15th Dec 2013 at 18:21.
    Quote Quote  
  5. multiAVCHD is no longer developed so posting probably won't help.

    Try using your assets from a very simple file structure like "c:\MyVideos" and output to something simelar like "c:\Output". I think I recall something similar using ..\Documents\... or perhaps ..\Desktop\.. Anyway one of those directories Windows try to rename to something completely different in my language. I recall it didn't make the m2ts file or it was empty.
    Quote Quote  



Similar Threads