VideoHelp Forum
+ Reply to Thread
Results 1 to 2 of 2
Thread
  1. At some stage (and I'm assuming it's when MPC-HC switched to LAV filters) I lost the ability to open a DirectShowSource script with MPC-HC if the source file contains AVC video. The container doesn't seem to matter, just whether the video is AVC. Other types of video I've tested seem to be fine.

    MPC-HC displays an Avisynth error message:
    DirectShowSource: Renderfile, the filter graph manager won't talk to me

    The same script will open fine using MPC-BE or VirtualDub etc (ffdshow decoding). I've tried disabling MPC-HC's internal filters and adding the ffdshow video decoder as a preferred external filter, but nothing has worked so far.

    Other methods such as FFVideoSource and AVISource seem to work as they always have (even if the source file contains AVC video).

    After attempting to open a "problem" DirectShowSource script with MPC-HC and then using the Play/Filters menu, there's three filters listed as follows (in this case the source file was an MKV containing AVC video):

    Video Mixing Renderer 9 (renderless)
    Color Space Converter
    AVI/WAV File source

    Repeating the process using an FFVideoSource script instead (which will successfully open), shows these three filters listed:

    Video Renderer
    AVI Decompressor (YV12)
    AVI/WAV File source

    I guess for a start, could someone create a DirectShowSource script to open a file containing AVC video and let me know if MPC-HC will open it, so at least I'll know whether it's a problem unique to my PC. Well actually, unique to two PC's here. Both are running XP and Avisynth 2.5.8.

    Thanks.
    Last edited by hello_hello; 11th Dec 2013 at 16:01.
    Quote Quote  
  2. Originally Posted by hello_hello View Post
    I guess for a start, could someone create a DirectShowSource script to open a file containing AVC video and let me know if MPC-HC will open it, so at least I'll know whether it's a problem unique to my PC. Well actually, unique to two PC's here. Both are running XP and Avisynth 2.5.8.
    Someone? Anyone??
    Quote Quote  



Similar Threads