VideoHelp Forum
+ Reply to Thread
Results 1 to 5 of 5
Thread
  1. Member
    Join Date: Sep 2008
    Location: United States
    Search Comp PM
    I installed VobSub (so I could use VirtualDub to permanently embed subtitles into the video), but now videos no longer display separate external subtitles when I open them in Media Player Classic. Auto-load subtitles is checked in MPC.

    I can get them to work if I use "DirectShow Video: VMR7 (renderless)" in MPC, but then the video gets too light. How do I get external subtitles to show using "DirectShow Video: System Default" in MPC?

    MPC (unicode build) 6.4.9.0
    VobSub 2.23
    Windows XP (64-bit)
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Tried install latest vsfilter?
    Quote Quote  
  3. Member
    Join Date: Sep 2008
    Location: United States
    Search Comp PM
    I'm pretty sure VSFilter is already installed. I don't know if it's the latest one, but subtitles were showing fine before I installed VobSub. I believe I installed VSFilter using K-Lite Mega Codec Pack 9.4.0. Should that work with VobSub? Is there a way to configure VSFilter if I already have it? Or is the latest version necessary?

    I noticed that doing the following does nothing:
    Start > All Programs > K-Lite Codec Pack > Configuration > DirectVobSub

    The configuration does not open. Is this an issue of changing the target? I had to do that in order to get VobSub Configure to open.
    Quote Quote  
  4. Originally Posted by lomaidala View Post
    I can get them to work if I use "DirectShow Video: VMR7 (renderless)" in MPC, but then the video gets too light. How do I get external subtitles to show using "DirectShow Video: System Default" in MPC?
    I don't work with subtitles much so if I tried to help I'd just be wildly guessing, however.....

    Could I be so bold as to suggest you appear to be asking the wrong question. Instead, I'd be thinking asking how to fix the luminance levels when using the VMR7/9 renderers would be a better one.
    If it's the usual "TV levels in video while displaying it on a PC monitor which uses PC levels" problem, then there's likey to be an option in your video card's control panel which will get it to expand TV levels to PC levels on playback. That's the way I do it, as then the levels are always right regardless of the player/renderer being used, or there's a couple of ways to get MPC-HC to do it. One is to enable the "16-235 -> 0-255" pixel shader if you're familiar with those, or under the View/Renderer Settings/Output Levels menu there's an option to choose between TV (16-235) and PC (0-255) levels.... which will probably be greyed out as I'm pretty sure that setting only works with the EVR Renderer. At least that's how it seems to work using XP.

    I wonder what the system default renderer is? One which expands TV levels to PC levels I'd assume, and given by default the EVR Renderer does for MPC-HC, maybe if the EVR Renderer is installed it becomes the system default renderer. It's no big deal but does anyone know?
    Quote Quote  
  5. Member
    Join Date: Sep 2008
    Location: United States
    Search Comp PM
    That is an insightful way of approaching the problem. Such thinking did not occur to me. It is a bit complex though, and I decided to first try out a few solutions that seemed more readily available at my fingertips.

    I installed the latest vsfilter, but that made things worse. I got the blue screen of death when opening any video file, whether or not it had subtitles (could this have been a 64-bit conflict?).

    So I uninstalled vsfilter and reinstalled the entire K-Lite Codec Pack. Everything works fine now.
    Quote Quote  



Similar Threads