VideoHelp Forum
+ Reply to Thread
Results 1 to 21 of 21
Thread
  1. Member
    Join Date: Jun 2013
    Location: Egypt
    Search PM


    First of all i would like to greet all of forum members

    I have a problem in media player classic with a sound

    And that problem appears only with mp4 video files

    And This is a picture to show you what's the real problem




    At the end i wish to solve this problem

    Thanks a lot


    Memtodemon@gmail.com
    Quote Quote  
  2. MPC or MPCHC? Check the audio codec then enable the codec in MPC's internal decoders or download one and install it. Probably AAC.
    Quote Quote  
  3. Member
    Join Date: Jun 2013
    Location: Egypt
    Search PM
    thank you for Reply


    i'm already did all these steps and the problem still exists
    Quote Quote  
  4. Member netmask56's Avatar
    Join Date: Sep 2005
    Location: Sydney, Australia
    Search Comp PM
    Post a MediaInfo report on one of your MP4 files might help...
    TheVoiceIsAnotherPerson ~ BeyonWiz DP-P1 and T3 PVR's ~ Popcorn C200 ~ Samsung ES8000 65" LED TV ~ Windows 7 ~ Yamaha RX-A1030 http://www.openwiz.org/wiki/ProjectX
    Quote Quote  
  5. I'm a Super Moderator johns0's Avatar
    Join Date: Jun 2002
    Location: canada
    Search Comp PM
    Upload a short clip and don't use big text.
    I think,therefore i am a hamster.
    Quote Quote  
  6. Member
    Join Date: Jun 2013
    Location: Egypt
    Search PM
    General
    Complete name : L:\Clips\Sandy & Karl Wolf - Awel Marra Atgara' - YouTube.mp4
    Format : dash
    Codec ID : dash
    File size : 53.3 MiB
    Duration : 3mn 37s
    Overall bit rate : 2 054 Kbps
    Encoded date : UTC 2013-05-21 15:03:47
    Tagged date : UTC 2013-05-21 15:03:47

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : Main@L3.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 3 frames
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 3mn 37s
    Bit rate mode : Constant
    Bit rate : 2 051 Kbps
    Width : 1 280 pixels
    Height : 720 pixels
    Display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 25.000 fps
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.089
    Stream size : 53.2 MiB (100%)
    Encoded date : UTC 2013-05-21 15:03:47
    Tagged date : UTC 2013-05-21 15:03:47
    Quote Quote  
  7. Member
    Join Date: Jun 2012
    Location: USA
    Search Comp PM
    Based on your mediainfo report, this isn't a playback issue, your files literally have no sound. How are you aquiring them?
    Quote Quote  
  8. Member
    Join Date: Jun 2013
    Location: Egypt
    Search PM
    So What i can do
    Quote Quote  
  9. Get some sound.
    Quote Quote  
  10. Member
    Join Date: Jun 2013
    Location: Egypt
    Search PM
    Now I'm going to upload the video that has the problem
    Quote Quote  
  11. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    There is no use uploading the video - mediainfo reports no audio - so there probably is no audio . ie.. it's probably not a playback problem

    If you downloaded it from somewhere, try other software to download it
    Quote Quote  
  12. Member
    Join Date: Jun 2013
    Location: Egypt
    Search PM
    That's the video that has the problem



    Attachment 18374
    Quote Quote  
  13. Member
    Join Date: Jun 2013
    Location: Egypt
    Search PM
    Originally Posted by poisondeathray View Post
    There is no use uploading the video - mediainfo reports no audio - so there probably is no audio . ie.. it's probably not a playback problem

    If you downloaded it from somewhere, try other software to download it


    First thank you for reply

    i had download it from YouTube by internet download manager v6.07
    That's all
    Quote Quote  
  14. I think your file is corrupt. Download it again.
    Quote Quote  
  15. Freemake Video Downloader was able to download that video successfully -- with audio.
    Quote Quote  
  16. Member
    Join Date: Feb 2010
    Location: Bavaria
    Search PM
    downloaded it too from Germany but with special workflow. Do you want that specific file or the complete workflow. should work everywhere. file has 66.3 MB
    Quote Quote  
  17. Member turk690's Avatar
    Join Date: Jul 2003
    Location: ON, Canada
    Search Comp PM
    Originally Posted by Memto View Post
    General
    Complete name : L:\Clips\Sandy & Karl Wolf - Awel Marra Atgara' - YouTube.mp4
    Format : dash
    Codec ID : dash
    File size : 53.3 MiB
    Duration : 3mn 37s
    I have encountered this when trying to download some clips off YouTube in 1080 or 720 HD (if there is that choice). File is unplayable (WMP, MPC, VLC, etc.), telltale sign is mediainfo reporting dash for codec and format, and there is no audio stream. If downloaded at 480 or below resolutions however, clip plays back normally (mp4 container but much more likely flv); audio is present. It may or may not be a deliberate YouTube thing, as some clips that could be downloaded before with audio and video intact and playable are not so now.
    The downloader used affects the results. Real player & keepHD all show this problem (they all didn't before); internet download manager may or may not (maybe if you paid it will behave better?). The latest freemake video downloader behaves properly (for now, on nearly all clips I tried), so I guess is a good first choice. Ant will only download 360 or 480 resolution versions, even if either 720 or 1080 was duly chosen before clicking the wretched download button (resulting file is playable mp4 sometimes, again more likely flv).
    The file Memto downloaded is not corrupt, video-wise; the player just can't detect what codecs to display it with so that's what it says. Mediainfo says it like it is. If the clip must really, really be obtained in HD and downloading in any form only results in like the OP got, there are workarounds that basically go like these:
    1. use some sort of repair program (like videorepair, paid; free version repairs only half the length.... though you can figure out how to make it repair the whole) to re-establish correct headers and all the info in them on the downloaded mp4 HD clip
    2. demux to get video
    3. download the properly-behaving 480 resolution version and demux
    4. remux the video from step 2 and audio from step 3
    Lots of things are changing on the internet that include the move to HTML5 & WebM, subtle methods used by sites to prevent downloading or not, downloaders that have to be updated or not, etc that all conspire to prevent us from doing so....
    Last edited by turk690; 18th Jun 2013 at 00:57.
    Stop feeling suicidal just because he unfriended you on fezbuk.
    Quote Quote  
  18. Member
    Join Date: Jul 2010
    Location: Cleveland, Ohio
    Search PM
    How does one "figure out how to make (HD Video Repair Utility) repair the whole"? It seems like a fairly beneficial program, but at $130 I can't justify the purchase...

    Some YouTube videos I cannot directly download a muxed A/V stream and the usual download tools will not work. However, Jaksta Streaming Media recorder is able to obtain a separate video and audio stream of these videos which are protected by invalidity in some form. The HD Video Repair Utility seems to be able to somewhat repair the video stream, at least to the point where I can bring it into MP4Box to remux it so that's it's usable in my target editing application. I've had no such luck with the audio stream; HD Video Repair Utility will find the stream and "repair" it, but the resulting file is unplayable moreso than the original. The original audio stream is playable in my copy of Zoom Player with ffdshow as well as WMP with AC3Filter but not "repaired" stream.

    Any advice would be appreciated. The video I'm currently trying to deal with is here: http://www.youtube.com/watch?v=8hhu-OyHqZM
    I don't need the audio stream because I would just replace it with a CD extraction, but it would be very helpful in terms of syncing and editing. (Perhaps I could just VAC record the stream since I can play it and then resync as necessary)
    Quote Quote  
  19. Member
    Join Date: Jul 2010
    Location: Cleveland, Ohio
    Search PM
    Well I was able to get the tool to repair the whole by hex editing a larger file... unfortunately there's an error present after repair which causes missing frames that equate to almost exactly 4 beats... ugh, I give up. For now. And I had the CD audio synced up perfectly with the good portion. I was so close.
    Quote Quote  
  20. Member
    Join Date: Aug 2013
    Location: Aus
    Search Comp PM
    Hi Guy's

    What I have found recently is the MP4 file container have an encrypted AAC audio track.

    The Audio track is there.

    You can play the movie but with no sound.

    You can try converting it but if the audio track is encrypted the same thing will happen.

    Mogo!!!
    Last edited by Mogo 529; 25th Aug 2013 at 23:35.
    Quote Quote  
  21. Member netmask56's Avatar
    Join Date: Sep 2005
    Location: Sydney, Australia
    Search Comp PM
    Post a mediainfo report on the file in question.
    TheVoiceIsAnotherPerson ~ BeyonWiz DP-P1 and T3 PVR's ~ Popcorn C200 ~ Samsung ES8000 65" LED TV ~ Windows 7 ~ Yamaha RX-A1030 http://www.openwiz.org/wiki/ProjectX
    Quote Quote  



Similar Threads