VideoHelp Forum
+ Reply to Thread
Results 1 to 12 of 12
Thread
  1. Member
    Join Date: Jan 2013
    Location: Canada
    Search Comp PM
    I added subtitles to some mkv files using MKVMerge, however now when I scan through the files with VLC, it takes 15 seconds before it starts playing again. I can skip to any part of the original mkv files and VLC plays without any lag. Any ideas?
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Are you using latest mkvtoolnix? You can try disable header compression, under file->setting in mkvtoolnix and remux again.
    Quote Quote  
  3. Member
    Join Date: Jan 2013
    Location: Canada
    Search Comp PM
    I did this but unfortunately it did not work. I remuxed with header compression disabled. I don't think header compression is related to subtitles since when I enabled it, the option showed 'none' on video and audio files but not subtitles. I switched it to none on subtitles anyway but my files still went from instantaneous scanning to 10-25 seconds.

    Just to make sure I'm doing this right I click add for both the .mkv file and the .srt file right? Then remux? The only other changes I made were to switch the added SRT file to 'yes' for both default and forced because it's subtitle that translates alien language into English so there aren't many lines.

    I am using mkvmerge GUI v5.9.0.
    Quote Quote  
  4. Member
    Join Date: Jan 2013
    Location: Canada
    Search Comp PM
    I noticed the files were originally muxed with 5.4.0. I went back to that version and the files scan perfectly with the added subtitles now. So 5.9.0 has a small bug somewhere.
    Quote Quote  
  5. Originally Posted by Maskawisewin View Post
    I added subtitles to some mkv files using MKVMerge, however now when I scan through the files with VLC, it takes 15 seconds before it starts playing again. I can skip to any part of the original mkv files and VLC plays without any lag. Any ideas?
    I am having the EXACT same problem. The last time I used this program (about 4 months ago and on a different computer), this didn't happen. I guess I'll downgrade as well.

    EDIT:
    Downgraded to 5.4.0, and the problem is gone for me as well. This version seems to be working fine, so I guess I'll stick with it.
    Last edited by vegeta13613; 1st Jan 2013 at 21:39.
    Quote Quote  
  6. Member
    Join Date: Jan 2013
    Location: Canada
    Search Comp PM
    I don't think there's a need to downgrade so far. I'm started with 5.4.0 but I really think it would be best to go to 5.8.0 and work your way backwards. If you do this before me, please report back.
    Quote Quote  
  7. You can add this parameters :

    --clusters-in-meta-seek --engage no_cue_duration --engage no_cue_relative_position

    It will fix the problem of seeking after remuxing.
    Quote Quote  
  8. Member
    Join Date: Jan 2013
    Location: Canada
    Search Comp PM
    Would you be so kind as to explain what these flags do? Can I add these flags in the GUI (i.e. is there a place to paste that line)?
    Quote Quote  
  9. Hi,

    First read this, it will explain the bug :

    https://trac.bunkus.org/wiki/FAQ%3APlaybackDoesNotWorkVLCCannotSeekMkvmerge590

    The bug doesn't seem to be resolved even if it is marked fixed in the VLC bug tracker.

    Now, how you do this :
    In the menu bar go to Muxing->add command line option

    In the new window jsut past in the bottom field (command line options) :

    --clusters-in-meta-seek --engage no_cue_duration --engage no_cue_relative_position

    Remux and your done.

    Note that those options need to be pasted EACH time you open MKVToolNIX : they are not persistent.

    But before doing so, if you don't want to remux, there is a workaround in VLC. I just quote a passage of the page i linked to you at the begining of the post:

    Turning on "Dummy elements" fixes this immediately; now seeking works as it has before. You can do that in VLC here : Tools -> Preferences -> "Show settings: all" at the bottom left; In the tree on the left side: Input/Codecs -> Matroska; make sure "Dummy elements" is turned on.

    Regards
    Quote Quote  
  10. Member
    Join Date: Apr 2013
    Location: France
    Search PM
    Originally Posted by Namoi View Post
    Hi,

    First read this, it will explain the bug :

    https://trac.bunkus.org/wiki/FAQ%3APlaybackDoesNotWorkVLCCannotSeekMkvmerge590

    The bug doesn't seem to be resolved even if it is marked fixed in the VLC bug tracker.

    Now, how you do this :
    In the menu bar go to Muxing->add command line option

    In the new window jsut past in the bottom field (command line options) :

    --clusters-in-meta-seek --engage no_cue_duration --engage no_cue_relative_position

    Remux and your done.

    Note that those options need to be pasted EACH time you open MKVToolNIX : they are not persistent.

    But before doing so, if you don't want to remux, there is a workaround in VLC. I just quote a passage of the page i linked to you at the begining of the post:

    Turning on "Dummy elements" fixes this immediately; now seeking works as it has before. You can do that in VLC here : Tools -> Preferences -> "Show settings: all" at the bottom left; In the tree on the left side: Input/Codecs -> Matroska; make sure "Dummy elements" is turned on.

    Regards
    Thanks Sir.
    No more freeze when i try to scan a remuxed mkv .
    Works like a charm for me on v6.1.0
    Arigato !
    Quote Quote  
  11. Originally Posted by Namoi View Post
    ...there is a workaround in VLC. I just quote a passage of the page i linked to you at the begining of the post:

    Turning on "Dummy elements" fixes this immediately; now seeking works as it has before. You can do that in VLC here : Tools -> Preferences -> "Show settings: all" at the bottom left; In the tree on the left side: Input/Codecs -> Matroska; make sure "Dummy elements" is turned on.

    Regards

    Perfect! This did the trick for me as well. Thank you so much!
    Quote Quote  
  12. you're welcome
    Quote Quote  



Similar Threads