VideoHelp Forum
+ Reply to Thread
Results 1 to 2 of 2
Thread
  1. on Hybrid 2012.05.03 how do i change frame rates? example:29.97 > 23.976 ext.
    Quote Quote  
  2. how do i change frame rates? example:29.97 > 23.976 ext.
    In general: In the Filtering-Tab.

    Detailed:
    It depends on what your input and what your target is.

    1. Assuming your content is telecine/3:2 Pulldown
      • and detected as telecine/3:2 Pulldown by Hybrid
        If 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Auto deinterlacing' is active, Hybrid will automatically select 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Deinterlacer->ivtc - filmdint'
        or
        'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Deinterlacer->TIVTC (Avisynth) or Decomb (Avisynth)' if you installed the Avisynth extension.
        Both are fine methods and you do not have to do anything.
      • but detected as 'Top or Buttom field first'
        Running 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Analyse' might als cause Hybrid to detect you material properly assuming it was not properly flagged. (if this changes how Hybrid detects the content, choose another way in this list)
        You need to select on of the methods mentioned above. Running 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Analyse' might als cause Hybrid to detect you material properly assuming it was not properly flagged.
      • but your content is detected as progressive.
        Running 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Analyse' might als cause Hybrid to detect you material properly assuming it was not properly flagged. (if this changes how Hybrid detects the content, choose another way in this list)
        You need to activate 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Deinterlacer' select on of the methods mentioned above.
    2. assuming your content is interlaced
      • and detected as 'top or bottom field first'
        • and you want the output to be progressive with 23.976 fps
          You can select a deinterlaced of your choice under 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Deinterlacer', as default Hybrid will choose Yadif or Yadif (Avisynth).
          You need to decide wether you want to slow down the material (-> activate 'Filtering->Speedchange->Speed Settings->Change speed' and select '23.976fps') or you want to drow frames to meet you target frame rate (-> activate 'Filtering->Speedchange->Speed Settings->Scale output frame rate' and select '23.976fps')
        • and you want the output to be interlaced with 23.976 fps
          You should make sure to deactivate 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Auto deinterlacing'.
          You need to decide wether you want to slow down the material (-> activate 'Filtering->Speedchange->Speed Settings->Change speed' and select '23.976fps') or you want to drow frames to meet you target frame rate (-> activate 'Filtering->Speedchange->Speed Settings->Scale output frame rate' and select '23.976fps')
      • but detected as 'progressive' or 'telecine'
        Running 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Analyse' might als cause Hybrid to detect you material properly assuming it was not properly flagged. (if this changes how Hybrid detects the content, choose another way in this list)
        • and you want the output to be progressive with 23.976 fps
          You should make sure to activate 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Force deinterlacing'.
          You can select a deinterlaced of your choice under 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Deinterlacer', as default Hybrid will choose Yadif or Yadif (Avisynth).
          You need to decide wether you want to slow down the material (-> activate 'Filtering->Speedchange->Speed Settings->Change speed' and select '23.976fps') or you want to drow frames to meet you target frame rate (-> activate 'Filtering->Speedchange->Speed Settings->Scale output frame rate' and select '23.976fps')
        • and you want the output to be interlaced with 23.976 fps
          You should make sure to activate interlaced encoding in you x264/Xvid/... settings.
          You need to decide wether you want to slow down the material (-> activate 'Filtering->Speedchange->Speed Settings->Change speed' and select '23.976fps') or you want to drow frames to meet you target frame rate (-> activate 'Filtering->Speedchange->Speed Settings->Scale output frame rate' and select '23.976fps')
    3. assuming your content is progressive
      • and detected as progressive
        • and you want the output to be progressive with 23.976 fps
          You need to decide wether you want to slow down the material (-> activate 'Filtering->Speedchange->Speed Settings->Change speed' and select '23.976fps') or you want to drow frames to meet you target frame rate (-> activate 'Filtering->Speedchange->Speed Settings->Scale output frame rate' and select '23.976fps')
      • and you want the output to be interlaced with 23.976fps
        You should make sure to activate interlaced encoding in you x264/Xvid/... settings.
        You need to decide wether you want to slow down the material (-> activate 'Filtering->Speedchange->Speed Settings->Change speed' and select '23.976fps') or you want to drow frames to meet you target frame rate (-> activate 'Filtering->Speedchange->Speed Settings->Scale output frame rate' and select '23.976fps')
      • you want to use ivtc to lower the frame rate to 23.976fps
        If you want the output to be interlaced: You should make sure to activate interlaced encoding in you x264/Xvid/... settings.
        You need make sure to activate 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Force deinterlacing' and select on of the ivtc methods ('ivtc - filmdint', 'Decomb (Avisynth)', 'TIVTC (Avisynth)').
      • and detected as 'interlaced' or 'telecine'
        Running 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Analyse' might als cause Hybrid to detect you material properly assuming it was not properly flagged. (if this changes how Hybrid detects the content, choose another way in this list)
        You should make sure to deactivate 'Filtering->Deinterlace/Telecine->Deinterlace/Telecine Settings->Auto deinterlacing'.
        If you want the output to be interlaced, you should make sure to activate interlaced encoding in you x264/Xvid/... settings.
        You need to decide wether you want to slow down the material (-> activate 'Filtering->Speedchange->Speed Settings->Change speed' and select '23.976fps') or you want to drow frames to meet you target frame rate (-> activate 'Filtering->Speedchange->Speed Settings->Scale output frame rate' and select '23.976fps')


    Hope, this helps (and I didn't miss a scenario or make a mistake somewhere) and "Yes, this is only such a hunk of text because your questions wasn't detailed enough."

    You can check the output frame rate (not taking x264's pulldown flags into account) under: "Filtering->Current Frame Rate/Count"

    Cu Selur

    Ps.: DOH, I forgot a side note!
    As alternative to 'Filtering->Speedchange->Speed Settings->Scale output frame rate' you can also use 'Avisynth filter->Motion FPS' if the Avisynth extension is installed.

    PPs.: Just released a new version:
    Hybrid rev. 2012.05.05.1

    *fixed*
    • vfw: fixed vfw video decoder detection on 64bit systems
    • profiles: profiles with a '.' in the name weren't detected when saved,...
    • muxing: accidentally frame count made it's way into the fps options,..
    -> downloads: http://www.selur.de/downloads
    (should be enough to download the 'Hybrid - only' download that matches you OS and extract the binary into the Hybrid folder)
    Last edited by Selur; 5th May 2012 at 05:00.
    Quote Quote  



Similar Threads