VideoHelp Forum
+ Reply to Thread
Results 1 to 19 of 19
Thread
  1. Hey guys, i have a problem.. i had a bunch of mkv files (episodes) that i wanted to edit so i converted them to m4v with mkvtomp4 but they are not accepted in my vegas movie hd platinum 11 ! do you know why? and the thing is ive always worked with m4v/mp4 formats! anyway here is some info of one of the files from mediainfo:


    General
    Complete name : C:\Users\Windows 7 Pro\Desktop\DEATH NOTE\MP4 OR AVI\Death Note episode 1.m4v
    Format : MPEG-4
    Codec ID : M4V
    File size : 260 MiB
    Duration : 19mn 59s
    Overall bit rate mode : Variable
    Overall bit rate : 1 818 Kbps
    Encoded date : UTC 2012-04-24 23:47:42
    Tagged date : UTC 2012-04-25 23:49:16
    Writing application : MkvToMp4 [www.mkvtomp4.ru] version 0.218

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4.1
    Format settings, CABAC : Yes
    Format settings, ReFrames : 3 frames
    Codec ID : avc1
    Codec ID/Info : Advanced Video Coding
    Duration : 19mn 59s
    Bit rate : 1 392 Kbps
    Maximum bit rate : 4 739 Kbps
    Width : 720 pixels
    Height : 480 pixels
    Display aspect ratio : 16:9
    Original display aspect ratio : 16:9
    Frame rate mode : Constant
    Frame rate : 23.976 fps
    Standard : NTSC
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.168
    Stream size : 199 MiB (77%)
    Writing library : x264 core 59 r859M ce13bb6
    Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x133 / me=hex / subme=5 / me-prepass=0 / brdo=0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=1 / nr=0 / decimate=1 / mbaff=0 / fgo=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / bime=1 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=1392 / ratetol=1.0 / rceq='blurCplx^(1-qComp)' / qcomp=1.00 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=2:1.00
    Language : Japanese
    Encoded date : UTC 2012-04-24 23:47:42
    Tagged date : UTC 2012-04-24 23:48:29

    Audio
    ID : 2
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format profile : LC
    Codec ID : 40
    Duration : 19mn 59s
    Bit rate mode : Variable
    Bit rate : 418 Kbps
    Maximum bit rate : 488 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Stream size : 59.7 MiB (23%)
    Language : Japanese
    Encoded date : UTC 2012-04-24 23:48:24
    Tagged date : UTC 2012-04-24 23:48:29

    Text
    ID : 3
    Format : Apple text
    Codec ID : text
    Duration : 19mn 59s
    Duration_FirstFrame : -1mn 20s
    Bit rate mode : Variable
    Bit rate : 1 bps
    Stream size : 82.0 Bytes (0%)
    Encoded date : UTC 2012-04-25 23:49:16
    Tagged date : UTC 2012-04-25 23:49:16
    Last edited by Baldrick; 26th Apr 2012 at 06:17. Reason: New title
    Quote Quote  
  2. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    Remove the subtitle track when you use mkvtomp4.

    You could also try remux the mkv to mp4 with other tools like avidemux, open video and under audio choose copy, save a mkv. Or with ffmpeg, ffmpeg -i video.mkv -vcodec copy -acodec copy new.mp4.
    Quote Quote  
  3. i didn't convert with the subtitles? mkv has subs while m4v doesnt..
    i didnt understand how to fix my problem, could you be more..simple ?
    Quote Quote  
  4. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    But it says that is has subs from MEDIAINFO??? Can't you adjust any setting in mkvtomp4 to disable subtitles? I have never used it.

    Or try other mkv to mp4 tools like avidemux(as I already mentioned and how to....) or http://www.videohelp.com/tools/sections/all-in-one-mkv-to-mp4-avchd-ts
    Quote Quote  
  5. no it hasnt got any subs, i played around with the sub settings on vlc and there arent any
    is that the problem? i have gotsent too that can work, should i use it instead? i dont want to convert to avi coz i will lose much quality
    Quote Quote  
  6. gotsent didnt work any suggestions?
    Quote Quote  
  7. i tried multiple different converters and none worked so i guess ill go with my good old handbrake
    Quote Quote  
  8. ok so i converted some of them with handbrake but it still didnt work!
    so i guess i need to download some codecs or something? anyone knows which?
    Quote Quote  
  9. i installed quick time too but stil didnt work .. help me please :'(
    Quote Quote  
  10. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    What is the error in vegas when you try import it?

    You could also try remux/convert the mp4s to a new mp4 with mp4muxer (quicktime), open mp4 and make a new one. Or use quicktime pro or mpeg streamclip and do the same.
    Quote Quote  
  11. the error message vegas pops up is : ''None of the files dropped On Vegas Movie Studio HD Platinum could be opened.''
    Okay thanks ill try what you said and tell you if it worked
    Quote Quote  
  12. ok i did what you said to me. created new mp4, converted to avi, wmv.. but STILL didnt work . so the problem isnt the format because as i already said ive been working with m4v for a long time. im editing for my youtube channel (http://www.youtube.com/user/loosecontroiPL)
    anyway i found an answer into a thread of someone who had the same problem but i didnt understand what he meant.
    http://www.videoforums.co.uk/sony-vegas-media-studio/37691-cant-get-m4v-into-vegas-eve...i-wmv-mp4.html
    he said : ''I got it to work with the MP4 (AVC) setting. Should I delete this thread? if thats possible? Or could this be helpful to someone'' what did he mean?
    Quote Quote  
  13. anyone knows what the guy meant by ''I got it to work with the MP4 (AVC) setting.'' ?
    Quote Quote  
  14. Last edited by loosecontroi; 26th Apr 2012 at 12:58.
    Quote Quote  
  15. problem solved but go **** yourselves for not helping me bitches
    Quote Quote  
  16. aBigMeanie aedipuss's Avatar
    Join Date: Oct 2005
    Location: 666th portal
    Search Comp PM
    Originally Posted by loosecontroi View Post
    problem solved but go **** yourselves for not helping me bitches

    grow up. no one here cares about your stupid stolen anime tv series videos. next time buy the box set from amazon THIEF.
    --
    "a lot of people are better dead" - prisoner KSC2-303
    Quote Quote  
  17. I'm a MEGA Super Moderator Baldrick's Avatar
    Join Date: Aug 2000
    Location: Sweden
    Search Comp PM
    how did you solve it? Others might find it helpful....
    Quote Quote  



Similar Threads