VideoHelp Forum
+ Reply to Thread
Results 1 to 4 of 4
Thread
  1. Hello there, this is a problem that I've been tinkering with today, but I just can't fix it...


    http://imgur.com/7pQVe


    Different font:


    http://imgur.com/J3lsq



    Here are some facts:

    1. I've been using japanese regional settings alot. Yes. Most likely this is related to the problem one way or another.

    2. Due to 1, I've been reinstalling MPC-HC with my normal regional settings to see if it made any difference. It didn't. I'm using the CCCP package.

    3. VLC also does the same thing, although it's a box instead of an actual japanese character.

    4. The subtitles are embedded in the video, or whatever. There's no subtitle file. It seems the subtitles in the video are in the UTF-8 format. They're "softsubs" I think, since you can change the font yourself.

    5. I have tried deleting the FNTCACHE.dat file in system32 and rebooting. No difference.



    Again, I don't have japanese regional settings on right now. But these video players still apparently wants to show characters like that instead of an "", and presumably other similar characters. Why? I don't have a clue at this point. Both VLC and MPC-HC tries the same thing, and they obviously shouldn't be doing that since there's no japanese characters involved in the actual subtitles.



    I'd be grateful for any help
    Quote Quote  
  2. Member
    Join Date: Jan 2012
    Location: Australia
    Search Comp PM
    If the subtitles are embedded in the video, it could be a problem with the actual embedded subtitle file. Try the attached .srt file to see whether you can see the ''. Open any video, and drag the subtitles in if your player supports it. There should be a line for 1 minute with the capped e to see whether the problem is the embedded video subs, or an actual problem on your computer for rendering the capped e. When I played the subs with a video using VLC, I was able to see the capped e.
    Attached Files
    Quote Quote  
  3. Thanks for that test, yes I can see the . Infact, right now I'm using japanese regional settings and I'm able to see four 's in VLC. One in MPC-HC. This is what the .srt looks like for me with jpn regional settings on:

    1
    00:00:00,000 --> 00:01:00,000
    Test subtitles, can you see the capped e: 鳬鳬鳬・


    I'm curious why that last ended up as a dot instead of the japanese character, but whatever.

    But yea when I switch back to normal regional settings the .srt looks the way it should either way... Which is good.

    So, I guess it's possible that the embedded .srt file in that anime video is entirely at fault? Because I haven't been able to change it at all, and I've tried alot of things now. Well it'd be good if that's the case.
    Quote Quote  
  4. Member
    Join Date: Jan 2012
    Location: Australia
    Search Comp PM
    Yep, its possible that the subtitle file embedded in the video was at fault. If you want to fix the problem with the subs, you can use a tool such as Mkvtoolnix (or Avidemux for AVIs) to demultiplex the video into its elementary streams. You can then load the resulting .ass/.ssa file into a subtitle editor like Subtitle Edit and fix it from there. If you want to add the 'anime sub' look, then use Aegisub to resave the subs as an .ass file. The styles manager on there allows you to change font, outline of font, and shadow of font. Have fun
    Quote Quote  



Similar Threads