VideoHelp Forum
+ Reply to Thread
Results 1 to 6 of 6
Thread
  1. Hi everyone.

    I made this little movie using VisualBoyAdvance's built-in AVI recorder and VirtualDub:

    https://www.youtube.com/watch?v=tTVSxi-myvE&feature=g-upl&context=G2bb827bAUAAAAAAAAAA

    The encoding is Xvid MPEG-4. But as you can see, the audio progressively desyncs itself from the video during playback. This tends to happen a lot when using VBA's built-in video recorder, but usually a simple encoding in VirtualDub with the "sync to audio" option ticked will fix this. Except this time it did nothing.

    So I tried adjusting the framerate so that audio and video would last the same amount of time using Direct Stream Copy mode, and it did nothing. Then I did the same thing again using Full Processing mode, and it did nothing. I tried typing lots of different keyphrases in the Startpage search engine regarding this problem, and only found solutions that either did not fit my situation, or that I had already tried.

    I would appreciate any suggestions susceptible of sorting out this mess. Please note that I unfortunately do not have the original, raw recording anymore because I needed to make room on my hard drive, and did not expect the desync issue to turn out this bad post-upload.

    Thanks in advance.
    Quote Quote  
  2. Determine how far off the audio is near the end of the video and stretch/shrink the audio to match using VirtualDub's advanced audio filtering.
    Quote Quote  
  3. Thanks for the help.

    Apparently, the biggest desync in the whole video, on the version I have on my computer at least, is the audio being four seconds behind. i found an "advanced audio filtering" option in virtualDub, but all I seem to be able to do is turn it on or off. I can't find anything else other than the "filters" option, which I don't understand. So how should I proceed to specify in which way I want it to correct the audio ?
    Quote Quote  
  4. After turning on the Advanced Audio Filtering option click on Audio -> Filters.... Add filters to build a filter chain. Add Input, Stretch, Output. Connect them if they don't auto connect. Double click on the Stretch filter and input a value.

    Name:  aud.png
Views: 206
Size:  41.0 KB

    I forget which way it works but 0.99 or 1.01 will change the length by 1 percent. If your audio is off by 4 seconds after 660 seconds (11 minutes) you need to stretch or squish it by:

    660/656 = 1.0061

    or

    660 / 664 = 0.9940
    Last edited by jagabo; 25th Mar 2012 at 12:11.
    Quote Quote  
  5. Just making sure I got this right, the "/" stands for division here ? If so, I just tried both. The first one seems to stretch the audio but barely helped at all, and the second one must be squishing it because it inverted the problem.

    To make it worse, the streamed video remains desynced after the cut credits part (skip to 10:08 to see that), but resyncs itself in the offline equivalent, so I'm not even sure my time is right. I based it off the offline one cause that was the only thing that seemed to make sense, but like I said I used the most desynced moment that is possible to determine, which isn't nearly close to the end of the video since it happens before the cut part...
    Quote Quote  
  6. Yes / stands for division.

    Simply adjusting the length of the audio won't completely fix the A/V sync if you have a variable frame rate issue or erratic frame drops. When I used ffMpegSource() to read the video I found the sound of the mothership exploding (9:41.8 in the video) to be 9 or 10 seconds late.
    Quote Quote  



Similar Threads