VideoHelp Forum
+ Reply to Thread
Results 1 to 13 of 13
Thread
  1. Hi folks,

    I have been searching & searching & no luck ... using search here & go--ogle ...

    Here is my problem ... I have an MP4 from YTube ... and when I try to play it on my Netgear EVA-9100 it crashes the media player ... and I have to reset the box (hard reset) ...

    But I noticed by accident that if I run the MP4 thru AviDemux and copy Audio & copy Video, the resulting MP4 will Not crash my Netgear player. However, the Audio and Video is now Out-of-Sync. I guess it has to do with the Warning message that AviDemux gives me when I am loading the Origianl MP4 into it ... something about B Frame accuracy.

    Q1: Is there a way to prevent this Audio-Video out-of-sync problem?

    Since this Sync problem was happening ... I decided may be I can use VirtualDub to repack this MP4. But when trying to use VDub 1.9.11 ... I get the Error ... "Failed to load FFmpeg.dll".

    I have seen posts here on this Error message ... but there is No straight dummy-proof answer.

    I am using Portable version of VirtualDub and have the latest FFDshow installed.

    Q2: How to fix this VirtualDub error message?

    Q3: Is there any other program that I can use besides AviDemux or VDub to recopy my problem MP4 file without complete re-encode?

    Thanks,

    G!
    Last edited by gonwk; 12th Feb 2012 at 17:34.
    Quote Quote  
  2. Hi folks,

    There is no need to answer my Q1 ... Just got it fixed by downloading the Latest version of "AviDemux 2.5 r7200" and they must have fixed A/V Sync problem ... because my MP4 file copied just right. I tried both ways ... saying Yes and No to the B-Frames Warning/Alert ... and both files copied perfectly with the same size and no Sync problems!

    Still would appreciate some help with VirtualDub Error message!

    Thanks,

    G!
    Quote Quote  
  3. This is rather ffdshow error message.
    Try a different (older?) ffdshow version.

    BTW
    Exactly which ffdshow version/build you have installed? rev4305_20120205?
    VideoAudio.pl - Serwis o technologii wideo & audio
    Quote Quote  
  4. Originally Posted by Placio74 View Post
    This is rather ffdshow error message.
    Try a different (older?) ffdshow version.

    BTW
    Exactly which ffdshow version/build you have installed? rev4305_20120205?
    Hi Placio74,

    Thanks for your reply!

    Placio, I just had updated to "ffdshow_rev4305_20120205_clsid_exe" version! so ...

    Q1: What version do you recommend ... please give me Exact rev?

    I am always confused by which version I should use "CLSID" or "ICL12" or "ICL10"!?!? Never know how to decide which is BEST for my System?

    BTW, my OS is Vista Home Premium, SP2, x64 and I have Intel Core Duo CPU T5750 @ 2.00GHz laptop.

    Thanks again!

    G!
    Quote Quote  
  5. clsid is nick of one of developers participating in ffdshow project and released SVN builds.
    ICL10 and ICL12 means that a particular build has been compiled using Intel C++ Compiler 10 or 12. However, devs also uses Microsoft Visual C++ (currently 2010) compiler for generic builds.

    For more go to: http://ffdshow-tryout.sourceforge.net/wiki/faq
    VideoAudio.pl - Serwis o technologii wideo & audio
    Quote Quote  
  6. Hi Placio,

    Thanks for the answer.

    Placio, you mentioned the Older Version has No Problem ... I am on rev4305 ... so which REV will not have all these FFmpeg.dll Error !?!?!

    Q: Can you give me a Rev Number?

    Thanks,

    G!
    Quote Quote  
  7. I can't point a particular build. Issue does not occur for me (probably depend on environment, OS/CPU).

    New build is available - rev4323_20120213.
    If issue still persists, then try rev4257_20120115 (or older).


    BTW
    You are using generic or 64-bit version of ffdshow?
    VideoAudio.pl - Serwis o technologii wideo & audio
    Quote Quote  
  8. Hi Palcio,

    Darn VideoHelp time-out and I lost my 1 page long response ... so here is a quick response befoer VH dumps me out again ...

    Thanks for your Help.

    rev 4323 ... same problem ... but rev 4257 worked.

    But now when I drag and drop MP4 ... even though I don't get ffmepg.dll Error ... but I get Black Screen for the picture ... No Vidoe or Audio ... but it seems to be working since Scroll works ... but Nothing there.

    I have been looking for a repsonse ... searching the last several hours ... for topics here and other locations ... and No Specific answers or tips.

    Can you help with this problem?

    Oh, btw, I use generic CLSID, x32 version. And my OS is Vista Home Premium, with T5750 Intel Chip @ 2.0GHz.

    Thanks again!

    G!
    Last edited by gonwk; 14th Feb 2012 at 19:44.
    Quote Quote  
  9. Hi Placio,

    OK ... disregard my above post ... I have finally solved my 2 prong MP4 problem with VDub ...

    1) not opening MP4 files and giving me the ffmpeg.dll error (Thanks to You)
    2) MP4 file opening with a Black Screen ... and No visual Video & Audio

    Here is what I did for the next person with the same problem ...

    1) I downloaded (all downloads from here VH) the latest VDub 1.10.1 Portable one.
    2) I downloaded the 2 VirtualDubPlugin Packs (1 & 2)
    3) I added the FFInputDriver (I am not sure if this had anything to do with the Fix ... but nonetheless I have it in the "plugin32" folder)
    4) I removed these 2 Drivers from the "plugin32" folder ... "MP4InputDriver.vdplugin" and all the "Quicktime" plugin [3 files].

    I can now drag and drop MP4 into VDub and works just fine!

    Thanks again for everyone's Help & Support here at VideoHelp ... there is always help when you need it.

    G!
    Quote Quote  
  10. SEt's MP4 input plugin does not handle properly H.264/AVC video. After initial release - abandoned. Currently (honestly, for quite some time) no practical reason to use this plugin.

    Other...
    tateu's QuickTime plugin uses QuickTime framework for decoding. Can't use direct stream copy.
    FFInputDriver uses FFmpeg libs for decoding. Again, can't use direct stream copy.
    fccHandler's QuickTime plugin uses VfW and ACM codecs - properly handle H.264/AVC video. And with that plugin can use direct stream copy.
    VideoAudio.pl - Serwis o technologii wideo & audio
    Quote Quote  
  11. Hi Placio74,

    Now you tell me that SEt's & tateu's MP4 Plugins don't work!

    Placio, Thanks for your reply & Input. I tried your Tip about fccHandler's QT Plugin ... you are correct, it works ... I put it in ... it shows the MP4, but when I try to play the MP4 it will not go Forward, meaning the video will Not play ... but I can use the Slider and move thru the Video and it shows the movie ...

    Q: So, what do you think causes this glitch? ... just curous!

    But the way that I have it set up works just fine!

    BTW, I wonder if someone that has a lot of knowledge of Plugins ... could make a Plugin Package that has Only the plugins that work under "Plugins32"... in here it would only be the "Required" plugin ... none of the GPL.txt or Readme.txt ... which does not do anything for the operation of the plugin ... also, they can have a folder called "Sources" under Plugins32 that holds the Zipped version of the Original Plugin ...

    Appreciate all of your Help!

    G!
    Last edited by gonwk; 15th Feb 2012 at 16:57.
    Quote Quote  
  12. Originally Posted by gonwk View Post
    Now you tell me that SEt's & tateu's MP4 Plugins don't work!
    tateu's plugin works - just require installed QuickTime.

    Originally Posted by gonwk View Post
    Placio, Thanks for your reply & Input. I tried your Tip about fccHandler's QT Plugin ... you are correct, it works ... I put it in ... it shows the MP4, but when I try to play the MP4 it will not go Forward, meaning the video will Not play ... but I can use the Slider and move thru the Video and it shows the movie ...
    Odd... you are sure that this plugin is in use?
    Go to File Information and check - plugin name should be included in (window) title.

    Originally Posted by gonwk View Post
    BTW, I wonder if someone that has a lot of knowledge of Plugins ... could make a Plugin Package that has Only the plugins that work under "Plugins32"... in here it would only be the "Required" plugin ... none of the GPL.txt or Readme.txt ... which does not do anything for the operation of the plugin ... also, they can have a folder called "Sources" under Plugins32 that holds the Zipped version of the Original Plugin ...
    If you mean "VirtualDub Portable Plugins Pack" (or similar) it depends on who created package installer (also licensing requirements). But carefully, "VirtualDub Portable Plugins Pack" contain outdated plugins (old versions).
    VideoAudio.pl - Serwis o technologii wideo & audio
    Quote Quote  
  13. vanished El Heggunte's Avatar
    Join Date: Jun 2009
    Location: Misplaced Childhood
    Search Comp PM
    Placio74 is right, the most up-to-date builds of the input plug-ins for VirtualDub should be gotten directly from the author's web site:

    http://fcchandler.home.comcast.net/~fcchandler/

    Also, I think it's not terribly difficult to learn how to use 7-zip, or WinRAR, and (most importantly) Windows Explorer
    Quote Quote  



Similar Threads