VideoHelp Forum
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. Member
    Join Date
    Apr 2009
    Location
    United States
    Search Comp PM
    Ok so right now im using mkvtoolnix-unicode-1.7.0 at least that what the folder is tittled. Anyway I have 2 mkv files, part 1 and part 2. I need to extract the subtitles and convert the video files to avi. I already did that for part 1 and 2. Next I extracted the subtitles for part 1 and 2. Had no problems with part 2. Converted the mkv file to avi with WinAvi, extracted the subtitles with mkvtoolnix-unicode-1.7.0, and they were .ssa, i think, and then convert them from ssa to srt with SubtitleWorkshop251.

    Ok so mkv file part 2 is done. Part 1 is where im having trouble getting the subtitles extracted. I had no problem converting from mkv to avi with winavi. Whenever I try to extract the subtitles with mkvtoolnix-unicode-1.7.0 from mkv file part 1 it only goes up to 28% and it says, Extraction done, on bottom left corner, and a window pops up saying, Files demux sucessfully! but of course that is not the case as it only goes to 28% and says its done.

    Anyone else have any other programs that extract subtitles from mkv files that I could try. It worked on part 2 and don't know why it wont work on part 1.

    When I play the mkv file in media player classic, there are no errors. The mkv file part 1 plays fine, all the way thru with subtitles. So dont know what the problem is.

    thanks,
    Quote Quote  
  2. VH Wanderer Ai Haibara's Avatar
    Join Date
    Jan 2006
    Location
    Somewhere on VideoHelp...
    Search Comp PM
    Try to determine exactly what program you're using to extract the subtitles. mkvtoolnix, for example, is currently at version 4.9.1.

    MKVExtractGUI-2 (with the latest version of mkvtoolnix installed to the same folder as MKVExtractGUI-2) should work.
    If cameras add ten pounds, why would people want to eat them?
    Quote Quote  
  3. Member
    Join Date
    Apr 2009
    Location
    United States
    Search Comp PM
    Thank you, looks like I had version 1. something lol. With version 4.9.1. like you said, it worked.

    thanks,
    Quote Quote  



Similar Threads