VideoHelp Forum
+ Reply to Thread
Results 1 to 7 of 7
Thread
  1. Member
    Join Date: Mar 2010
    Location: Berlin
    Search PM
    Hi

    ACDSee, XnView, DOpus Viewer, GraphStudio - they all display videos pixelated. It seems they use the default renderer of Windows 7 x64, GraphEdit tells me it is "VMR Input0".

    Players like VLC, PotPlayer/KMPlayer, MPC-HC and Browsers like Firefox don't show videos pixelated - they seem to use EVR.

    I'm a noob and I don't know if really the renderer causes the pixelation, but it's really annoying. I forced the Viewers to use ffdshow but it did not help, possible because ffdshow is no renderer. Now I am looking how I can set the default renderer to EVR, but I don't know if this would be the solution. The same viewers which are displaying videos pixelated, are displaying them antialiased when I disable Windows Aero or check "disable desktop composition" in the compatibility settings of the executable (f.e. acdsee.exe).

    That's how videos looks for example in GraphStudio and ACDSee:
    Name:  SS-2010-10-29_22.35.45.png
Views: 1766
Size:  133.1 KB

    Do you have ideas how I could fix the pixelation for the viewers without deactivating Aero?

    System: Windows 7 x64, Geforce GTX 460, 8GB Ram, Intel Q6600 @2,4Ghz
    Last edited by klischee; 29th Oct 2010 at 15:42.
    Quote Quote  
  2. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    no, the renderer is application dependent - each one needs to be adjusted separately within each program

    it's unlikely that the renderer is the cause for pixellation

    if you provide more info on the sources you are looking at maybe the real reason can be determined

    EDIT: ok i didn't see your screenshot. I assumed you meant macroblocking when you said "pixellation". The choice of renderer can cause that, when different upsampling algorithms are used, also if you are resizing (e.g. fullscreen) , then resizing algorithm as well comes into play
    Quote Quote  
  3. Member
    Join Date: Mar 2010
    Location: Berlin
    Search PM
    Thanks for trying helping me (again )

    What do you mean with "sources"?

    I have the problem since I switched from XP to 7. It happens with all formats Windows is able to play - XviD, WMV, MPEG-2... the lower the resolution, or the higher the zooming, the higher the pixelation grade.

    Graphedit shows the following:
    example.mpg --> MPEG-I Stream Splitter --> MPEG Video Decoder --> Video Renderer
    example.avi --> AVI Splitter --> Mpeg4s Decoder DMO --> Video Renderer
    example.wmv --> WMVideo Decoder DMO --> Video Renderer

    The question could be: Why are videos not pixelated when Aero is deactivated?

    Oh, forgot to say, Windows Media Player shows videos antialiased/smooth, also with Aero activated.
    Last edited by klischee; 29th Oct 2010 at 15:46.
    Quote Quote  
  4. Member
    Join Date: Sep 2007
    Location: Canada
    Search Comp PM
    I mean what kind of file , but if it occurs with all types of videos , then it's a system wide issue

    If it looks ok with your web browser and video players, then I wouldn't worry too much...
    Quote Quote  
  5. Member
    Join Date: Mar 2010
    Location: Berlin
    Search PM
    Yes, video players like KMP or MPC-HC are displaying videos antialiased, but it would be a big advantage for the workflow when ACDSee and the integrated player of my file browser would display videos without that pixelation. I need the player of the viewer because of direct database handling issues - I can't tag, flag, rate, delete, rename and do other things in external players (or, if I would, I could loose database connection entries).

    Sadly, I got no support at the ACDSee Forums, and there are only a few threads in the web about this problem (but I am not the only one having it).
    Quote Quote  
  6. Your problem is quite common. And yes, it's the video renderer causing it (along with some bugs in the graphics card's driver, I believe). Some players let you explicitly select the renderer. For example, in MPCHC it's: View -> Options -> Playback -> Output -> DirectShow Video... In VLC it's: Tools -> Preferences -> Video -> Display -> Output...
    Quote Quote  
  7. Member
    Join Date: Mar 2010
    Location: Berlin
    Search PM
    Yeah.. but what to do when the Player don't let configurize the renderer?
    Is there a trick?

    It sucks to disable Aero
    Quote Quote  



Similar Threads