VideoHelp Forum
+ Reply to Thread
Results 1 to 14 of 14
Thread
  1. Hi I am trying to convert MP4 to avi video but no audio at the end, it happens that when I open a video in the ffmpegX pressing the preview button and play the video played without sound as the exporters do not have audio, I'm a system with version ffmpegX 0.0.9y MACOSX

    xvid avi
    mencoder xvid, 320x176, 379 kbps, 29.97 fps, no crop
    mp3, 48000 Hz, 128 kbps

    out there think it's some problem with the playback and import the video into another apalicacion called avidemux2 audio options in the selecting the local option downmixing and audio playback device if it works but I can not encode the video there
    thank you very much for your help.
    Quote Quote  
  2. Member
    Join Date: Nov 2006
    Location: United States
    Search Comp PM
    You might try selecting "Invert Map" (options tab?) or using an option that utilizes ffmpeg instead of mencoder.
    Quote Quote  
  3. Member
    Join Date: Nov 2010
    Location: USA
    Search Comp PM
    Aha! That did it for me! Thanks a bunch!
    Quote Quote  
  4. Member
    Join Date: Nov 2006
    Location: United States
    Search Comp PM
    Cool! Are you the same person as PabloFX or someone new? Just curious...
    Also - what was it, the invert map, or using ffmpeg that did it for you?

    Glad it worked out!
    Quote Quote  
  5. Member
    Join Date: Nov 2010
    Location: USA
    Search Comp PM
    Well, both...last week the ffmpeg option fixed it for me; but then, this week I was getting no audio again. It seems that if I toggle back and forth between Invert Mapping on and off, the audio comes through now.
    Quote Quote  
  6. Member
    Join Date: Nov 2006
    Location: United States
    Search Comp PM
    Awesome! Glad it's all working for you.
    Quote Quote  
  7. Member
    Join Date: Dec 2010
    Location: London
    Search Comp PM
    Hi. I have the same problem. It does not seem to matter what form the video is in but if the audio is aac, then the converted (to avi) is silent. This happens with mov and mp4. I have tried all the suggestions given (toggle Invert Mapping, use an option using FFMPEG).
    Please help.
    Quote Quote  
  8. Explorer Case's Avatar
    Join Date: Feb 2004
    Location: Middle Earth
    Search Comp PM
    Originally Posted by dtsrppp View Post
    It does not seem to matter what form the video is in but if the audio is aac, then the converted (to avi) is silent. This happens with mov and mp4.
    Please post the Process Information log, accessible by clicking the blue "i" in the ffmpegX Progress window. That log should provide the necessary information to let us help you.
    Quote Quote  
  9. Member
    Join Date: Dec 2010
    Location: London
    Search Comp PM
    Dear Case
    Many thanks
    Please excuse my late reply but I have been (and continue to be) quite unwell. I did what you said and the result was:
    Process Control
    Encoding started on Tue Feb 1 07:51:53 GMT 2011
    MEncoder dev-CVS-060307-04:23-4.0.1 (C) 2000-2006 MPlayer Team
    Mac OSX static build for ffmpegX
    FIXME:Hardenabling SSE and SSE2 without detection
    CPU: Intel (Family: 6, Stepping: 10)
    CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
    success: format: 0 data: 0x0 - 0x15a6be9b
    ISO: File Type Major Brand: ISO/IEC 14496-1 (MPEG-4 system) v2
    Quicktime/MOV file format detected.
    MOV: selected audio stream (1) does not exists
    VIDEO: [avc1] 480x272 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
    [V] filefmt:7 fourcc:0x31637661 size:480x272 fps:25.00 ftime:=0.0400
    Opening video filter: [expand osd=1]
    Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
    Opening video filter: [scale w=480 h=272]
    ================================================== ========================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
    ================================================== ========================
    Forcing output fourcc to 58564944 [DIVX]
    VDec: vo config request - 480 x 272 (preferred colorspace: Planar YV12)
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is undefined - no prescaling applied.
    SwScaler: using unscaled Planar YV12 -> Planar YV12 special converter
    videocodec: libavcodec (480x272 fourcc=58564944 [DIVX])
    Writing header...
    ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
    Writing header...
    ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.

    Now although this says the audio stream does not exist, the mp4 will play quite happily in Quicktime (with sound)

    I have attached the quicktime window and the ffmegx window if that is any help.

    Many thanks
    Attached Images    
    Quote Quote  
  10. Explorer Case's Avatar
    Join Date: Feb 2004
    Location: Middle Earth
    Search Comp PM
    Originally Posted by dtsrppp View Post
    Encoding started on Tue Feb 1 07:51:53 GMT 2011
    MEncoder dev-CVS-060307-04:23-4.0.1 (C) 2000-2006 MPlayer Team
    ISO: File Type Major Brand: ISO/IEC 14496-1 (MPEG-4 system) v2
    Quicktime/MOV file format detected.
    MOV: selected audio stream (1) does not exists
    There seems to be a bug in the way ffmpegX creates a command for mencoder when processing MP4 files that have the audio stream listed before the video stream. User jvh detailed this in post 1944537. Basically, the command lets mencoder look for audio in the wrong place.

    Unfortunately, editing apps that use QuickTime as an export engine will by default produce files with the audio stream before the video stream, so it is quite common for MOV and MP4 files to be ordered like this.


    However, if you use the ffmpeg engine for conversion (e.g. the "DivX ffmpeg" or "XviD ffmpeg" presets), you can instruct ffmpegX about the stream order by setting "Invert mapping" in the Audio tab. (Note that Invert mapping only works with ffmpeg.)
    Quote Quote  
  11. Member
    Join Date: Dec 2010
    Location: London
    Search Comp PM
    Dear Case

    Thank you for your message. I have tried "Invert Mapping" earlier, but with no results. However do you mean I have to use "Invert Mapping" with the DivX ffmpeg option (see attachment) and that it does not do anything with the DivX mencoder setting. Sorry to be so helpless.

    Many thanks

    dtsrppp
    Attached Images  
    Quote Quote  
  12. Explorer Case's Avatar
    Join Date: Feb 2004
    Location: Middle Earth
    Search Comp PM
    Originally Posted by dtsrppp View Post
    Do you mean I have to use "Invert Mapping" with the DivX ffmpeg option (see attachment) and that it does not do anything with the DivX mencoder setting.
    Yes. The stream mapping is an ffmpeg option, so "Invert mapping" doesn't do anything for mencoder conversions.
    The version of ffmpeg in ffmpegX tries to convert the first stream to video and the second stream to audio, unless instructed otherwise. If the first stream is audio and the second stream is video, then ffmpeg may error as it finds a mismatch in the streams.
    It may seem a bit weird to bother the user with these details, but that's how this version ffmpeg worked when it was compiled. (Later versions of ffmpeg can figure it out better by itself, without user interacting, but ffmpegX can't use those newer versions without the developer making changes to ffmpegX.)

    input ----------- output
    #0.0 video --> #0.0 video
    #0.1 audio --> #0.1 audio
    streams match

    #0.0 audio --> #0.0 video
    #0.1 video --> #0.1 audio
    stream mismatch

    #0.1 video --> #0.0 video
    #0.0 audio --> #0.1 audio
    invert mapping
    Quote Quote  
  13. Member
    Join Date: Dec 2010
    Location: London
    Search Comp PM
    Dear Case

    Many thanks for your message. Just to complicate matters I had a .mov that I wanted to put on my iPod, so I dragged and dropped the .mov . Selected iPod H264 320w (attached). Pressed play - no sound this time (info is attached as well). Should I use invert mapping.? How can I tell which 'to' options are ffmpeg?

    Sorry to be so stupid.

    Regards
    Attached Images    
    Quote Quote  
  14. Explorer Case's Avatar
    Join Date: Feb 2004
    Location: Middle Earth
    Search Comp PM
    Originally Posted by dtsrppp View Post
    Pressed play - no sound this time
    Not to worry. You know the audio is there and is good. The [Play] button invokes mplayer to play the source file. If ffmpegX is not using mplayer to decode the file, then this has no consequences for the conversion.
    The reason mplayer will not let you hear audio has to do with stream order and the way in which ffmpegX tells mplayer what to do. Yes, it's a bug in the software. The mplayer binary can play audio from the same file just fine, when used from the Terminal:
    Code:
    /Library/Application\ Support/ffmpegX/mplayer /Volumes/storage/AlienSong.mov
    Imho, that means mplayer itself is fine.

    Originally Posted by dtsrppp
    How can I tell which 'to' options are ffmpeg?
    Many of the Quick Presets have the encoder engine in their name. E.g. "XviD ffmpeg" uses ffmpeg. After selecting a preset, the Video section of the Target format (right side of the Summary) should have the encoder engine as the first word. E.g. "iPod h.264 320w" may have something like "x264 h264, 320x176, 200 kbps, 23.976 fps, no crop" listed under Video, the first word being "x264", which is the encoder engine. "x264" doesn't care about stream order, it will figure it out by itself.

    What I usually do, is to just try an encode without setting/changing "Invert mapping". If ffmpegX errors immediately, I check the Process Information log (the blue circled "i"). If that log says "Codec mismatch for stream mapping", only then do I set "Invert mapping" and try again. It only takes a few seconds.
    Quote Quote  



Similar Threads