VideoHelp Forum
+ Reply to Thread
Results 1 to 3 of 3
Thread
  1. Member
    Join Date: Aug 2010
    Location: USA
    Search Comp PM
    I've been searching Google for hours trying to figure this out. The farthest I've gotten is to get Windows Media Player 12 to not display an error when I try to play the file. Before it would just play the audio with an error message. Now it still plays the audio, but with a black screen and without the error. Not really much help there though.

    So far, from what I've read, I need to install ffdshow and Haali Media Splitter for WMP to play the video. But it's not working.

    GSpot said that I need the H.264/MPEG-4 AVC video codec to play the file and that's also what the error message from WMP said to get.

    Any suggestions?

    *I would still like to use WMP
    **I'm a real newbie so pleases bare with me :]
    Quote Quote  
  2. Always Watching guns1inger's Avatar
    Join Date: Apr 2004
    Location: Miskatonic U
    Search Comp PM
    G-spot is old and really doesn't do AVC too well. Try mediainfo Tree view instead.

    That said, ffdshow and haali works fine for me, although I prefer The KM Player because WMP has too many other issues. Also, H.264 in an AVI container is a hack. WMP12 plays some MP4 formats, including H.264, natively. It might simply be a matter of repackaging the content into a better container. AVI Demux or Xvid4PSP can do this using copy mode.
    Read my blog here.
    Quote Quote  
  3. Member
    Join Date: Aug 2010
    Location: USA
    Search Comp PM
    Thank you very much^^ Avidemux worked like a charm.
    Quote Quote  



Similar Threads